4. Adım - Makronuzu başkalarıyla paylaşma

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Makroları paylaşmakla ilgili olarak anlaşılması gereken önemli nokta, Office dosyasında depolanması ve dolayısıyla bu dosyayı başkalarıyla paylaşmanız gerektiğidir. Word'de bir makro oluşturduysanız, dosyayı bir Word Makro Etkinleştirilmiş Şablonu (.dotm) veya Word Makro Etkinleştirilmiş Belgesi (.docm) olarak paylaşmanız gerekecektir. Makroyu Excel’de oluşturduysanız, dosyayı Excel Makro Etkin Çalışma Kitabı (.xlsm) veya Excel Makro İçerebilen Şablonu (.xltm) olarak paylaşmanız gerekecektir.

Bir Word makrosu oluşturduysanız, makronuzu paylaşmak için gerçekleştirmeniz gereken fazladan birkaç adım vardır:

Boş Word şablonunu oluşturma

  1. Yeni bir Word belgesi açın.

  2. Dosya menüsünde Farklı Kaydet'e tıklayın.

  3. Dosyanızı global_macros.dotm olarak adlandırın.

  4. Biçim açılır menüsünden, Biçim olarak Word Makro Etkinleştirilmiş Şablonu (*.dotm) seçeneğini belirleyin.

  5. Dosyayı ağınızda depolamak istediğiniz yeri seçin.

  6. Kaydet'e tıklayın ve ardından şablonu kapatın.

Word makrosunu belgenizden dışarı aktarma

1. adımda kaydettiğiniz makro için, sıradaki şu adımları izleyerek makroyu dışarı aktarın:

  1. Dışarı aktarmak istediğiniz makroyu içeren belge veya şablonu açın.

  2. Araçlar menüsünde, Makro seçeneği üzerine gidin ve Makrolar’a tıklayın.

  3. Dışarı aktarmak istediğiniz makroyu seçin ve Düzenle’ye tıklayın. Makro için Dışarı Aktar'ı seçin

  4. Visual Basic Düzenleyicisi'nde, Dosya > Dosyayı Dışarı Aktar öğelerine tıklayın.

  5. Makroyu, global_macros.dotm adlı makro etkinleştirilmiş şablon ile aynı klasöre kaydedin.

Word makrosunu yeni boş şablonunuza aktarma

  1. Global_macros.dotm dosyasını açın ve sonra Araçlar > Makro > Visual Basic Düzenleyicisi’ne tıklayın.

  2. Makroyu içeri aktarmak için, Dosya > Dosyayı İçeri Aktar’a tıklayın, makronuzu aktardığınız klasöre gidin, dosyayı seçip ’a tıklayın.

  3. Modülü kaydedin, Visual Basic Düzenleyicisi'nden çıkın ve sonra da Word’den çıkın.

Şimdi makroyu başkalarıyla paylaşabilir ve makroyu bilgisayarlarına yüklemek için aşağıdaki adımları izlemelerini söyleyebilirsiniz.

Şablonu yükleme: Word'ü makronuz kullanmak üzere ayarlama

  1. Global_macro.dotm dosyasını şu konuma yerleştirin:

    • Mac için Word 2011: Macintosh HD: Kullanıcılar: Kullanıcı adı: Kitaplık: Uygulama Desteği: Microsoft: Office: Kullanıcı Şablonları: Şablonlarım

    • Windows’daki Word 2003 veya sonraki sürümleri: C:\Documents and Settings\Kullanıcıadı\Application Data\Microsoft\Word\STARTUP

      Not :  Kullanıcı adı, bir kullanıcının oturum açma adıdır.

  2. Word’de, Word > Tercihler…’e tıklayın.

Word Tercihleri'ni

  1. Kişisel Ayarlar bölümünde Dosya Konumları’na tıklayın. 

  2. Dosya konumları listesinden Başlangıç’ı seçin ve sonra Değiştir…’e tıklayın.

Dosya Konumu

  1. Word’ün, global_macro.dotm dosyasını yerleştirdiğiniz klasörü Başlangıç klasörü olarak kullandığını doğrulayın.

  2. Seç’e tıklayarak Bir klasör seçin iletişim kutusunu kapatın ve sonra Dosya Konumları iletişim kutusunu kapatmak için Tamam’a tıklayın.

Son adımınız, başladığında Word’e global_macros.dotm dosyasını kullanmasını söylemektir.

  1. Word’de, Araçlar > Şablonlar ve Eklentiler…’e tıklayın.

  2. Listeden global_macros.dotm dosyasını işaretleyin ve Tamam’a tıklayın.

    İpucu :  Şablonunuzu listede görmüyorsanız, global_macros.dotm dosyanız Word başlangıç klasöründe değildir. Bu bölümdeki 1. adıma dönün ve Başlangıç klasörünün, global_macros.dotm dosyasını kaydettiğiniz klasörle aynı klasör olduğunu doğrulayın.

Word'de genel şablonu ayarlama

 1. Adım - Makro Kaydedici ile Çalışmaya Başlama

2. Adım - Kodu Okuma ve Anlama

3. Adım - Programlamanın Esaslarını Kavrama

4. Adım - Makronuzu Başkalarıyla Paylaşma

5. Adım - Gerçek Dünyadan Örnekler

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×