#YOK hatasını düzeltme

#YOK hatası genel olarak, formülün aranan öğeyi bulamadığını gösterir.

En iyi çözüm

#YOK hatasının en yaygın nedeni, DÜŞEYARA; YATAYARA, ARA veya KAÇINCI işlevlerinde formülün başvurulan değeri bulamamasıdır. Örneğin, arama değeriniz kaynak veriler arasında yer almıyordur.

Arama değeri yoktur.  E2 hücresindeki formül =DÜŞEYARA(D2,$D$6:$E$8,2,YANLIŞ) formülüdür.  Banana değeri bulunamadığından, formül #YOK hatası döndürür.
Kaynak verilerde öğe bulunamadı

Bu örnekte, arama tablosunda listelenen bir “Banana” girişi yoktur, dolayısıyla DÜŞEYARA işlevi #YOK hatasını döndürür.

Çözüm: Arama değerinin kaynak verilerde yer aldığından emin olun veya formülde EĞERHATA gibi bir hata işleyici kullanın. Örneğin, =EĞERHATA(FORMÜL(),0), anlamı:

  • =EĞER(formülünüz hesaplandığında hata oluşursa 0 görüntüle, aksi takdirde formülün sonucunu görüntüle)

Hiçbir şey görüntülenmemesi için “” kullanabilir veya kendi metninizi koyabilirsiniz: =EĞERHATA(FORMÜL(),”Burada Hata İletisi var”)

Bu noktada ne yapmanız gerektiğinden veya ne tür bir yardıma ihtiyacınız olduğundan emin değilseniz, Excel Topluluk Forumu'nda benzer sorular için arama yapabilir veya kendi forumlarınızdan birine gönderebilirsiniz.

Excel Topluluk Forumu'nun bağlantısı

İlerlemek istiyorsanız, aşağıdaki denetim listesinde formüllerinizde neyin yanlış olabileceğini bulmanız için sorun giderme adımları sağlanır.

Arama değeri ve kaynak veriler birbirinden farklı veri türlerinde. Örneğin, DÜŞEYARA’nın bir sayıya başvurmasını istediğiniz ama veri kaynağı metin olarak depolanmış.

Yanlış değer türleri.  Aranan öğenin sayı olarak, ancak arama tablosunun metin olarak biçimlendirilmesi nedeniyle #YOK hatası döndüren DÜŞEYARA formülü örneği.
Farklı veri türlerinin neden olduğu #YOK hatası

Çözüm: Veri türlerinin aynı olmasına dikkat edin. Hücreyi veya hücre aralığını seçip sağ tıklayarak ve Hücreleri Biçimlendir > Sayı’yı seçerek (veya Ctrl+1 tuşlarına basarak), hücre biçimlerini denetleyebilir ve gerekirse sayı biçimini değiştirebilirsiniz.

Sayı sekmesinin gösterildiği ve Metin seçeneğinin belirtildiği Hücreleri Biçimlendir iletişim kutusu

İpucu : Sütunun tamamında biçim değişikliğini zorunlu tutmanız gerekiyorsa, önce istediğiniz biçimi uygulayın ve ardından Veri > Metni Sütunlara Dönüştür > Son’u kullanın.

Baştaki veya sondaki boşlukları kaldırmak için KIRP işlevini kullanabilirsiniz. Aşağıdaki örnekte, A2:A7 hücrelerindeki adların başında yer alan boşlukları kaldırmak ve bölüm adını döndürmek için, DÜŞEYARA işlevinin içinde KIRP işlevi kullanılır.

Baştaki/sondaki boşlukları kaldırmak için Dizi formülünde DÜŞEYARA’yı KIRP işleviyle kullanma.  E3 hücresindeki formül {=DÜŞEYARA(D2,KIRP(A2:B7),2,YANLIŞ)} formülüdür ve CTRL+SHIFT+ENTER tuşlarıyla girilmesi gerekir.

{=DÜŞEYARA(D2,KIRP(A2:B7),2,YANLIŞ)}

Not : Bu bir dizi formülüdür ve Ctrl+Shift+Enter ile girilmelidir. Excel formülü sizin için otomatik olarak küme ayracı {} içine alır. Bunları kendiniz girmeye çalışırsanız, Excel formülü metin olarak görüntüler.

Varsayılan olarak, işlevlerin bilgileri aradığı tablolarda artan düzende sıralanmalıdır. Bununla birlikte, DÜŞEYARA ve YATAYARA çalışma sayfası işlevlerinde tablo sıralanmamış bile olsa işleve tam eşleşmeyi bulmasını söyleyen bir aralık_bak bağımsız değişkeni vardır. Tam eşleşmeyi bulmak için, aralık_bak bağımsız değişkenini YANLIŞ olarak ayarlayın. İşleve yaklaşık eşleşme aramasını söyleyen DOĞRU değeri kullanıldığında, sonuçta yalnızca #YOK hatası verilmez, aynı zamanda aşağıdaki örnekte görüldüğü gibi hatalı sonuçlar da döndürülebilir.

DÜŞEYARA formülünün DOĞRU aralık_bak bağımsız değişkeniyle kullanılmasının hatalı sonuçlara neden olduğunu gösteren örnek.
DÜŞEYARA başarısız olur çünkü sıralanmamış bir tabloda yaklaşık eşleşme bağımsız değişkeni kullanılmıştır

Bu örnekte, “Banana” #YOK hatası döndürmekle kalmaz, “Pear” değeri de yanlış fiyatı döndürür. Bunun nedeni, DÜŞEYARA işlevine tam eşleşme yerine yaklaşık eşleşmeyi aramasını söyleyen DOĞRU bağımsız değişkeninin kullanılmasıdır. “Banana” değerinin yakın eşleşmesi yoktur ve “Pear” sözcüğü de alfabetik olarak “Peach” sözcüğünden önce gelir. Bu durumda, DÜŞEYARA işlevini YANLIŞ bağımsız değişkeniyle kullanmak “Pear” için doğru fiyatı döndürebilir, ama “Banana” yine #YOK hatası verir çünkü bakılan listede “Banana” yoktur.

KAÇINCI işlevini kullanıyorsanız, tablonun sıralama düzenini belirtmek için eşleştir_tür bağımsız değişkeninin değerini değiştirmeyi deneyin. Tam eşleşme bulmak için eşleştir_tür bağımsız değişkenini 0 (sıfır) olarak ayarlayın.

Bunu düzeltmek için dizi formülü tarafından başvuruda bulunulan aralığın dizi formülünün girildiği hücrelerin aralığıyla aynı satır veya sütun sayısına sahip olduğundan emin olun veya formüldeki aralık başvurusunu eşleştirmek için dizi formülünü daha az veya daha çok hücreye girin.

Bu örnekte, E2 hücresi eşleşmeyen aralıklara başvurmuştur:

Eşleşmeyen aralık başvurularının #YOK hatasına neden olduğu dizi formülü örneği.  E2 hücresindeki formül {=TOPLA(EĞER(A2:A11=D2,B2:B5))} formülüdür ve CTRL+SHIFT+ENTER tuşlarıyla girilmesi gerekir.

{=TOPLA(EĞER(A2:A11=D2,B2:B5))}

Formülün doğru hesaplanması için, her iki aralığın da 2 - 11 arası satırları yansıtmasını sağlayacak şekilde düzeltilmesi gerekir.

{=TOPLA(EĞER(A2:A11=D2,B2:B11))}

Not : Bu bir dizi formülüdür ve Ctrl+Shift+Enter ile girilmelidir. Excel formülü sizin için otomatik olarak küme ayracı {} içine alır. Bunları kendiniz girmeye çalışırsanız, Excel formülü metin olarak görüntüler.

Hücrelere #YOK girilmesinin TOPLA formülünün düzgün hesaplanmasını engellediğini gösteren örnek.

Bu örnekte Mayıs-Aralık arasında #YOK değerleri vardır, dolayısıyla Toplam hesaplanamaz ve #YOK hatası döndürülür.

Bu hatayı düzeltmek için kullanmakta olduğunuz işlevin formül söz dizimini denetleyin ve gerekli tüm bağımsız değişkenleri hatayı döndüren formüle girin. Bunun için Visual Basic Düzenleyicisi’ne (VBE) gidip işlevi denetlemeniz gerekebilir. VBE’ye Geliştirici sekmesinden veya ALT+F11 tuşlarına basarak erişebilirsiniz.

Bu hatayı düzeltmek için kullanıcı tanımlı işlevi içeren çalışma kitabının açık olduğundan ve söz konusu işlevin düzgün çalıştığından emin olun.

Bu hatayı düzeltmek için işlevdeki bağımsız değişkenlerin doğru olduğundan ve doğru konumda kullanıldığından emin olun.

Bunu düzeltmek için, Ctrl+Atl+F9 tuşlarına basarak sayfayı yeniden hesaplayın

Doğru bağımsız değişkenleri tam olarak bilmiyorsanız, yardımcı olması için İşlev Sihirbazı’nı kullanabilirsiniz. Söz konusu formülün bulunduğu hücreyi seçin, Şeritte Formül sekmesine gidin ve İşlev Ekle’ye basın.

İşlev Ekle düğmesi.

Excel, sizin için Sihirbazı otomatik olarak yükler.

Formül Sihirbazı iletişim kutusu örneği.

Bağımsız değişkenlere tıkladığınızda, Excel size her biri için uygun bilgileri verir.

#YOK hatası yararlı olabilir! Grafiklerde aşağıdaki örnektekine benzer veriler kullanıldığında #YOK hatasını kullanmak yaygın bir uygulamadır, çünkü #YOK değerleri grafiğe çizilmez. Burada, #YOK yerine 0 içeren bir grafiğin nasıl göründüğünü gösteren bir örnek verilmiştir.

0 değerlerinin çizildiği Çizgi Grafik örneği.

Önceki örnekte, 0 değerlerinin çizildiğini, grafiğin altında düz çizgi olarak görüntülendiğini ve sonra Toplam’ı göstermek üzere aniden yükseldiğini görebilirsiniz. Aşağıdaki örnekte, 0 değerleri #YOK ile değiştirilmiştir.

#YOK değerlerinin çizilmediği Çizgi Grafik örneği.

#YOK hatasının belirli bir işlevde görünmesiyle ilgili daha fazla bilgi için aşağıdaki konulara bakın:

Sayfanın başı

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Metin olarak depolanan sayıları numaralara dönüştürme

DÜŞEYARA işlevi

YATAYARA işlevi

ARA işlevi

KAÇINCI işlevi

Excel’de formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Windows için Excel'de klavye kısayolları

Mac için Excel'de klavye kısayolları

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×