#BAŞV! hatasını düzeltme

#BAŞV! hatasını düzeltme

Formül geçerli olmayan bir hücreye başvurduğunda #BAŞV! hatası gösterilir. Bu çoğunlukla formülün başvurduğu hücrelerin silinmesi veya üzerlerine başka bir şey yapıştırılması durumunda olur.

Örnek - Sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği

Aşağıdaki örnek, E sütununda =TOPLA(B2,C2,D2) formülünü kullanır.

=TOPLA(B2,C2,D2) gibi açık hücre başvuruları kullanan formüller, bir sütunun silinmesi durumunda #BAŞV! hatası verebilir.

B, C veya D sütununu silmeniz #BAŞV! hatasına neden olur. Bu örnekte C sütununu (2007 Satışları) siliyoruz ve şimdi formül =TOPLA(B2,#BAŞV!,C2) oluyor. Bunun gibi açık hücre başvuruları kullanır (birbirinden virgülle ayrılmış olarak her hücreye tek tek başvurarak) ve başvurulan bir satır veya sütunu silerseniz, Excel bunu çözemez ve dolayısıyla #BAŞV! hatası döndürür. İşlevlerde açık hücre başvuruları kullanımının önerilmemesinin birincil nedeni budur.

Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

  • Satır veya sütunları yanlışlıkla sildiyseniz, hemen Hızlı Erişim Araç Çubuğu'nda Geri Al düğmesine tıklayarak (veya CTRL+Z tuşlarına basarak) bunları geri yükleyebilirsiniz.

  • Formülü, tek tek hücreler yerine bir aralık başvurusu (=TOPLA(B2:D2) gibi) kullanacak şekilde ayarlayın. Şimdi toplama aralığının içindeki herhangi bir sütunu silebilirsiniz ve Excel formülü otomatik olarak ayarlar. Ayrıca, satırların toplamı için =TOPLA(B2:B5) formülünü de kullanabilirsiniz.

Örnek - Yanlış aralık başvuruları olan DÜŞEYARA

Aşağıdaki örnekte, =DÜŞEYARA(A8,A2:D5,5,YANLIŞ) formülü #BAŞV! hatası döndürür çünkü döndürmek üzere 5. sütunda bir değer arar ancak hücre başvurusu A:D'dir yani yalnızca 4 sütundur.

Yanlış aralık içeren bir DÜŞEYARA formülü örneği.  Formül =DÜŞEYARA(A8,A2:D5,5,YANLIŞ)  DÜŞEYARA formülünde beşinci sütun olmadığı için 5 #BAŞV! hatası verir.

Çözüm

Aralığı daha büyük olacak şekilde ayarlayın veya sütun arama değerini başvuru aralığıyla eşleşecek şekilde küçültün. =DÜŞEYARA(A8,A2:E5,5,YANLIŞ) ve =DÜŞEYARA(A8,A2:D5,4,YANLIŞ) geçerli başvuru aralıkları olabilir.

Örnek - Yanlış satır veya sütun başvurusu olan İNDİS

Bu örnekte, =İNDİS(B2:E5,5,5) formülü #BAŞV! hatası döndürür çünkü İNDİS aralığı 4 satıra 4 sütundur ama formül döndürmek üzere 5. satır ve 5. sütundaki değeri arar.

Geçersiz aralık başvurusu içeren bir İNDİS formülü örneği.  Formül =İNDİS(B2:E5,5,5) ancak aralık yalnızca 4 satıra 4 sütundur.

Çözüm

Satır ve sütun başvurularını İNDİS arama aralığı içinde kalacak şekilde ayarlayın. =İNDİS(B2:E5,4,4) formülü geçerli bir sonuç döndürebilir.

Örnek – DOLAYLI işleviyle kapalı bir çalışma kitabına başvurma

Aşağıdaki örnekte, DOLAYLI işlevi kapalı olan bir çalışma kitabına başvurmayı denediğinden #BAŞV! hatasına neden olur.

Kapalı bir çalışma kitabına yapılan DOLAYLI başvuru nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

Başvurulan çalışma kitabını açın

OLE/DDE Sorunları

#BAŞV! hatası döndüren bir Nesne Bağlama ve Ekleme (OLE) bağlantısı kullandıysanız, bağlantının çağırdığı programı başlatın.

Not: OLE, programlar arasında bilgi paylaşmak için kullanabileceğiniz bir teknolojidir.

#BAŞV! hatası döndüren bir Dinamik Veri Değişimi (DDE) konusu kullandıysanız, doğru konuya başvurduğunuzdan emin olun.

Not: DDE, Microsoft Windows tabanlı programlar arasında veri alışverişine yönelik yerleşik bir protokoldür.

Makro Sorunları

Makro, çalışma sayfasına bir işlev girerse, bu işlev girildiği konumun yukarısındaki bir hücreye başvuruyorsa ve işlevi içeren hücre 1. satırdaysa, 1. satırın üstünde hiçbir hücre olmadığından söz konusu işlev #BAŞV! hatasını döndürecektir. İşlevi denetleyip bir bağımsız değişkenin geçerli olmayan bir hücreye veya hücre aralığına başvurup başvurmadığına bakın. Makroyu, Visual Basic Düzenleyicisi'nde (VBE) bu durumu hesaba katacak şekilde düzenlemeniz gerekebilir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×