#BAŞV! hatasını düzeltme

#BAŞV! hatasını düzeltme

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

#REF! ne zaman bir formül geçerli olmayan bir hücreye başvuran hata gösterir. Formüller tarafından başvurulan hücreleri silinmiş veya üzerinden yapıştırılan en sık olur.

Örnek - Sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği

Aşağıdaki örnek, E sütununda =TOPLA(B2,C2,D2) formülünü kullanır.

=TOPLA(B2,C2,D2) gibi açık hücre başvuruları kullanan formüller, bir sütunun silinmesi durumunda #BAŞV! hatası verebilir.

B sütunu silmek için yazacaksanız, C veya D #REF neden! bir hata oluştu. Bu durumda biz C sütunu silersiniz (2007 satışları) ve formülü şimdi =SUM(B2,#REF!,C2)okur. Açık hücre başvuruları şöyle kullandığınızda (her hücreye tek tek başvuran yerlerde, virgülle ayrılmış) ve başvurulan satır veya sütun silmek için Excel yapamazsınız çözme, dolayısıyla #REF döndürür! bir hata oluştu. Neden açık hücre başvuruları işlevlerini kullanarak önerilmez temel nedeni budur.

Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

  • Satır veya sütunları yanlışlıkla sildiyseniz, hemen Hızlı Erişim Araç Çubuğu'nda Geri Al düğmesine tıklayarak (veya CTRL+Z tuşlarına basarak) bunları geri yükleyebilirsiniz.

  • Formülü =SUM(B2:D2)gibi tek tek hücrelere yerine bir aralığa başvuru kullanır şekilde ayarlayın. Şimdi Topla aralık içinde herhangi bir sütunu silmek ve Excel formül otomatik olarak ayarlanır. Bir satır toplamı için =SUM(B2:B5) de kullanabilirsiniz.

Örnek - Yanlış aralık başvuruları olan DÜŞEYARA

Aşağıdaki örnekte, =DÜŞEYARA(A8,A2:D5,5,YANLIŞ) formülü #BAŞV! hatası döndürür çünkü döndürmek üzere 5. sütunda bir değer arar ancak hücre başvurusu A:D'dir yani yalnızca 4 sütundur.

Yanlış aralık içeren bir DÜŞEYARA formülü örneği.  Formül =DÜŞEYARA(A8,A2:D5,5,YANLIŞ)  DÜŞEYARA formülünde beşinci sütun olmadığı için 5 #BAŞV! hatası verir.

Çözüm

Daha büyük olması için aralığı ayarlayın veya başvuru aralık eşleştirmek için sütun arama değerini azaltın. =vlookup(a8,a2:e5,5,false) yaptığınız gibi geçerli bir başvuru aralığı, olacak VLOOKUP(A8,A2:D5,4,FALSE) =.

Örnek - Yanlış satır veya sütun başvurusu olan İNDİS

Bu örnekte, =İNDİS(B2:E5,5,5) formülü #BAŞV! hatası döndürür çünkü İNDİS aralığı 4 satıra 4 sütundur ama formül döndürmek üzere 5. satır ve 5. sütundaki değeri arar.

Geçersiz aralık başvurusu içeren bir İNDİS formülü örneği.  Formül =İNDİS(B2:E5,5,5) ancak aralık yalnızca 4 satıra 4 sütundur.

Çözüm

Dizin arama aralık içinde bulunmaları satır veya sütun başvuruları ayarlayın. Geçerli sonucu =Index(B2:E5,4,4) döndürür.

Örnek – DOLAYLI işleviyle kapalı bir çalışma kitabına başvurma

Aşağıdaki örnekte, DOLAYLI işlevi kapalı olan bir çalışma kitabına başvurmayı denediğinden #BAŞV! hatasına neden olur.

Kapalı bir çalışma kitabına yapılan DOLAYLI başvuru nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

Başvurulan çalışma kitabını açın

OLE sorunları

#BAŞV! hatası döndüren bir Nesne Bağlama ve Ekleme (OLE) bağlantısı kullandıysanız, bağlantının çağırdığı programı başlatın.

Not: OLE, programlar arasında bilgi paylaşmak için kullanabileceğiniz bir teknolojidir.

DDE sorunları

Bir #REF döndüren bir dinamik veri değişimi (DDE) konusunu kullandıysanız! hata, ilk denetleyin doğru konu başvuran emin olun. Bir #REF almaya devam varsa! hata, dış içerik, Güven Merkezi Ayarları Seviyelendirilmiş içinde onay engelleme veya engelini kaldırma Office belgelerinde dış içeriği.

Not: Dinamik veri değişimi (DDE)Microsoft Windows tabanlı programları arasında veri değişimi için önceden oluşturulmuş bir protokolü olur.

Makro Sorunları

Makro İşlevi yukarıda hücreye başvuruyorsa çalışma sayfasındaki bir işlev giren ve işlevi içeren hücrenin satır 1 ise, işlevi #REF verip vermeyeceğini! Satır 1 yukarıda hiçbir hücre olduğundan. İşlev bağımsız değişken bir hücre veya geçerli olmayan hücre aralığına başvuruyorsa görmek için denetleyin. Bu makroyu içinde Visual Basic Düzenleyicisi'ni (söz konusu durum dikkate almak için VBE) düzenleme gerektirebilir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×