İNDİS işlevi

İNDİS işlevi, tablo veya aralığın içindeki bir değeri veya değerin başvurusunu döndürür.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

İNDİS işlevini kullanmanın iki yolu vardır:

  • Belirli bir hücre veya hücre dizisinin değerini döndürmek için Dizi biçimi konusuna bakın.

  • Belirli hücrelere başvuru döndürmek istiyorsanız Başvuru formu konusuna bakın.

Dizi biçimi

Açıklama

Satır ve sütun numarası dizinlerinin seçildiği bir tablodaki veya dizideki öğenin değerini verir.

İNDİS işlevinin birinci bağımsız değişkeni bir dizi sabitiyse, dizi biçimini kullanın.

Söz dizimi

İNDİS(dizi, satır_sayısı, [sütun_sayısı])

INDIS işlevinin dizi biçimi aşağıdaki bağımsız değişkenlere sahiptir:

  • dizi Gerekli. Bir hücre aralığı veya dizi sabitidir.

    • Dizi yalnızca tek bir satır veya sütun içeriyorsa, ilgili satır_sayısı veya sütun_sayısı bağımsız değişkeni isteğe bağlıdır.

    • Dizide birden fazla satır ve birden fazla sütun varsa, INDIS işlevi dizideki tüm satır veya sütunun dizisini döndürür.

  • satır_sayısı    Gerekli. Dizinin içinden değeri verilecek satırı seçer. Satır_sayısı belirtilmezse, sütun_sayısı gereklidir.

  • sütun_sayısı    İsteğe bağlı. Dizinin içinden değeri verilecek sütunu seçer. Sütun_sayısı belirtilmezse, satır_sayısı gereklidir.

Notlar

  • Satır_sayısı ve Sütun_sayısı bağımsız değişkenlerinin ikisi de kullanılırsa INDIS işlevi, satır_sayısı ve Sütun_sayısı.

  • satır_sayısı ve Sütun_sayısı dizideki bir hücreyi göstermelidir; Aksi takdirde, INDIS #REF! hatasıyla sonuçlanır.

  • Satır_sayısı veya sütun_sayısı 'yi 0 (sıfır) olarak ayarlarsanız, INDIS işlevi, sırasıyla tüm sütun veya satırın değer dizisini verir. Dizi olarak döndürülen değerleri kullanmak için, INDIS işlevini dizi formülü olarak girin.

    Not: Office 365' in güncel bir sürümünü kullanıyorsanız, formülü, formülü bir dinamik dizi formülü olarak onaylamak için ENTER tuşuna basın. Aksi takdirde, formülün önce çıkış aralığını seçerek eski bir dizi formülü olarak girilmesi gerekir, formülü çıktı aralığının sol üst hücresine girer ve ardından CTRL + SHIFT + enter tuşlarına basarak onaylayın. Excel, formülün başında ve sonunda süslü ayraçlar ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Örnekler

Örnek 1

Bu örneklerde, bir satır ve sütunun buluştuğu kesişen hücredeki değeri bulmak için İNDİS işlevi kullanılmaktadır.

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2 tuşuna ve sonra da Enter tuşuna basın.

Veri

Veriler

Elma

Limon

Muz

Armut

Formül

Açıklama

Sonuç

=İNDİS(A2:B3,2,2)

Aralıktaki ikinci satırın ve ikinci sütunun kesişimindeki değer A2:B3.

Armutlar

=İNDİS(A2:B3,2,1)

Aralıktaki ikinci satırın ve birinci sütunun kesişimindeki değer A2:B3.

Muzlar

Örnek 2

Bu örnekte, 2x2 dizisinde belirtilen iki hücredeki değerleri bulmak için bir dizi formülü içinde İNDİS işlevi kullanılmaktadır.  

Not: Office 365' in güncel bir sürümünü kullanıyorsanız, formülü, formülü bir dinamik dizi formülü olarak onaylamak için ENTER tuşuna basın. Aksi takdirde, formülün ilk kez iki boş hücre seçilerek eski bir dizi formülü olarak girilmesi gerekir, formülü çıktı aralığının sol üst hücresine girin ve CTRL + SHIFT + enter tuşlarına basarak onaylayın. Excel, formülün başında ve sonunda süslü ayraçlar ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Formül

Açıklama

Sonuç

=İNDİS({1,2;3,4},0,2)

Dizide ilk satırdaki ikinci sütunda bulunan değer. Dizi; ilk satırda 1 ve 2'yi, ikinci satırda 3 ve 4'ü içerir.

2

İkinci satırda bulunan değeri ikinci sütundaki bir dizi (yukarıdaki gibi aynı dizi).

4

Sayfanın Başı


Başvuru formu

Açıklama

Belirli bir satır ve sütunun kesişimindeki hücrenin başvurusunu verir. Başvuru bitişik olmayan seçimlerden yapılırsa, bakılacak seçimi seçebilirsiniz.

Söz dizimi

İNDİS(başvuru, satır_sayısı, [sütun_sayısı], [alan_sayısı])

INDIS işlevinin başvuru biçimi aşağıdaki bağımsız değişkenlere sahiptir:

  • başvuru    Gerekli. Bir ya da daha fazla hücre aralığına bir başvurudur.

    • Başvuru için bitişik olmayan bir Aralık giriyorsanız, başvuruyu ayraç içine alın.

    • Başvurudaki her alan yalnızca bir satır veya sütun içeriyorsa, satır_sayısı veya sütun_sayısı bağımsız değişkeni isteğe bağlıdır. Örneğin, tek bir satır başvurusu için, İNDİS(başv; sütun_sayısı) işlevini kullanın.

  • satır_sayısı    Gerekli. İçinden bir başvuru verilecek olan başvurudaki satırın sayısıdır.

  • sütun_sayısı    İsteğe bağlı. İçinden bir başvuru verilecek olan başvurudaki sütunun sayısıdır.

  • alan_sayısı    İsteğe bağlı. Satır_sayısı ve Sütun_sayısı ile kesişimini döndürmek için, başvurudaki bir aralığı seçer. Seçilen ya da girilen ilk alana 1 numarası verilir, ikinci alan 2 olur, vb. Alan_sayısı atlanırsa, INDIS alanı 1 kullanılır.  Burada listelenen alanların tümü tek sayfada yer almalıdır.  Hepsi aynı sayfada olmayan alanlar belirtirseniz, bu durum #DEĞER! hatasının döndürülmesine neden olur.  Birbirinden farklı sayfalarda yer alan aralıklar kullanmanız gerekiyorsa, İNDİS işlevinin dizi biçimini kullanmanız ve diziyi oluşturan aralığı hesaplamak için başka bir işlevi kullanmanız önerilir.  Örneğin, hangi aralığın kullanılacağını hesaplamak için ELEMAN işlevini kullanabilirsiniz.

Örneğin, başvuru hücreleri tanımlar (a1: B4, D1: E4, G1: H4); alan_sayısı 1 Aralık: D1: E4 ve alan_sayısı 3 ise G1: H4 aralığıdır.

Açıklamalar

  • Başvuru ve alan_sayısı belirli bir aralığı seçtikten sonra, satır_sayısı ve Sütun_sayısı belirli bir hücre seçer: satır_sayısı 1 aralığın ilk satırı, sütun_sayısı 1 ilk sütundur vb. INDIS tarafından döndürülen başvuru satır_sayısı ve Sütun_sayısı 'ın kesişimi.

  • Satır_sayısı veya sütun_sayısı 'yi 0 (sıfır) olarak ayarlarsanız, INDIS işlevi, sırasıyla tüm sütun veya satırın başvurusunu verir.

  • Satır_sayısı, sütun_sayısı ve alan_sayısı başvuru içindeki bir hücreyi göstermelidir; Aksi takdirde, INDIS #REF! hatasıyla sonuçlanır. Satır_sayısı ve Sütun_sayısı belirtilmezse, INDIS işlevi, alan_sayısı ile belirtilen başvurudaki alanı verir.

  • İNDİS işlevinin sonucu bir başvurudur ve başka formüller tarafından başvuru olarak yorumlanır. Formüle bağlı olarak, İNDİS işlevinin sonuç değeri bir başvuru ya da bir değer olarak kullanılabilir. Örneğin, HÜCRE("en";İNDİS(A1:B2;1;2)) formülü, HÜCRE("en";B1) formülünün eşdeğeridir. HÜCRE işlevi, İNDİS işlevinin sonuç değerini bir hücre başvurusu olarak kullanır. Öte yandan, 2*İNDİS(A1:B2;1;2) gibi bir formül İNDİS işlevinin sonuç değerini B1 hücresindeki sayıya çevirir.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın.

Meyve

Fiyat

Sayı

Elma

0,69 TL

40

Muz

0,34 TL

38

Limon

0,55 TL

15

Portakal

0,25 TL

56

Armut

0,59 TL

40

Badem

2,80 TL

10

Mahun

3,55 TL

geliştir

Fıstık

1,25 TL

20

Ceviz

1,75 TL

12

Formül

Açıklama

Sonuç

=İNDİS(A2:C6, 2, 3)

A2:C6 aralığında, ikinci sıranın ve üçüncü sütunun C3 hücresinin içeriğini oluşturan kesişimi.

38

=İNDİS((A1:C6, A8:C11), 2, 2, 2)

A8:C11'in ikinci alanında, ikinci satır ve ikinci sütunun B9 hücresinin içeriğini oluşturan kesişimi.

1,25

=TOPLA(İNDİS(A1:C11, 0, 3, 1))

A1:C11 aralığının birinci alanındaki üçüncü sütunun C1:C11'nın toplamına karşılık gelen toplamı.

216

=TOPLA(B2:İNDİS(A2:C6, 5, 2))

B2'de başlayan ve A2:A6 aralığının beşinci sırasının ve ikinci sütununun kesişiminde sona eren aralığın B2:B6'nın toplamına karşılık gelen toplamı.

2,42

Sayfanın Başı

Ayrıca Bkz:

DÜŞEYARA işlevi

KAÇINCI işlevi

DOLAYLI işlevi

Dizi formülleriyle ilgili yönergeler ve örnekler

Arama ve başvuru işlevleri (başvuru)

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×