İNDİS işlevi

İNDİS işlevi, tablo veya aralığın içindeki bir değeri veya değerin başvurusunu döndürür.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

DİZİN işlevini kullanmanın iki yolu vardır:

  • Belirli bir hücre veya hücre dizisinin değerini döndürmek için Dizi biçimi konusuna bakın.

  • Belirli hücrelere başvuru döndürmek istiyorsanız Başvuru formu konusuna bakın.

Dizi biçimi

Açıklama

Tabloda veya dizi bulunan öğenin değerini, satır ve sütun numarası indisleriyle seçerek verir.

İNDİS işlevinin birinci bağımsız değişkeni bir dizi sabitiyse, dizi biçimini kullanın.

Söz dizimi

İNDİS(dizi, satır_sayısı, [sütun_sayısı])

İNDİS işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur.

  • Dizi    Gerekli. Bir hücre aralığı veya dizi sabitidir.

    • Dizi yalnızca tek bir satır veya sütun içeriyorsa, ilgili Satır_sayısı veya Sütun_sayısı bağımsız değişkeni isteğe bağlıdır.

    • Dizinin birden çok satırı ve birden çok sütunu varsa ve yalnızca Satır_sayısı veya Sütun_sayısı'ndan biri kullanılırsa, İNDİS işlevi dizideki tüm satır veya sütuna ilişkin bir dizi verir.

  • Satır_sayısı    Gerekli. Dizinin içinden değeri verilecek satırı seçer. Satır_sayısı belirtilmezse, Sütun_sayısı gerekir.

  • Sütun_sayısı    İsteğe bağlı. Dizinin içinden değeri verilecek sütunu seçer. Sütun_sayısı belirtilmezse, Satır_sayısı gerekir.

Notlar

  • Satır_sayısı ve Sütun_sayısı bağımsız değişkenlerinin ikisi de kullanılırsa İNDİS işlevi, Satır_sayısı ve Sütun_sayısı bağımsız değişkenlerinin kesişimindeki hücrenin değerini verir.

  • Satır_sayısı veya Sütun_sayısı'nı 0 (sıfır) olarak belirtirseniz, İNDİS sırasıyla tüm sütuna veya satıra ilişkin değerlerin dizisini verir. Dizi sonucu verecek değerlerin kullanılması için, İNDİS işlevi bir sıra için yatay hücreler aralığında veya bir sütun için dikey hücreler aralığında dizi formülü olarak girilmelidir. Bir dizi formülünü girmek için, CTRL+ÜST KARAKTER+ENTER'a basın.

    Not:  Excel Web App'ta dizi formülü oluşturamazsınız.

  • Satır_sayısı ve Sütun_sayısı dizideki bir hücreyi göstermelidir, tersi durumda, İNDİS işlevi #BAŞV! hata değeri verir.

Örnekler

Örnek 1

Bu örneklerde, bir satır ve sütunun buluştuğu kesişen hücredeki değeri bulmak için İNDİS işlevi kullanılmaktadır.

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Veri

Veriler

Elma

Limon

Muz

Armut

Formül

Açıklama

Sonuç

=İNDİS(A2:B3,2,2)

Aralıktaki ikinci satırın ve ikinci sütunun kesişimindeki değer A2:B3.

Armutlar

=İNDİS(A2:B3,2,1)

Aralıktaki ikinci satırın ve birinci sütunun kesişimindeki değer A2:B3.

Muzlar

Örnek 2

Bu örnekte, 2x2 dizisinde belirtilen iki hücredeki değerleri bulmak için bir dizi formülü içinde İNDİS işlevi kullanılmaktadır.

Bu durumda A1:A2 gibi herhangi iki dikey hücreyi seçin, ilk hücreye =INDEX({1,2;3,4},0,2) formülünü yapıştırın ve CTRL+SHIFT+ENTER tuşlarına basın. Dizi formülü olarak girildiğinde, Excel otomatik olarak formülü ikinci hücreye yapıştıracak.

Formül

Açıklama

Sonuç

=İNDİS({1,2;3,4},0,2)

Dizide ilk satırdaki ikinci sütunda bulunan değer. Dizi; ilk satırda 1 ve 2'yi, ikinci satırda 3 ve 4'ü içerir.

2

İkinci satırda bulunan değeri ikinci sütundaki bir dizi (yukarıdaki gibi aynı dizi).

4

Not: Bu bir dizi formülüdür ve CTRL+SHIFT+ENTER ile girilmelidir. Excel formülü otomatik olarak küme ayracı {} içine alır. Bunları kendiniz girmeye çalışırsanız Excel formülü metin olarak görüntüler. CTRL+SHIFT+ENTER kullanmazsanız formül, #DEĞER! hatası döndürür.

Sayfanın Başı

Başvuru biçimi

Açıklama

Belirli bir satır ve sütunun kesişimindeki hücrenin başvurusunu verir. Başvuru bitişik olmayan seçimlerden oluşuyorsa, araştırılacak olan seçimi alabilirsiniz.

Söz dizimi

İNDİS(başvuru, satır_sayısı, [sütun_sayısı], [alan_sayısı])

İNDİS işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur.

  • Başv    Gerekli. Bir ya da daha fazla hücre aralığına bir başvurudur.

    • Başv için bitişik olmayan bir aralık giriyorsanız, başvuruyu ayraç içine alın.

    • Başv'daki her alan yalnızca bir satır ya da sütun içeriyorsa, Satır_sayısı ya da Sütun_sayısı bağımsız değişkeni isteğe bağlıdır. Örneğin, tek bir satır başvurusu için, İNDİS(başv; sütun_sayısı) işlevini kullanın.

  • Satır_sayısı    Gerekli. İçinden bir başvuru verilecek olan başvurudaki satırın sayısıdır.

  • Sütun_sayısı    İsteğe bağlı. İçinden bir başvuru verilecek olan başvurudaki sütunun sayısıdır.

  • Alan_numarası    İsteğe bağlı. Başvuruda, Satır_sayısı ve Sütun_sayısı’nın kesişiminin döndürüleceği bir aralık seçer. Seçilen ya da girilen ilk alana 1 numarası verilir, ikinci alan 2 olur, vb. Alan_numarası belirtilmezse, İNDİS 1. alanı kullanır.  Burada listelenen alanların tümünün tek bir sayfada bulunması gerekir.  Birbiriyle aynı sayfada olmayan alanlar belirtirseniz #DEĞER! hatası oluşur.  Birbirinden farklı sayfalarda yer alan aralıklar kullanmanız gerekiyorsa, İNDİS işlevinin dizi biçimini kullanmanız ve diziyi oluşturan aralığı hesaplamak için başka bir işlev kullanmanız önerilir.  Örneğin, hangi aralığın kullanılacağını hesaplamak için ELEMAN işlevini kullanabilirsiniz.

Örneğin, Başv (A1:B4;D1:E4;G1:H4) hücrelerini tanımlıyorsa, Alan_sayısı 1, A1:B4 aralığı, Alan_sayısı 2, D1:E4 aralığı ve Alan_sayısı 3, G1:H4 aralığıdır.

Notlar

  • Başv ve Alan_sayısı belirli bir aralığı seçtikten sonra, Satır_sayısı ve Sütun_sayısı belirli bir hücre seçer: Satır_sayısı 1 aralıktaki ilk satırdır, Sütun_sayısı 1 ilk sütundur vb. İNDİS işlevinin verdiği başvuru Satır_sayısı ve Sütun_sayısının kesişimidir.

  • Satır_sayısı ya da Sütun_sayısını 0'a ayarlarsanız, İNDİS işlevi, sırasıyla, tüm sütun ya da tüm satırın başvurusunu verir.

  • Satır_sayısı, Sütun_sayısı ve Alan_sayısı başvuru içindeki bir hücreye işaret etmelidir; aksi halde, İNDİS işlevi #BAŞV! hata değeri verir. Satır_sayısı ve Sütun_sayısı belirtilmezse, İNDİS işlevi, Alan_sayısı ile belirtilen başvurudaki alanı verir.

  • İNDİS işlevinin sonucu bir başvurudur ve başka formüller tarafından başvuru olarak yorumlanır. Formüle bağlı olarak, İNDİS işlevinin sonuç değeri bir başvuru ya da bir değer olarak kullanılabilir. Örneğin, HÜCRE("en";İNDİS(A1:B2;1;2)) formülü, HÜCRE("en";B1) formülünün eşdeğeridir. HÜCRE işlevi, İNDİS işlevinin sonuç değerini bir hücre başvurusu olarak kullanır. Öte yandan, 2*İNDİS(A1:B2;1;2) gibi bir formül İNDİS işlevinin sonuç değerini B1 hücresindeki sayıya çevirir.

Not:  HÜCRE işlevi Excel Web App'ta kullanılamaz.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Meyve

Fiyat

Sayı

Elma

0,69 TL

40

Muz

0,34 TL

38

Limon

0,55 TL

15

Portakal

0,25 TL

25

Armut

0,59 TL

40

Badem

2,80 TL

10

Mahun

3,55 TL

16

Fıstık

1,25 TL

20

Ceviz

1,75 TL

12

Formül

Açıklama

Sonuç

=İNDİS(A2:C6, 2, 3)

A2:C6 aralığında, ikinci sıranın ve üçüncü sütunun C3 hücresinin içeriğini oluşturan kesişimi.

38

=İNDİS((A1:C6, A8:C11), 2, 2, 2)

A8:C11'in ikinci alanında, ikinci satır ve ikinci sütunun B9 hücresinin içeriğini oluşturan kesişimi.

1,25

=TOPLA(İNDİS(A1:C11, 0, 3, 1))

A1:C11 aralığının birinci alanındaki üçüncü sütunun C1:C11'nın toplamına karşılık gelen toplamı.

216

=TOPLA(B2:İNDİS(A2:C6, 5, 2))

B2'de başlayan ve A2:A6 aralığının beşinci sırasının ve ikinci sütununun kesişiminde sona eren aralığın B2:B6'nın toplamına karşılık gelen toplamı.

2,42

Sayfanın Başı

Ayrıca Bkz:

DÜŞEYARA işlevi

KAÇINCI işlevi

DOLAYLI işlevi

Dizi formülleriyle ilgili yönergeler ve örnekler

Arama ve başvuru işlevleri (başvuru)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×