İNDİS/KAÇINCI işlevlerindeki #DEĞER! hatasını düzeltme

Bu konu başlığı altında, formülde DİZİN ve KAÇINCI işlevlerini birlikte kullandığınızda #DEĞER! hatasıyla karşılaştığınız en yaygın senaryolar açıklanır. İNDİS ve KAÇINCI işlevlerinin bileşimini kullanmanın en yaygın nedenlerinden biri, DÜŞEYARA işlevinin çalışmadığı bir senaryoda bir değeri aramak istemenizdir (örneğin, aranan değeriniz 255 karakterden uzun olabilir).

Sorun: Formül bir dizi olarak girilmedi

Bir değeri alabilmek için İNDİS işlevini KAÇINCI işleviyle birlikte bir dizi formülü olarak kullanıyorsanız, formülünüzü dizi formülüne dönüştürmeniz gerekir. Aksi takdirde #DEĞER! hatasını görürsünüz.

Çözüm: İNDİS ve KAÇINCI bir dizi formülü olarak kullanılmalıdır ve bu da CTRL+SHIFT+ENTER tuşlarına basmanız gerektiği anlamına gelir. Bu şekilde formül otomatik olarak küme ayracı {} içine alınır. Bunları kendiniz girmeye çalışırsanız, Excel formülü metin olarak görüntüler.

DİZİN/KAÇINCI işlevlerini kullanıyorsanız ve arama değeriniz 255 karakterden uzunsa, bunun bir Dizi formülü olarak girilmesi gerekir.  F3 hücresindeki formül =İNDİS(B2:B4,KAÇINCI(DOĞRU,A2:A4=F2,0),0) formülüdür ve Ctrl+Shift+Enter tuşlarına basılarak girilir
İNDİS ve KAÇINCI, dizi formülü olarak kullanılmalıdır

Belirli bir işlev sorunuz mu var?

Excel topluluk forumuna bir soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

İNDİS işlevi

KAÇINCI işlevi

DÜŞEYARA, DİZİN veya KAÇINCI ile aranan değerler

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×