İşlevi bir işlev ile iç içe geçirme

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Bir işlev kullanarak formül oluşturduğunuzda, işlevleri diğer işlevler içine yerleştirebilirsiniz. Bunu yaptığınızda, iç içe geçen işlevler sonuçlarınısbağımsız değişkenolarak kullanmakta olduğunuz — ilk işleve düzgün çalışması için gereken veri parçalarını. Her zaman, parantez içinde olduğundan ne zaman bir işlev yuvalanmışsa anlayabilirsiniz.

Burada bir örnek verilmiştir. EĞER işlevi bağımsız değişken olarak içe içe geçirilmiş ORTALAMA ve TOPLAM işlevlerini kullanır.

=EĞER(ORTALAMA2:F5)>50,TOPLA(G2:G5),0)

Bu formülü soldan sağa doğru okuyabilirsiniz. F2 - F5 hücrelerinin ortalama değeri 50'den büyük ise, G2 - G5 hücrelerindeki değer toplanır. Aksi takdirde 0 döndürülür.

En fazla 64 işlev düzeyini iç içe geçirebilirsiniz ve onları diğer işlevler gibi girersiniz:

  1. Formülü içerecek hücreyi tıklatın.

  2. Formül çubuğuna formülü girin ve Enter tuşuna basın.

Burada da başka bir örnek verilmiştir. Bu, gelir düzeyine göre kesintileri hesaplamak için bir EĞER işlevini başka bir EĞER işlevi içine yerleştirir.

=EĞER(A5<31500,A5*15%,EĞER(A5<72500,A5*25%,A5*28%))

Bu örneği de soldan sağa doğru okuyabilirsiniz. A5 hücresindeki değer 31.500'den az ise, değer %15 ile çarpılır. Ancak değilse, değerin 72.500'den az olup olmadığını kontrol edin. Öyle ise, %25 ile çarpılır, aksi takdirde %28 ile çarpılır.

Gelir düzeylerinde virgül kullanılmadığını unutmayın. Kullanılırsa, EĞER işlevi onları bağımsız değişken olarak kullanmaya çalışır ve formül bozulur.

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×