İç içe formülü adım adım hesaplama

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

Birkaç ara hesaplamalarda ve mantıksal sınamalar olduğundan bazen, bir iç içe formül nihai sonucu nasıl hesapladığını anlamak zordur. Bununla birlikte, Formül Değerlendir iletişim kutusunu kullanarak formülü hesaplanır sırayla bir iç içe formülün farklı bölümlerini görebilirsiniz. Örneğin, formül =Eğer(ortalama(F2:F5) > 50,SUM(G2:G5),0) aşağıdaki Ara sonuçları ne zaman görebilirsiniz anlamanız daha kolay:

İletişim kutusunda gösterilen adımlar

Açıklama

=EĞER(ORTALAMA2:F5)>50,TOPLA(G2:G5),0)

Başlangıçta iç içe formül görüntülenir. ORTALAMA işlevi ve TOPLA işlevi, EĞER işlevinin içine yerleştirilmiştir.

=EĞER(40>50,TOPLA(G2:G5),0)

F2: F5 hücre aralığı 55, 35, 45 ve 25 değerlerini içerir ve dolayısıyla ortalama(F2:F5) işlevinin sonucu 40'tır.

=EĞER(Yanlış,TOPLA(G2:G5),0)

40 50'den büyük olmadığından ilk bağımsız değişkenindeki ifade (mantıksal_sınama bağımsız değişkeni) Eğer işlevinin false'tur.

0

Eğer işlevini üçüncü bağımsız değişken (eğer_yanlışsa_değer bağımsız değişkeni) değerini verir. TOPLA işlevi (eğer_doğruysa_değer bağımsız değişkeni) Eğer işlevinin ikinci bağımsız değişkeni olduğundan ve yalnızca ifade doğru olduğunda döndürülür değerlendirilmez.

  1. Hesaplamak istediğiniz hücreyi seçin. Bir kerede tek bir hücre hesaplanabilir.

  2. Formüller sekmesinin Formül Denetimi grubunda, Formül Değerlendir'e tıklayın.

    Formüller sekmesinde Formül Denetim grubu

  3. Altı çizili başvurunun değerini incelemek için Değerlendir’e tıklayın. Değerlendirme sonucu italik yazıyla gösterilir.

    Formülün altı çizili bölümü başka bir formüle başvuruysa Değerlendirme kutusundaki başka diğer formülü görüntülemek için İçeri Adımla’ya tıklayın. Önceki hücre ve formüle geri dönmek için Dışarı Adımla’ya tıklayın.

    Not: Başvuru formülde ikinci kez görünüyorsa ya da formül başka bir çalışma kitabındaki hücreye başvuruyorsa, başvuru için İçeri Adımla düğmesi sağlanmaz.

  4. Formülün tüm kısımları hesaplanana kadar devam edin.

  5. Hesaplamayı yeniden görmek için, Yeniden Başlat'a tıklayın.

    Hesaplamayı sona erdirmek için Kapat'a tıklayın.

    Notlar: 

    • Eğer ve eleman işlevlerini kullanan formüllerin bazı kısımları değerlendirilmez ve Değerlendirme kutusunda #yok görüntülenir.

    • Başvuru boşsa, Değerlendirme kutusunda sıfır değeri (0) görüntülenir.

    • Döngüsel başvurular içeren formüller beklendiği gibi değerlendirme değil. Döngüsel başvurular istenirse, yinelemeli hesaplamayı etkinleştirkaldırabilirsiniz.

    • Aşağıdaki işlevler yeniden hesaplanır her çalışma değiştiğinde ve Formülü Değerlendir aracı hücrede gösterilenden farklı sonuçlar vermesine neden olabilir: S_SAYI_ÜRET, Kaydır, hücre, dolaylı, şimdi, bugün, RASTGELEARADA, bilgi ve ETOPLA (bazılarında Senaryo).

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×