İç içe formülü adım adım hesaplama

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Bazı durumlarda, iç içe bir formülün sonucu nasıl hesapladığını anlamak zor olabilir çünkü bazı ara hesaplamalar ve mantıksal sınamalar vardır. Bununla birlikte, Formülü Değerlendir iletişim kutusunu kullanarak iç içe formülün farklı bölümlerinin formülde hangi sırayla hesaplandığını görebilirsiniz. Örneğin, aşağıdaki ara sonuçları görebildiğinizde =EĞER(ORTALAMA(F2:F5)>50,TOPLA(G2:G5),0) formülünü daha kolay anlayabilirsiniz:

İletişim kutusunda gösterilen adımlar

Açıklama

=EĞER(ORTALAMA2:F5)>50,TOPLA(G2:G5),0)

Başlangıçta iç içe formül görüntülenir. ORTALAMA işlevi ve TOPLA işlevi, EĞER işlevinin içine yerleştirilmiştir.

=EĞER(40>50,TOPLA(G2:G5),0)

F2:F5 hücre aralığı 55, 35, 45, ve 25 değerlerini içerir, dolayısıyla ORTALAMA(F2:F5) işlevinin sonucu 40'tır.

=EĞER(Yanlış,TOPLA(G2:G5),0)

40 50'den büyük olmadığından ilk bağımsız değişkenindeki ifade (mantıksal_sınama bağımsız değişkeni) Eğer işlevinin false'tur.

0

Eğer işlevini üçüncü bağımsız değişken (eğer_yanlışsa_değer bağımsız değişkeni) değerini verir. TOPLA işlevi (eğer_doğruysa_değer bağımsız değişkeni) Eğer işlevinin ikinci bağımsız değişkeni olduğundan ve yalnızca ifade doğru olduğunda döndürülür değerlendirilmez.

  1. Hesaplamak istediğiniz hücreyi seçin. Bir kerede tek bir hücre hesaplanabilir.

  2. Formüller sekmesinin Formül Denetimi grubunda, Formül Değerlendir'e tıklayın.

    The Formula Auditing group on the Formulas tab

  3. Altı çizili başvurunun değerini incelemek için Değerlendir’e tıklayın. Değerlendirme sonucu italik yazıyla gösterilir.

    Formülün altı çizili bölümü başka bir formüle başvuruysa Değerlendirme kutusundaki başka diğer formülü görüntülemek için İçeri Adımla’ya tıklayın. Önceki hücre ve formüle geri dönmek için Dışarı Adımla’ya tıklayın.

    Not : Başvuru formülde ikinci kez görünüyorsa ya da formül başka bir çalışma kitabındaki hücreye başvuruyorsa, başvuru için İçeri Adımla düğmesi sağlanmaz.

  4. Formülün tüm kısımları hesaplanana kadar devam edin.

  5. Hesaplamayı yeniden görmek için, Yeniden Başlat'a tıklayın.

    Hesaplamayı sona erdirmek için Kapat'a tıklayın.

    Notlar : 

    • Eğer ve eleman işlevlerini kullanan formüllerin bazı kısımları değerlendirilmez ve Değerlendirme kutusunda #yok görüntülenir.

    • Başvuru boşsa, Değerlendirme kutusunda sıfır değeri (0) görüntülenir.

    • Aşağıdaki işlevler yeniden hesaplanır her çalışma değiştiğinde ve Formülü Değerlendir hücrede gösterilenden farklı sonuçlar vermesine neden olabilir: S_SAYI_ÜRET, ALANSAY, dizin, Kaydır, hücre, dolaylı, satırlar, sütunlar, şimdi, bugün, RASTGELEARADA.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×