İç içe formülü adım adım hesaplama

Bazı durumlarda, iç içe bir formülün sonucu nasıl hesapladığını anlamak zor olabilir çünkü bazı ara hesaplamalar ve mantıksal sınamalar vardır. Bununla birlikte, Formülü Değerlendir iletişim kutusunu kullanarak iç içe formülün farklı bölümlerinin formülde hangi sırayla hesaplandığını görebilirsiniz. Örneğin, aşağıdaki ara sonuçları görebileceğiniz zaman = Eğer (ortalama (F2: F5) >50, SUM (G2: G5), 0) formülü daha da anlaşılır:

İletişim kutusunda gösterilen adımlar

Açıklama

=EĞER(ORTALAMA2:F5)>50,TOPLA(G2:G5),0)

Başlangıçta iç içe formül görüntülenir. ORTALAMA işlevi ve TOPLA işlevi, EĞER işlevinin içine yerleştirilmiştir.

=EĞER(40>50,TOPLA(G2:G5),0)

F2:F5 hücre aralığı 55, 35, 45, ve 25 değerlerini içerir, dolayısıyla ORTALAMA(F2:F5) işlevinin sonucu 40'tır.

=EĞER(Yanlış,TOPLA(G2:G5),0)

40, 50 'den büyük olmadığından, Eğer işlevinin ilk bağımsız değişkenindeki ifade (mantıksal_sınama bağımsız değişkeni) yanlış 'tır.

0

EĞER işlevi üçüncü bağımsız değişkenin (eğer_yanlışsa_değer bağımsız değişkeni) değerini döndürür. TOPLA işlevi değerlendirilmez çünkü eğer işlevinin ikinci bağımsız değişkeni (eğerk_değer bağımsız değişkeni) ve yalnızca ifade doğru olduğunda döndürülür.

  1. Hesaplamak istediğiniz hücreyi seçin. Bir kerede tek bir hücre hesaplanabilir.

  2. Formüller sekmesinin Formül Denetimi grubunda, Formül Değerlendir'e tıklayın.

    Formüller sekmesinde Formül Denetim grubu

  3. Altı çizili başvurunun değerini incelemek için Değerlendir’e tıklayın. Değerlendirme sonucu italik yazıyla gösterilir.

    Formülün altı çizili bölümü başka bir formüle başvuruysa Değerlendirme kutusundaki başka diğer formülü görüntülemek için İçeri Adımla’ya tıklayın. Önceki hücre ve formüle geri dönmek için Dışarı Adımla’ya tıklayın.

    Not: Başvuru formülde ikinci kez görünüyorsa ya da formül başka bir çalışma kitabındaki hücreye başvuruyorsa, başvuru için İçeri Adımla düğmesi sağlanmaz.

  4. Formülün tüm kısımları hesaplanana kadar devam edin.

  5. Hesaplamayı yeniden görmek için, Yeniden Başlat'a tıklayın.

    Hesaplamayı sona erdirmek için Kapat'a tıklayın.

    Notlar: 

    • Eğer ve CHOOSE işlevlerini kullanan formüllerin bazı bölümleri değerlendirilmez ve #N/A değerlendirme kutusunda görüntülenir.

    • Başvuru boşsa, Değerlendirme kutusunda sıfır değeri (0) görüntülenir.

    • Döngüsel başvuruları olan formüller beklendiği gibi değerlendirilmeyebilir. Döngüsel başvurular isteniyorsa, yinelemeli hesaplamayı etkinleştirebilirsiniz.

    • Aşağıdaki işlevler, çalışma sayfası her değiştiğinde yeniden hesaplanır ve Formül değerlendir aracının hücrede göründüklerden farklı sonuçlar vermesine neden olabılır: S_SAYı_ÜRET, kaydır, hücre, dolaylı, ŞIMDI, bugün, RASGELEARADA, BILGI ve ETOPLA (bazılarında) senaryolar).

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Ayrıca Bkz:

Bozuk formülleri önleme

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×