Örtük kesişim işleci: @

Örtük kesişim operatörü, Excel 'in formül diline önemli yükseltmenin dinamik dizileridesteklemesi için önemli yükseltmenin bir parçası olarak sunulmuştur. Dinamik diziler, Excel 'e önemli ölçüde yeni hesaplama özelliği ve işlevselliği getirir.

Yükseltilen formül dili

Excel 'in yükseltilmiş formül dili, eski dilin yerini belirtmek için @ işlecini kullandığından, eski dil bunu sessizce yaparken, hemen eski dille aynıdır. Sonuç olarak, bazı formüllerde bazı formüllerde açıldığında @ işareti görebilirsiniz. Formüllerinizin her zaman sahip olduğu şekilde hesaplamaya devam etmelerigerektiğini unutmayın.  

Örtük kesişim nedir?

Örtük kesişim mantığı tek bir değere birçok değer küçültür. Excel bunu bir formülün tek bir değer döndürmesini zorunlu tutar; çünkü bir hücre yalnızca tek bir değer içerebilir. Formülünüz tek bir değer döndürmüyse, örtük kesişim hiçbir şey olmadı (Bu da teknik olarak arka planda yapılmış olsa bile). Mantık aşağıdaki gibi çalışır:

  • Değer tek bir öğsem öğeyi iade edin.

  • Değer bir aralıktır, sonra da formülün bulunduğu aynı satırdaki veya sütundaki değeri döndürün.

  • Değer bir diziyse, sol üst değeri seçin.

Dinamik dizileri kullanarak, Excel artık formüllerden tek değerler döndürmeyle sınırlı değildir, bu nedenle sessiz örtük kesişim artık gerekli değildir. Eski bir formül örtük kesişmeyle ilgili olarak tetiklenebilir, dinamik dizi etkinleştirilmiş Excel, @.  

Neden @ simgesi? 

@ Simgesi, tablo başvurularında örtülü kesişmesi belirtmek için zaten kullanılır. Tabloda aşağıdaki formülü düşünün = [@Column1]. Burada @ formülün, [Sütun1] ' dan aynı satırdaki değeri almak için örtük kesişim kullanacağını gösterir.  

@ Öğesini kaldırabilir misiniz? 

Genellikle yapabilirsiniz. Bu, formülün sağındaki formülün ne olduğuna bağlıdır: 

  • Tek bir değer döndürürse (en yaygın durum), @ işareti kaldırılarak hiçbir değişiklik olmayacaktır.

  • Bir Aralık veya dizi döndürürse, @ kaldırıldığında komşu hücrelere taşmaolmaz.

Otomatik olarak eklenmiş bir @ ve daha sonrasını kaldırırsanız çalışma kitabını Excel 'in önceki bir sürümünde açarsanız,eski bir dizi formülü (kaşlı ayraçlar {}) olarak görünecektir

@ Öğesini eski formüllere ne zaman eklerim? 

Genellikle, çok hücreli aralıkları veya dizileri döndüren işlevler, önceki Excel sürümlerinde yazıldıklarında, @ ile eklenir. Formülünüz gibi bir değişiklik olmadığına dikkat etmek önemlidir; şimdi yalnızca önceden görünmez bir kesişme noktasını görebilirsiniz. Çok hücreli aralıklar döndüren yaygın işlevler DIZIN, uzaklık ve Kullanıcı tanımlı Işlevler (UDF 'ler) içerir.  Yaygın bir istisna, dizi veya aralığı kabul eden bir işlevde (örneğin, topla () veya ortalama ()) kaydırılmışlardır. 

Daha fazla ayrıntı için Aralık veya dizi döndüren Excel işlevlerine bakın.

Örnekler

Özgün formül

Dinamik dizi Excel 'de göründüğü gibi 

Açıklama

=TOPLA(A1:A10) 

=TOPLA(A1:A10) 

Hayır, topla işlevi aralıkları veya dizileri beklediği için hiçbir örtük kesişim oluşmaz. 

=A1+A2 

=A1+A2 

Değişiklik yok-örtük kesişim oluşmaz. 

= A1: A10 

= @A1: A10 

Örtük kesişim gerçekleşir ve Excel formülün bulunduğu satırla ilişkili değeri döndürür.

= DIZIN (A1: A10, B1) 

= @INDEX (A1: A10, B1) 

Örtük kesişim gerçekleşebilir. İndis işlevi , ikinci veya üçüncü bağımsız değişkeni 0 olduğunda bir dizi veya Aralık döndürebilir.  

= OFFSET (A1: A2, 1, 1) 

= @OFFSET (A1: A2, 1, 1) 

Örtük kesişim gerçekleşebilir. Kaydır işlevi , çok hücreli bir Aralık döndürebilir. Bunu yaparken örtük kesişim tetiklenir. 

= MYUDF () 

= @MYUDF () 

Örtük kesişim gerçekleşebilir. Kullanıcı tanımlı işlevler dizi döndürebilir. Bunu yaparken, özgün formül örtük kesişim tetikleyecektir. 

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

FİLTRE işlevi

RASGDİZİ işlevi

SIRALI işlevi

SIRALA işlevi

SIRALAÖLÇÜT işlevi

BENZERSİZ işlevi

Excel’de #SPILL! hataları

Dinamik diziler ve geçmiş dizi davranışı

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×