Çalışma kitabını SharePoint kitaplığında yayımlama

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Microsoft Excel 2013 uygulamasında, bir çalışma kitabını Microsoft SharePoint kitaplığında yayımlayabilirsiniz ve böylece kişiler bilgisayarlarında Excel yüklü olmasına gerek kalmadan çalışma kitabını web tarayıcısında görüntüleyebilir veya düzenleyebilirler. Yayımlama esasında kaydetme ile aynı işlemdir; ancak kişiler çalışma kitabını tarayıcıda açtıklarında görebilecekleri öğeleri denetlemenize izin veren bazı yerleşik seçenekler sunar.

Bir çalışma kitabını merkezi bir SharePoint sitesine kaydetme veya yayımlama gibi bir uygulamanın kuruluşunuz çapında benimsenmesi, aynı çalışma kitabının biraz farklı sürümlerinin e-posta ile gönderildiğinde kuruluşunuzun her yanında ortaya çıkmamasını sağlamanıza yardımcı olabilir.

Bazı yayımlama seçeneklerini ayarlayarak, çalışma kitabınızın grafikler gibi belirli bölümlerini vurgulayabilir veya diğer bölümlerinin tarayıcıda görüntülenmesini engelleyebilirsiniz. Örneğin, bir grafiği gösterebilir, ancak temelini oluşturan verileri gizleyebilirsiniz. Ya da görmesi gereken kişilere yalnızca belirli çalışma sayfalarını gösterirken, diğer çalışma sayfalarını gizleyebilirsiniz.

Bu makalede, bir çalışma kitabının Excel 2013 masaüstü programından nasıl yayımlanacağı gösterilmektedir ve çalışma kitabının veya çalışma kitabı verilerinin, SharePoint sayfasındaki bir Excel Web Access Web Bölümüne bağlanması konusuna yer verilmemiştir. Excel Web Access Web Bölümleri hakkında daha fazla bilgi için Excel Web Access Web Bölümü'nü Excel çalışma kitabına bağlama makalesine bakın.

Çalışma kitabını bir SharePoint sitesinde yayımladığınızda tüm çalışma kitabı SharePoint'e kaydedilir. Gerekli SharePoint izinlerine sahip bir kullanıcı gerek tarayıcıda gerekse Excel masaüstü programında tüm çalışma kitabını görüntüleyebilir ve verileriyle çalışabilir.

SharePoint'te Office Online dağıtılırsa, verilerinizin tarayıcıda görüntülenmesi ve üzerinde çalışılması, Excel masaüstü programında verilerinizle çalışmaya çok benzeyebilir. Aslında, Excel masaüstü programından farklı olarak tarayıcı kılavuzunda aynı anda birden fazla kullanıcı çalışma kitabını düzenleyebilir. Çalışma kitabını tarayıcıda görüntülediğinizde Excel Online’te düzenle düğmesi görünüyorsa, Office Online'in kullanılmaya hazır olduğunu anlayabilirsiniz.

Çalışma Kitabını Düzenle menüsünde Excel Online’da Düzenle

Daha fazla bilgi için, Excel ve Excel Hizmetler'de çalışma kitabı kullanma arasındaki farklar makalesine bakın.

Çalışma kitabını hazırlama

Çalışma kitabını yayımlamadan önce, yalnızca tarayıcıda görünmesini istediğiniz çalışma sayfalarını veya öğeleri seçmeyi tercih edebilirsiniz. Bu modda nelerin görüntülenebilir olacağını sınırlayabilseniz de, çalışma kitabının tüm içeriğinin yine de SharePoint sunucusuna kaydedileceğini unutmayın.

Grafikler veya Özet Tablolar gibi diğer öğelere ek olarak çalışma sayfalarının tamamını bir öğe olarak dahil etmek istiyorsanız, çalışma sayfasının tamamını adlandırılmış bir aralık olarak tanımlayın. Çalışma sayfasının tamamını seçin ve sonra adlandırılmış bir aralık tanımlayın. Bu adlandırılmış aralık daha sonra siz yayımlamaya hazır olduğunuzda Yayımlama Seçenekleri iletişim kutusunda kullanılabilir bir öğe olarak görüntülenir.

Kullanıcıların başka bir hücredeki formülle çalışmak için hücreye değer girebilmelerini isterseniz, çalışma kitabını yayımlamadan önce bu hücreyi Excel'de tanımlı bir ad olarak ayarlayın. Daha sonra, Tarayıcı Görünümü Seçenekleri iletişim kutusundaki Parametreler sekmesinde bu tanımlı adı bir parametre olarak ekleyebilirsiniz.

Örneğin, aşağıda tanımlı adı "Oran" olan bir D2 hücresi gösterilmektedir. Tarayıcıda, bir kullanıcı Parametreler bölmesindeki kutuya 5,625 değerini girer ve Uygula'yı tıklatır. Daha sonra bu değer D2 hücresinde görünür ve A2 hücresindeki formül D2'deki değeri kullanır. Formülün sonucu yeniden hesaplanır ve A2 hücresinde 1.151,31$ olarak gösterilir.

Aralıkları tanımlama hakkında bilgi için Excel Yardımı'na bakın.

Bölmeye bir parametre girildiğinde bu değer D2 hücresinde kullanılır

Not : Excel tablosu için dilimleyiciler oluşturur ve tablo ve dilimleyicileri içeren hücre aralığı için bir ad tanımlarsanız, tanımlı aralığı yayımlamanız durumunda tarayıcıda tabloya filtre uygulamak için dilimleyicileri kullanamazsınız. Tabloyu ya da tüm çalışma sayfasını veya çalışma kitabını yayımlarsanız, dilimleyiciler tarayıcıda olması beklendiği gibi çalışır.

Çalışma kitabını yayımlama

  1. Dosya > Farklı Kaydet > SharePoint'i tıklatın.

  2. SharePoint klasörünüzü altında görürsenizgeçerli klasörde veya son klasörler, istediğiniz klasörü tıklatın. Aksi takdirde, Gözat ' ı tıklatın ve SharePoint sitesinin web adresini girin. Ardından, çalışma kitabını yayımlamak istediğiniz klasöre göz atın. Farklı Kaydet iletişim kutusu görüntülenir.

  3. Çalışma kitabından yayımlanacak çalışma sayfalarını veya öğelerini tek tek seçmek için Tarayıcı Görünümü Seçenekleri'ni tıklatın. Bir Göster sekmesi ve bir Parametreler sekmesi göreceksiniz. Tüm çalışma kitabını olduğu gibi yayımlamak istiyorsanız Kaydet'i tıklatın. Aksi takdirde aşağıdakilerden birini yapın:

  • Tarayıcıda çalışma kitabının tamamını göstermek için, Göster sekmesinde, liste kutusundan Tüm Çalışma Kitabı seçimini yapın.

  • Tarayıcıda yalnızca belirli çalışma sayfalarını göstermek için, Göster sekmesinde, liste kutusundan Sayfalar seçimini yapın ve sonra tarayıcıda gizli olmasını istemediğiniz sayfalara ilişkin kutuların işaretini kaldırın.

    Varsayılan olarak tüm sayfalar seçilir. Onay kutularından bazılarının işaretini kaldırdıktan sonra tüm sayfaları kısa sürede yeniden görünür hale getirmek için Tüm Sayfalar onay kutusunu seçin.

  • Tarayıcıda yalnızca belirli öğeleri göstermek için (adlandırılmış aralıklar, grafikler, tablolar veya PivotTable'lar gibi), Göster sekmesinde, liste kutusundan Çalışma Kitabındaki Öğeler seçimini yapın ve sonra göstermek istediğiniz öğelere ilişkin kutuları işaretleyin.

  • Parametreler sekmesinde, kullanıcılar tarayıcıda çalışma kitabını görüntülediğinde düzenlenebilir hücreleri belirtmek için kullanmak istediğiniz tanımlı adları ekleyin. Ardından iletişim kutusunu kapatmak için Tamam'ı tıklatın.

  1. Çalışma kitabını kaydedin.

Notlar : 

  • Aynı ada sahip öğeleri (örn. bir grafik ve temel veri tablosu) seçerseniz, bu öğelerden yalnızca biri tarayıcıda kullanılabilir olur. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir ada sahip olduğundan emin olun.

  • Aynı ada sahip öğeleri (örn. bir grafik ve temel veri tablosu) seçerseniz, bu öğelerden yalnızca biri tarayıcıda kullanılabilir olur. Tüm öğeleri göstermek için, çalışma kitabındaki her öğenin benzersiz bir ada sahip olduğundan emin olun.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

  • Tabloları Tasarım sekmesinin Özellikler grubunda, PivotTable'ları Seçenekler sekmesinin PivotTable grubunda ve grafikleri ya da PivotChart'ları Düzen sekmesinin Özellikler grubunda yeniden adlandırabilirsiniz. Adlandırılmış aralıklar gibi diğer yinelenen öğeler, Formüller sekmesinin Tanımlı Adlar grubunda yeniden adlandırılabilir.

Excel Hizmetleri ve tarayıcıda verilerle çalışma hakkında bilgi edinme

Excel Hizmetleri'nde iş zekası özellikleri

Excel Hizmetleri'nde dış verilerle çalışma

Tarayıcı penceresinde bir çalışma kitabındaki verileri yenileme

Sayfanın Başı

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×