ÇOKETOPLA işlevi

Matematik ve trigonometri işlevlerinden biri olan ÇOKETOPLA işlevi, birden fazla ölçüte uyan tüm bağımsız değişkenlerini toplar. Örneğin, ülkedeki (1) tek bir posta kodunda yer alan ve (2) karları belirli bir dolar değerini aşan satıcı sayısını toplamak için ÇOKETOPLA işlevini kullanırsınız.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Bu video, İleri düzey EĞER işlevleri adlı eğitim kursunun bir bölümüdür.

Söz dizimi

ÇOKETOPLA(toplam_aralığı; ölçüt_aralığı1; ölçüt1; [ölçüt_aralığı2; ölçüt2]; ...)

  • =ÇOKETOPLA(A2:A9,B2:B9,"=A*",C2:C9,"Taner")

  • =ÇOKETOPLA(A2:A9,B2:B9,"<>Muzlar",C2:C9,"Taner")

Bağımsız değişken adı

Açıklama

Toplam_aralığı    (gerekli)

Toplanacak hücre aralığı.

Ölçüt_aralık1    (gerekli)

Ölçüt1 kullanılarak test edilen aralık.

Ölçüt_aralığı1 ve Ölçüt1, belirli ölçütlere göre arama yapılan bir arama çifti ayarlar. Aralıktaki öğeler bulunduktan sonra, Toplam_aralığı içindeki karşılık gelen değerler toplanır.

Ölçüt1    (gerekli)

Ölçüt_aralığı1 içinde hangi hücrelerin toplanacağını tanımlayan ölçüt. Örneğin, ölçüt 32, ">32", B4, "elmalar" veya "32" olarak girilebilir.

Ölçüt_aralığı2, ölçüt2, …    (isteğe bağlı)

Ek aralıklar ve bunların ilişkilendirilmiş ölçütleri. En çok 127 aralık/ölçüt çifti girebilirsiniz.

Örnekler

Bu örnekleri Excel’de kullanmak için tablo içindeki veriyi sürükleyin ve seçin, daha sonra seçime sağ tıklayarak Kopyala’yı seçin. Yeni bir çalışma sayfasında A1 hücresine sağ tıklayın ve Yapıştırma Seçenekleri’nin altında Hedef Biçimlendirmesini Eşleştir’i seçin.

Satılan Miktar

Ürün

Satış Elemanı

5

Elmalar

Taner

4

Elmalar

Aysın

15

Enginar

Taner

3

Enginar

Aysın

22

Muz

Taner

12

Muz

Aysın

10

Havuç

Taner

33

Havuç

Aysın

Formül

Açıklama

=ÇOKETOPLA(A2:A9, B2:B9, "=A*", C2:C9, "Taner")

A ile başlayan ve Taner tarafından satılan ürün sayısını toplar. Ölçüt1, "=A*" içinde * joker karakterini kullanarak, Ölçüt_aralığı1 B2:B9 içinde eşleşen ürün adlarını ve Ölçüt_aralığı2 C2:C9 içinde "Taner" adını arar. Sonra Toplam_aralığı A2:A9 içinde her iki koşulu karşılayan sayıları toplar. Sonuç 20 olur.

=ÇOKETOPLA(A2:A9, B2:B9, "<>;Muz", C2:C9, "Taner")

Muz olmayan ve Taner tarafından satılan ürün sayısını toplar. Ölçüt1, "<>Muz" içinde <> kullanarak muzları hariç tutar ve Ölçüt_aralığı2 C2:C9 içinde "Taner" adını arar. Sonra Toplam_aralığı A2:A9 içinde her iki koşulu karşılayan sayıları toplar. Sonuç 30 olur.

Sık Karşılaşılan Sorunlar

Sorun

Açıklama

Beklenen sonuç yerine 0 (sıfır) gösteriliyor.

Kişi adı gibi metin değerlerini test ediyorsanız, Ölçüt1,2’nin tırnak işaretleri içinde olduğundan emin olun.

Toplam_aralığı DOĞRU veya YANLIŞ değerlerine sahipse sonuç yanlıştır.

Toplam_aralığı için DOĞRU veya YANLIŞ değerleri farklı değerlendirilir ve bunlar toplandığında beklenmedik sonuçlara neden olabilir.

Toplam_aralığı içinde yer alan ve DOĞRU değerini içeren hücreler 1 olarak değerlendirilir. YANLIŞ değerini içeren hücreler 0 (sıfır) olarak değerlendirilir.

En iyi yöntemler

Bunu yapın

Açıklama

Joker karakterler kullanın.

Ölçüt1, 2 içinde soru işareti (?) ve yıldız (*) gibi joker karakterler kullanmak, benzer olup tam olarak aynı olmayan eşleşmeleri bulmanıza yardımcı olabilir.

Soru işareti herhangi bir tek karakterle eşleşir. Yıldız işareti herhangi bir karakter dizisiyle eşleşir. Gerçek bir soru işaretini veya yıldız işaretini bulmak isterseniz, soru işaretinin önüne bir tilde işareti (~) yazın.

Örneğin, =ÇOKETOPLA(A2:A9, B2:B9, "=A*", C2:C9, "Ta?") "Ta" ile başlayan ve son harfi değişebilen adların tüm örneklerini ekler.

ETOPLA ve ÇOKETOPLA arasındaki farkı kavrayın.

Bağımsız değişkenlerin sırası, ETOPLA ve ÇOKETOPLA arasında farklılık gösterir. Özellikle toplam_aralığı bağımsız değişkeni ETOPLA’daki ilk bağımsız değişkendir, ancak ÇOKETOPLA’da üçüncü bağımsız değişkendir. Bu işlevler kullanılırken en yaygın sorunlardan bir budur.

Bu benzer işlevleri kopyalayacak veya düzenleyecekseniz, bağımsız değişkenleri doğru sıraya koyduğunuzdan emin olun.

Aralık bağımsız değişkenleri için aynı sayıda satır ve sütun kullanın.

Ölçüt_aralığı bağımsız değişkeni, Toplam_aralığı bağımsız değişkeniyle aynı sayıda satır ve sütun içermelidir.

Sayfanın Başı

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

ÇOKETOPLA gibi gelişmiş EĞER işlevlerinin kullanımını gösteren bir video izleyin

ETOPLA işlevi yalnızca tek bir ölçüte uyan değerleri toplar

TOPKARE işlevi, değerleri toplamadan önce her değer üzerinde matematiksel karesini alma işlemi yapar

EĞERSAY işlevi yalnızca tek bir ölçüte uyan değerleri sayar

ÇOKEĞERSAY işlevi yalnızca birden fazla ölçüte uyan değerleri sayar

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonrası)

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için hata denetimini kullanma

Matematik ve Trigonometri İşlevleri

Excel işlevleri (alfabetik)

Excel işlevleri (Kategori’ye göre)

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×