Office
Logga in

Utvärdera en kapslad formel ett steg i taget

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Ibland kan är förstå hur en kapslad formel beräknar slutresultatet svårt eftersom det finns flera mellanliggande beräkningar och logiska tester. Med hjälp av dialogrutan Utvärdera formel kan kan du se de olika delarna av en kapslad formel beräknas i den ordning som formeln beräknas. Exempelvis formeln =om(medel(F2:F5) > 50,SUM(G2:G5),0) är enklare att förstå när du ser mellanliggande innebär följande:

Steg som visas i dialogrutan

Beskrivning

=OM(MEDEL(F2:F5)>50,SUMMA(G2:G5);0)

Den kapslade formeln visas först. Funktionerna MEDEL och SUMMA är kapslade i funktionen OM.

=OM(40>50,SUMMA(G2:G5),0)

Cellområdet F2: F5 innehåller värdena 55, 35, 45 och 25 och så resultatet av funktionen medel(F2:F5) är 40.

=OM(Falskt;SUMMA(G2:G5),0)

40 är inte större än 50, så att uttrycket i det första argumentet i funktionen om (Logiskt_test) är FALSKT.

0

Funktionen om returnerar värdet för det tredje argumentet (argumentet värde_om_falskt). Funktionen Summa utvärderas inte eftersom det är det andra argumentet i funktionen om (argumentet värde_om_sant) och de returneras om uttrycket är uppfyllt.

  1. Markera cellen som du vill utvärdera. Endast en cell kan utvärderas i taget.

  2. Klicka på Utvärdera formel i gruppen Formelgranskning på fliken Formler.

    Gruppen Formelgranskning på fliken Formler

  3. Klicka på Utvärdera när du vill undersöka värdet för den understrukna referensen. Resultatet av utvärderingen visas i kursiv stil.

    Om den understrukna delen av formeln refererar till en annan formel klickar du på Stega in. Då visas den andra formeln i rutan Utvärdering. Klicka på Stega till procedurslut när du vill gå tillbaka till föregående cell och formel.

    Obs!: Knappen Stega in är inte tillgänglig när en referens visas i formeln för andra gången eller om formeln refererar till en cell i en annan arbetsbok.

  4. Fortsätt tills alla delar av formeln har utvärderats.

  5. Om du vill visa utvärderingen igen klickar du på Starta om.

    Om du vill avsluta utvärderingen klickar du på Stäng.

    Meddelanden: 

    • Vissa delar av formler som använder funktionerna om och välja utvärderas inte och #saknas visas i rutan utvärdering.

    • Om en referens är tom, visas värdet noll (0) i rutan Utvärdering.

    • Formler med cirkelreferenser kanske inte fungerar som förväntat. Om cirkelreferenser önskas, kan du Aktivera iterativ beräkning.

    • Följande funktioner räknas om varje gång kalkylbladet ändras och kan orsaka verktyget Utvärdera formel skiljer sig från vad som visas i cellen: SLUMP, förskjutning, CELL, indirekt, nu, idag, SLUMP.mellan, information och summa.Om (i vissa scenarier).

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×