Skapa ett histogram i Excel

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Ett histogram är ett stapeldiagram som visar frekvensdata.

Obs!: Det här avsnittet handlar endast om att skapa ett histogram. Information om Pareto (sorterat histogram) diagram finns i Skapa ett Paretodiagram.

  1. Kontrollera att du har läst in Analysis ToolPak. Mer information finns i läsa in Analysis ToolPak i Excel.

  2. Öppna ett kalkylblad, mata in indata i en kolumn och lägg till en etikett i den första cellen om du vill använda.

    Se till att använda kvantitativa numeriska data, t.ex. artikelantal eller testpoäng. Histogramverktyget fungera inte med kvalitativa numeriska data, t.e.x identifieringsnummer inmatade som text.

  3. I nästa kolumn skriver du facknumren i stigande ordning och lägger till en etikett i den första cellen om du vill.

    Det är en bra idé att använda dina egna facknummer, eftersom de kan vara mer värdefulla för din analys. Om du inte anger några facknummer skapar histogramverktyget jämnt fördelade fackintervall genom att använda minimi- och maximivärdena i indataområdet som start- och slutpunkter.

  4. Klicka på Data > Dataanalys.

    Knappen Dataanalys i gruppen Dataanalys

  5. Klicka på Histogram > OK.

    Dialogrutan Dataanalys

  6. Under Indata gör du följande:

    1. I rutan Indataområde anger du cellreferensen för det dataområde som innehåller indatanumren.

    2. I rutan Fackintervall anger du cellreferensen för det område som har facknumren.

      Om du använde kolumnetiketter på kalkylbladet kan du ta med dem i cellreferenserna.

      Tips: I stället för att ange referenser manuellt kan du klicka på Knappen Minimera för att tillfälligt dölja dialogrutan Markera områden i kalkylbladet. Klicka på knappen igen expanderar dialogrutan.

  7. Om du tog med kolumnetiketter i cellreferenserna markerar du rutan Etiketter.

  8. Under Utdataalternativ väljer du en utdataplats.

    Du kan placera histogrammet i samma kalkylblad, ett nytt kalkylblad i samma arbetsbok eller i en ny arbetsbok.

  9. Markera en eller fler av följande rutor:

    Pareto (sorterat histogram) Visa data i fallande frekvensordning.

    Ackumulerad procent     Visar ackumulerad procent och lägger till en rad med ackumulerad procent i histogramdiagrammet.

    Diagramutdata     Visar ett inbäddat histogramdiagram.

  10. Klicka på OK.

    Om du vill anpassa din histogram kan du ändra textetiketter och klicka var som helst i histogram till Använd knapparna Diagramelement, Diagramformat och Diagramfilter till höger i diagrammet.

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på Infoga > Infoga statistikdiagram > Histogram.

    Kommando för histogram som nås via knappen Infoga statistiskt diagram

    Du kan också skapa ett histogram från fliken Alla diagram i Rekommenderade diagram.

Tips: 

  • Använd flikarna Design och Format för att anpassa utseendet på diagrammet.

  • Om du inte ser flikarna, klicka någonstans i histogrammet att lägga till Diagramverktyg i menyfliksområdet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på den vågräta axeln i diagrammet, klicka på Formatera axel och klicka sedan på Alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i tabellen nedan för att avgöra vilka alternativ som du vill ange i åtgärdsfönstret Formatera axel.

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet när kategorierna (vågrät axel) är textbaserade i stället för numeriska. Histogrammet gruppera samma kategorier och summera värden inom värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatisk

    Det här är standardinställningen för histogram. Lagerplats bredd beräknas med Scotts normalreferensregel.

    Lagerplats bredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryssrutan om du vill skapa en lagerplats för alla värden ovanför värdet i rutan till höger. Ange ett annat decimaltal om du vill ändra värdet i rutan.

    Lagerplats för underskott

    Markera den här kryssrutan om du vill skapa en lagerplats för alla värden under eller lika med värdet i rutan till höger. Ange ett annat decimaltal om du vill ändra värdet i rutan.

    Åtgärdsfönstret Formatera axlar

Tips: Om du vill läsa mer om histogrammet och hur du kan visualisera statistiska data finns i det här blogginlägget histogram, Pareto, och rut-och morrhårsdiagram av Excel-grupp. Du kanske också vill veta mer om andra nya diagramtyper beskrivs i den här blogg inlägg.

Alternativet Automatisk (Scotts normalreferensregel)   

Formel för alternativet Automatisk

Scotts normalreferensregel försöker minimera snedvridningen i varians för histogrammet jämfört med datamängden, samtidigt som man antar normalt fördelade data.

Alternativet för spill lagerplats   

Formel för alternativet Lagerplats för överskott

Underskott lagerplats alternativet   

Formel för alternativet Lagerplats för underskott

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på Infoga > Diagram.

    Knappen Diagram i gruppen Illustrationer på fliken Infoga i Word
  3. Klicka på Histogram i dialogrutan Infoga diagram under Alla diagram, och klicka på OK.

Tips: 

  • Använd flikarna Design och Format i menyfliksområdet för att anpassa utseendet på diagrammet.

  • Om du inte ser flikarna, klicka någonstans i histogrammet att lägga till Diagramverktyg i menyfliksområdet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på den vågräta axeln i diagrammet, klicka på Formatera axel och klicka sedan på Alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i tabellen nedan för att avgöra vilka alternativ som du vill ange i åtgärdsfönstret Formatera axel.

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet när kategorierna (vågrät axel) är textbaserade i stället för numeriska. Histogrammet gruppera samma kategorier och summera värden inom värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatisk

    Det här är standardinställningen för histogram.

    Lagerplats bredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryssrutan om du vill skapa en lagerplats för alla värden ovanför värdet i rutan till höger. Ange ett annat decimaltal om du vill ändra värdet i rutan.

    Lagerplats för underskott

    Markera den här kryssrutan om du vill skapa en lagerplats för alla värden under eller lika med värdet i rutan till höger. Ange ett annat decimaltal om du vill ändra värdet i rutan.

    Åtgärdsfönstret Formatera axlar

Tips: Om du vill läsa mer om histogrammet och hur du kan visualisera statistiska data finns i det här blogginlägget histogram, Pareto, och rut-och morrhårsdiagram av Excel-grupp. Du kanske också vill veta mer om andra nya diagramtyper beskrivs i den här blogg inlägg.

Följ dessa steg för att skapa ett histogram i Excel 2016 för Mac:

  1. Välj data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på fliken Infoga i menyfliksområdet och sedan klickar du på Ikon för statistik (statistik ikonen) och markera Histogram under Histogram.

Tips: 

  • Använd flikarna Diagramdesign och Format för att anpassa utseendet på diagrammet.

  • Om du inte ser flikarna Diagramdesign och Format, klicka någonstans i histogrammet så läggs kontakten till i menyfliksområdet.

Om du vill skapa ett histogram i Excel 2011 för Mac, måste du hämta ett program från tredje part-tillägg. Läs jag hittar inte Analysis Toolpak i Excel 2011 för Mac för mer information.

Du kan visa ett histogram (ett stapeldiagram som visar frekvensdata) i Excel Online, men du kan inte skapa eftersom det kräver Analysis ToolPak, ett Excel-tillägg som inte stöds i Excel Online.

Om du har datorprogrammet Excel kan använda du knappen Redigera i Excel för att öppna Excel på ditt skrivbord och Skapa histogrammet.

Knappen Redigera i Excel

  1. Tryck för att markera data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du befinner dig på en telefon, trycker du på Redigera ikonen Ikonen Redigera om du vill visa i menyfliksområdet. och tryck sedan på Start.

  3. Tryck på Infoga > diagram > Histogram.

    Om det behövs kan du anpassa element i diagrammet.

    Obs!: Den här funktionen är endast tillgänglig om du har en Office 365-prenumeration. Om du har en prenumeration på Office 365 ska du kontrollera att du har den senaste versionen av Office.

    Prova Office 365 eller den senaste versionen av Excel

  1. Tryck för att markera data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du befinner dig på en telefon, tryck på Redigera ikonen Ikonen Redigera om du vill visa i menyfliksområdet och tryck sedan på Start.

  3. Tryck på Infoga > diagram > Histogram.

Om du vill skapa ett histogram i Excel måste du ange två typer av data – de data som du vill analysera och facknumren som representerar de intervall som du vill mäta frekvensen. Du måste ordna data i två kolumner i kalkylbladet. Dessa kolumner måste innehålla följande uppgifter:

  • Indata-data    Det här är de data som du vill analysera med hjälp av verktyget Histogram.

  • Facknumren    Dessa tal representerar de intervall som du vill använda histogrammet verktyget om du vill använda för att mäta den inmatade informationen i analysera data.

När du använder verktyget Histogram räknar Excel antalet datapunkter i varje data lagerplats. En datapunkt som ingår i en viss lagerplats om talet är större än den undre gränsen och lika med eller mindre än den största bundna för behållaren. Om du utelämnar fackintervall skapas Excel en uppsättning jämnt fördelade intervall mellan lägsta och högsta värdena i den inmatade informationen.

Utdata histogram analys visas på ett nytt kalkylblad (eller i en ny arbetsbok) och visar ett histogramtabell och ett stapeldiagram med data i histogramtabellen.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×