Office
Logga in

Skapa en pivottabell

Ibland kan det vara svårt att se helheten när du har rådata som inte har sammanfattats, som i exemplet nedan. Ofta handlar det första steget om att skapa en pivottabell för att sammanfatta och analysera data i ett strukturerat format, vilket är bra, men alla kan inte titta på tal och utifrån det snabbt se vad de visar. Pivotdiagram är ett bra sätt att lägga till visualiseringar i dina data.

Hushållsutgiftsdata

Motsvarande pivotdiagram

Exempel på data för hushållsutgifter för att skapa en pivottabell med månader, kategorier och belopp

Exempel på ett Excel-pivotdiagram

Om du bara har vanliga kalkylbladsdata och ingen befintlig pivottabell kan du välja ett pivotdiagram som rekommenderas för dina data, så skapar Excel automatiskt en kopplad pivottabell. Gör så här:

  1. Klicka var som helst i dina data.

  2. Välj Rekommenderade diagram i gruppen Diagram på fliken Infoga.

    Knappen rekommenderade diagram på fliken Infoga

  3. Välj valfritt diagram med pivotdiagramikonen Indikatorknappen Pivotdiagram i det övre hörnet på fliken Rekommenderade diagram. En förhandsvisning av ditt pivotdiagram visas i fönstret Förhandsgranskning.

    Dialogrutan Infoga diagram med rekommenderade pivotdiagram

  4. När du har hittat ett pivotdiagram som du vill använda klickar du på OK. Excel skapar ett nytt kalkylblad åt dig med både en pivottabell och ett pivotdiagram.

  5. Du kan ordna så att pivotdiagrammet hamnar bredvid pivottabellen för att visa både pivoterade data och diagrammet, eller så kan du placera pivotdiagrammet över dina data om du bara vill se diagrammet.

  6. Du kan sedan formatera ditt pivotdiagram.

Om du provade alternativet Rekommenderade diagram men inte hittade något du gillar kan du prova själv.

  1. Markera en cell i dina kalkylbladsdata och gå till Infoga > Pivotdiagram > Pivotdiagram.

  2. En dialogruta som frågar dig var du vill placera pivotdiagrammet visas i Excel. Det är oftast bra att välja alternativet Nytt kalkylblad så att du kan experimentera med att få diagrammet att se ut som du vill, utan att påverka något annat i kalkylbladet.

    Alternativ i Infoga > Pivotdiagram i Excel
  3. Tryck på OK så läggs ett nytt kalkylblad till i Excel med en tom pivottabell och pivotdiagram.

    Ett tomt pivotdiagram dyker upp och Fältlistan visas så att du kan lägga till eller ordna om fält i ditt pivotdiagram.

  4. Välj de fält du vill visa i pivotdiagrammet i Fältlistan.

    Fältlista som visar ett fältavsnitt och ett områdesavsnitt

  5. Du kan sedan formatera ditt pivotdiagram.

Om du redan har skapat en pivottabell och konfigurerat den så som du vill ha den skapar den här metoden det mest kompletta pivotdiagrammet åt dig.

  1. Markera en cell i pivottabellområdet.

  2. Öppna Verktyg för pivottabell > Analysera > Pivotdiagram.

  3. Välj den diagramtyp du vill använda och tryck på OK.

    Excel lägger ett nytt pivotdiagram i samma blad med den pivottabell du utgick från. I det här exemplet har vi valt ett vanligt stapeldiagram. Om du är osäker på vilken diagramtyp du vill använda kan du välja en i taget så förhandsvisas de i Excel i fönstret Infoga diagram.

    Exempel på pivotdiagram med förhandsgranskning i realtid av diagramtyp och ett markerat stapeldiagram

    Vissa diagram har inte stöd för pivottabelldata, och om du väljer en av dem får du information om detta i Excel.

  4. Du kan sedan formatera ditt pivotdiagram.

  1. Klicka på Data > Från andra källor och välj sedan den datakälla du vill ha. Välj till exempel Från Analysis Services för att ansluta till en OLAP-kubfil.

    Knappen Från andra källor på fliken Data

  2. Följ stegen i Guiden dataanslutning och klicka på Slutför.

  3. Välj Pivotdiagram och en plats där du vill lägga data i dialogrutan Importera data och klicka sedan på OK.

    Ett tomt pivotdiagram dyker upp och Fältlistan visas så att du kan lägga till eller ordna om fält i ditt pivotdiagram.

  4. Välj de fält du vill visa i pivotdiagrammet i Fältlistan.

    Fältlista som visar ett fältavsnitt och ett områdesavsnitt

  5. Du kan sedan formatera ditt pivotdiagram.

  1. Klicka på Infoga > Pivotdiagram.

    Knappen Pivotdiagram på fliken Infoga

  2. Klicka på Använd en extern datakälla i dialogrutan Skapa ett pivotdiagram och klicka sedan på Välj anslutning.

  3. Dubbelklicka på den anslutning du vill ha i dialogrutan Befintliga anslutningar på fliken Anslutningar.

  4. Klicka på OK.

    Ett tomt pivotdiagram dyker upp och Fältlistan visas så att du kan lägga till eller ordna om fält i ditt pivotdiagram.

  5. Välj de fält du vill visa i pivotdiagrammet i Fältlistan.

Fältlista som visar ett fältavsnitt och ett områdesavsnitt

Efter att du skapat ett pivotdiagram kan du anpassa det, precis som med vanliga standarddiagram. När du markerar pivotdiagrammet:

  1. Dyker två knappar upp intill diagrammet så att du snabbt kan lägga till eller ändra diagramelement, till exempel rubriker eller dataetiketter eller ändra diagramformat och färg på ditt pivotdiagram på samma sätt som du skulle i ett standarddiagram.

    Pivotdiagram med etiketter som pekar på fältknappar och diagramverktyg

  2. Fältknappar – I Excel visas pivottabellfält automatiskt som knappar i pivotdiagrammet. Med dem kan du filtrera ett enda pivotdiagram så att bara den information som du vill se visas. Du kan också använda Pivottabellutsnitt för att filtrera flera pivottabeller och pivotdiagram samtidigt i stället för fältknapparna. Om du vill ta bort dem klickar du på pivottabellen eller pivotdiagrammet, sedan på fliken Analysera i menyfliksområdet och avmarkerar knappen Fältlista.

  3. Verktyg för pivotdiagram visas på menyfliken. På flikarna Analysera, Design och Format kan du välja alternativ för att anpassa eller arbeta med ditt pivotdiagram.

    Verktyg för pivotdiagram på menyfliken

  4. Ett pivotdiagram måste inte vara i samma kalkylblad som den underliggande pivottabellen. När ditt pivotdiagram ser ut som du vill, kan du därför klippa ut och klistra in det på en annan plats.

  5. Om du vill ta bort ett pivotdiagram som du inte längre vill ha markerar du det och trycker på Delete.

Om du vill skapa ett pivotdiagram på en Mac-dator måste du först skapa en pivottabell och därefter infoga ett diagram. När det är klart fungerar diagrammet som ett pivotdiagram om du ändrar fälten i listan Pivottabellfält. 

  1. Skapa en pivottabell om du inte redan har en. 

  2. Markera en cell i pivottabellen.

  3. Klicka på en knapp på fliken Infoga för att infoga ett stapel-, linje-, cirkel- eller polärdiagram. Observera att andra typer av diagram inte fungerar med pivottabeller för närvarande. Till exempel fungerar ännu inte treemap-diagram, statistikdiagram och kombinationsdiagram med pivottabeller.

  4. När du infogat ett stapel-, linje-, cirkel- eller polärdiagram kan du pivotera det genom att ändra eller flytta fält med listan Pivottabellfält.

  5. Du kan också filtrera data i en pivottabell och använda utsnitt. När du gör det filtreras även diagrammet.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Närliggande avsnitt

Skapa en pivottabell
Använda fältlistan för att ordna fält i en pivottabell
Använda utsnitt för att filtrera data
Skapa en tidslinje för pivottabell för att filtrera datum

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×