Office
Logga in
Skapa eller redigera CSV-filer som ska importeras till Outlook

Skapa eller redigera CSV-filer som ska importeras till Outlook

En CSV-fil (Comma Separated Values – kommaavgränsade värden) är en särskild filtyp som du kan skapa eller redigera i Excel. CSV-filer lagrar information avgränsad av komman istället för att lagra den i kolumner. När text och tal sparas i en CSV-fil är det enkelt att flytta dem från ett program till ett annat. Du kan till exempel exportera kontakter från Google i CSV-format och sedan importera dem till Outlook.

Läs Importera och exportera e-post, kontakter och kalender till och från Outlook om du behöver hjälp att importera en lista med kalenderinlägg till Outlook.

Skapa en .csv-fil från ett annat program eller en annan e-postleverantör

Du kan vanligtvis välja bland flera format när du exporterar dina kontakter från ett annat program, till exempel Gmail. Med Gmail kan du välja mellan en CSV-fil för Google, en CSV-fil för Outlook eller vCards. Du kan välja att exportera till en CSV-fil eller en Outlook-datafil (.pst) när du exporterar en Outlook-profil och importerar den till en annan profil.

Ladda ned och öppna en exempelfil i .csv-format om du vill importera kontakter till Outlook

Om du manuellt vill skapa en CSV-fil för dina kontakter kan du göra på ett av två sätt.

Skapa en Excel-fil och sparade den som en CSV-fil

Du kan skriva in kontaktinformationen manuellt om informationen finns i ett program som du inte kan exportera den från.

  1. Skapa ett nytt dokument i Excel.

  2. Lägg till en kolumnrubrik för varje informationsuppgift du vill dokumentera (till exempel förnamn, efternamn, e-postadress, telefonnummer och födelsedag) och skriv sedan in informationen i rätt kolumn.

  3. När du är klar ska Excel-filen se ut ungefär så här.

    Så här ser exempelfilen i .csv-format ut i Excel.

  4. Välj Arkiv > Spara som.

  5. Välj CSV (kommaavgränsad) (*.csv) i den nedrullningsbara listrutan, namnge filen och välj sedan Spara.

    Spara Excel-filen som en CSV-fil.

  6. Du kan nu använda den nya CSV-filen när du ska importera dina kontakter till Outlook.

Ladda ned en CSV-mallfil

Om du vill börja med en tom CSV-fil kan du ladda ned exempelfilen nedan.

  1. Ladda ned den här exempelfilen i .csv-format. När du blir uppmanad att välja, väljer du att spara filen på datorn som en CSV-fil. Om du sparar den som en Excel-fil (.xls eller .xlsm) kommer alla data att hamna i en enda kolumn!

    När du laddar ned exempelfilen i .csv-format sparar du den på datorn som en CSV-fil.

  2. Öppna Excel på datorn.

  3. Gå till Arkiv > Öppna > i Excel och navigera sedan till den CSV-fil du just laddat ned till datorn. Om du vill söka efter CSV-filen bör du söka i Alla filer. Öppna CSV-filen genom att klicka på den.

    Om du vill söka efter CSV-filen bör du söka efter Alla filer.

Det finns några saker att tänka på när du arbetar med den här exempelfilen i .csv-format:

  • Ersätt inte kolumnrubrikerna på den första raden eftersom Outlook behöver dem.

    Så här ser exempelfilen i .csv-format ut i Excel.

  • Du kan ta bort data på raderna 2-6 (exempelnamnen, telefonnumren, e-postadresserna osv.).

  • Du behöver inte ange värden för varje kolumn. Ange bara den information du vill ha.

  • Spara filen med ett nytt namn och filtypen CSV (.csv). Om du sparar filen i Excel uppmanas du några gånger att bekräfta att du vill spara den i CSV-format. Välj alltid Ja. Om du väljer Nej sparas filen i Excels ursprungliga format (.xlsx) och den kan inte användas för att importera data till Outlook.

  • Prova att importera CSV-filen med bara några få kontakter för att säkerställa att du är nöjd med resultatet. Du kan sedan ta bort de importerade kontakterna, lägga till fler i CSV-filen och importera igen.

    Om du vill importera data i CSV-exempelfilen ska det se ut så här i Outlook på webben för Office 365:

    När du har importerat kontakter ser de ut så här i Outlook på webben.

Redigera en CSV-fil med kontakter som du vill importera till Outlook

Anta att du vill redigera en .csv-fil som du har exporterat från Outlook och sedan importera tillbaka den till Outlook eller en annan e-postleverantör. Med hjälp av Excel är det enkelt att redigera .csv-filen.

Här är några saker att komma ihåg när du redigerar en .csv-fil:

  • Behåll kolumnrubrikerna på den första raden.

  • När du sparar filen uppmanas du några gånger att bekräfta att du vill spara den i CSV-format. Välj alltid Ja. Om du väljer Nej sparas filen i Excels ursprungliga format (.xlsx) och den kan inte användas för att importera data till Outlook.

Problem: Alla data visas i den första kolumnen

Ett exempel på en CSV-fil som sparats i .xls-format.

Här är några anledningar till varför detta händer och tips om hur du kan försöka lösa problemet:

  • Om du sparar CSV-filen i ett annat format, till exempel .xls, .xlsx eller .xlm, visas alla data i den första kolumnen. Gå tillbaka till den ursprungliga CSV-filen och se till att spara den i .csv-format.

  • Det är möjligt att programmet som CSV-filen skapas i lägger till extra citationstecken i dina data. Det leder till att dina data behandlas som en enhet i Excel. Anta t.ex. att dina data ser ut så här:

    a, b, c, d - Excel lägger in de olika bokstäverna i varsin egen kolumn.

    "a, b, c, d", e – Excel lägger in a,b,c,d i en kolumn och e i en annan.

    Ta reda på om det är detta som är problemet med filen genom att öppna den i Anteckningar: Högerklicka på CSV-filen i Windows, välj Öppna med > Anteckningar. Sök efter extra citattecken.

    Om du hittar extra citationstecken gör du så här:

    1. Öppna CSV-filen med Excel. Alla data visas då i kolumn A och citationstecken är borta.

    2. Använd nu guiden Text till kolumner och dela in data i kolumn A i enskilda kolumner: välj Data > Text till kolumner på menyraden.

      Klicka på Data > Text till kolumner

    3. Välj Avgränsade > Nästa. Välj sedan Kommatecken > Slutför.

    4. Spara filen i .cvs-format så att du fortfarande kan importera den till Outlook.

Se även

Importera kontakter till Outlook

Exportera kontakter från Outlook

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×