Så korrigerar du ett #VÄRDEFEL!-fel i funktionen PRODUKTSUMMA

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

I det här avsnittet beskrivs vanliga situationer med #VÄRDEFEL!-fel när du arbetar med PRODUKTSUMMA.

Problem: Matrisargumenten har inte samma dimension

Alla matrisargument måste ha samma dimension. Annars får du felet #VÄRDEFEL! Om Matris 1 till exempel refererar till ett område med 3 rader och 2 kolumner så måste Matris 2 också motsvara ett liknande område.

PRODUKTSUMMA-formeln som orsakar felet är =SUMPRODUCT(D2:D13,E2:E10) – E10 måste ändras till E13 för att matcha det första intervallet.
  • =PRODUKTSUMMA(D2:D13,E2:E10)

Det här kommer att misslyckas eftersom de refererade områdena inte har samma antal rader (13 i det första intervallet men bara 10 i det andra).

Lösning: Ändra formeln till:

  • =PRODUKTSUMMA(D2:D13,E2:E13)

Så att båda områden har samma start- och slutrad, och prova formeln igen.

Om du löser #VÄRDEFEL!-felet i underliggande data åtgärdas PRODUKTSUMMA-felet

Problem: En eller flera celler i området innehåller text

Om en eller flera celler i det refererade området innehåller text eller är formaterad som datatypen Text får du felet #VÄRDEFEL! Texten kan vara resultatet av en beräkning från en annan formel, eller så kanske cellen bara inte är rätt formaterad.

Formeln i cell E15 visar ett #VÄRDEFEL!-fel eftersom det finns ett #VÄRDEFEL!-fel i kolumnen E.

Lösning: Leta efter celler som innehåller text eller är formaterade som text och ange rätt datatyp.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Se även

Korrigera #VÄRDEFEL!

Funktionen PRODUKTSUMMA

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×