Så här korrigerar du felvärdet #VÄRDEFEL! i funktionen MEDEL eller SUMMA

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Om medel eller summa refererar till celler som innehåller #VALUE! fel, formlerna leder till en #VALUE! Obs! Detta fungerar annorlunda än i Excel-versioner som är tidigare än TE000130083.

Felvärdet #VÄRDEFEL! i MEDEL

För att förbise felvärdena skapar vi en formel som ignorerar fel i referensområdet när du beräknar medelvärdet med de återstående ”normala” värdena.

För att lösa det här problemet använder vi en kombination av MEDEL tillsammans med OM och ÄRFEL för att avgöra om det finns ett fel i det angivna området. Just detta scenario kräver en matrisformel:

=MEDEL(OM(ÄRFEL(B2:D2));"";B2:D2))

Det här är en mat ris formel. Så du måste antingen trycka på RETUR (bara om du använder Office365) eller CTRL + SKIFT + RETUR i formeln.

Obs!: Om du har en aktuell version av Office 365kan du ange formeln i cellen output och sedan trycka på RETUR för att bekräfta formeln som en dynamisk mat ris formel. Annars måste formeln anges som en äldre mat ris formel genom att först markera cellen, skriva in formeln i utdatatabellen och sedan trycka på CTRL + SKIFT + RETUR för att bekräfta. Excel infogar klammerparenteser i början och slutet av formeln åt dig. Mer information om matrisformler finns i Riktlinjer för och exempel på matrisformler.

Funktionen matris i genomsnitt för att lösa #VALUE! med OM

Obs!: Funktionen ovan fungerar inte bara för #VÄRDEFEL!, utan även för #SAKNAS!, #NULL, #DIVISION/0! och andra felvärden.

Du kan också använda SUMMA på samma sätt:

=SUMMA(OM(ÄRFEL(B2:D2);"";B2:D2))

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Korrigera #VÄRDEFEL!

Funktionen medel

Funktionen Sum

Översikt över formler i Excel

Upptäck fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×