Räkna unika värden bland dubbletter

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Anta att du vill ta reda på hur många unika text eller numeriska värden som finns i ett område. Till exempel om en kolumn innehåller texten med ett belopp som Bradley, Doyle, Doyle, Doyle, det finns två unika värden – Bradley och Doyle. Om cellområdet inte innehåller talen 5, 6, 7, 6, är de unika värdena 5, 6 och 7.

För att endast räkna unika värden använder du en kombination av följande funktioner, så som visas i exempelkalkylbladet nedan:

  • Använd funktionen om för att tilldela värdet 1 för varje villkor är sant.

  • Använd funktionen Summa för att lägga till alla unika värden.

  • Använd funktionen frekvens för att räkna antalet unika värden. Text och nollvärden ignoreras i den här funktionen. För den första förekomsten av ett visst värde returnerar ett tal lika med antalet förekomster av värdet. För varje förekomst av samma värde efter först returneras värdet 0.

  • Använd funktionen passa för att returnera positionen för ett textvärde i ett område. Funktionen frekvens använder det resulterande värdet för att utvärdera motsvarande textvärden.

  • Använd funktionen längd för att söka efter tomma celler. Tomma celler har längden (antal tecken) 0.

Exempel

Kopiera tabellen till cell A1 på ett tomt kalkylblad i Excel om du vill arbeta med de här exemplen på formler som använder funktioner.

Data

Data

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Formel

Beskrivning (Resultat)

=SUMMA(OM(FREKVENS(A2:A10;A2:A10)>0;1))

Räknar antalet unika talvärden i cellerna A2:A10, men räknar inte tomma celler eller textvärden (4)

=SUMMA(OM(FREKVENS(PASSA(B2:B10;B2:B10;0);PASSA(B2:B10;B2:B10;0))>0;1))

Räknar antalet unika text- och talvärden i cellerna B2:B10 (som inte får innehålla några tomma celler) (7)

=SUMMA(OM(FREKVENS(OM(LÄNGD(A2:A10)>0;PASSA(A2:A10;A2:A10;0);""); OM(LÄNGD(A2:A10)>0;PASSA(A2:A10;A2:A10;0);""))>0;1))

Räknar antalet unika text- och talvärden i cellerna A2:A10, men räknar inte tomma celler eller textvärden (6)

Meddelanden: 

  • Formlerna i det här exemplet måste matas in som matrisformler. Markera varje cell som innehåller en formel, tryck på F2 och tryck sedan på Ctrl + Skift + Retur.

  • Om du vill se hur funktionen beräknas steg för steg markerar du den cell som innehåller formeln och klickar på pilen bredvid Utvärdera formel i gruppen Formelgranskning på fliken Formler.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×