Räkna tecken i celler

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

När du behöver räkna tecken i celler använder du funktionen längd– som räknar bokstäver, siffror, tecken och alla blanksteg. Till exempel längden på ”det är 98 grader idag, så att jag ska gå simmar” (utom citattecken) är 42 tecken – 31 bokstäver, 2 siffror, 8 blanksteg, ett kommatecken och 2 apostrofer.

Om du vill använda funktionen Ange = längd (cell) i formelfältet och tryck sedan på RETUR på tangentbordet.

Flera celler: Om du vill använda samma formel i flera celler, ange formeln i det första cellen och sedan dra fyllningshandtaget nedåt (eller tvärs över) cellområdet.

Ange flera LÄNGD-funktioner på ett kalkylblad

Att få den totala antalet tecken i flera celler är att använda funktionerna Summa tillsammans med längd. Du använder funktionen LÄNGD räknar tecknen i varje cell och lägger till räknar funktionen Summa i det här exemplet:

= Summa ((längd ( cell1 ), längd ( cell2 ), (längd ( cell3 )) )).

Prova själv

Här är några exempel som visar hur du använder funktionen längd.

Kopiera tabellen nedan och klistra in den i cell A1 i ett Excel-kalkylblad. Dra formeln i B2 till B4 visas längden på texten i alla celler i kolumn A.

Textsträngar

Formler

Flygande bäckasiner söka.

=LÄNGD(A2)

Flygande bäckasiner söka hwila.

Flygande bäckasiner söka hwila på mjuka tuvor

Räkna tecken i en cell

  1. Klicka på cell B2.

  2. Ange =längd(a2).

Formeln räknar tecknen i cell A2 som summerar 27 – vilket inkluderar alla blanksteg och period i slutet av meningen.

ANTECKNING: längd räknar blanksteg efter det sista tecknet.

Räkna tecken i flera celler

  1. Klicka på cell B2.

  2. Tryck på Ctrl + C för att kopiera cell B2 och sedan Markera cellerna B3 och B4 och tryck sedan på Ctrl + V för att klistra in dess formel i cellerna B3: B4.

Då kopieras formeln till cell B3 och B4 och funktionen räknar tecknen i varje cell (20 27 och 45).

Räkna ett totalt antal tecken

  1. I exempelarbetsboken klickar du på cell B6.

  2. I cellen anger du =SUMMA(LÄNGD(A2);LÄNGD(A3);LÄNGD(A4)) och trycker på Retur.

Då räknas antalet tecken i alla tre celler och den sammanlagda summan (92).

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×