OMFEL (Funktionen OMFEL)

Du kan använda funktionen OMFEL för att svälla och hantera fel i en formel. OMFEL returnerar ett värde som du anger om en formel utvärderar till ett fel; annars returneras resultatet av formeln.

Syntax

OMFEL(värde; värde_om_fel)

Syntaxen för funktionen OMFEL har följande argument:

  • värde    Obligatoriskt. Detta är det argument som genomsöks efter fel.

  • value_if_error    Obligatoriskt. Det värde som returneras om formeln utvärderas till ett fel. Följande feltyper utvärderas: #SAKNAS!, #VÄRDEFEL!, #REFERENS!, #DIVISION/0!, #OGILTIGT!, #NAMN? eller #NULL!.

Kommentarer

  • Om värde eller value_if_error är en tom cell behandlas det som ett tomt sträng värde ("").

  • Om värde är en mat ris formel returnerar OMFEL en matris med resultat för varje cell i det område som anges i värdet. Se det andra exemplet nedan.

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. Om du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur.

Kvot

Antal sålda enheter

210

35

55

0

23

Formel

Beskrivning

Resultat

=OMFEL(A2/B2; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6

=OMFEL(A3/B3; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=OMFEL(A4/B4; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera "" med 23), hittar inga fel och returnerar formelresultatet.

0

Exempel 2

Kvot

Antal sålda enheter

Proportioner

210

35

6

55

0

Fel i beräkningen

23

0

Formel

Beskrivning

Resultat

=C2

Söker efter fel i formeln i det första argumentet i det första elementet av matrisen (A2/B2 eller dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6

=C3

Söker efter fel i formeln i det första argumentet i det andra elementet i matrisen (A3/B3 eller dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=C4

Söker efter fel i formeln i det första argumentet i det tredje elementet av matrisen (A4/B4 eller dividera "" med 23), hittar inga fel och returnerar formelresultatet.

0

Obs! Om du har en aktuell version av Office 365kan du ange formeln i cellen längst upp till vänster i Utdataområde och sedan trycka på RETUR för att bekräfta formeln som en dynamisk mat ris formel. Annars måste formeln anges som en äldre mat ris formel genom att först välja ett Utdataområde, Ange formeln i den övre vänstra cellen i Utdataområde och sedan trycka på CTRL + SKIFT + RETUR för att bekräfta. I Excel infogas klammerparenteser i början och slutet av formeln åt dig. Mer information om matrisformler finns i Riktlinjer för och exempel på matrisformler.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×