Mer information om SUMMA

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Lär dig mer om funktionen Summa

Om du snabbt vill få fram summan av ett cellområde behöver du bara markera området och titta längst ned till höger i Excel-fönstret.

Skärmbild av markering av ett cellområde, och titta sedan i statusfältet.


Det här är statusfältet och visar information om vad du har valt, oavsett om det är en enskild cell eller flera celler. Om du högerklickar i statusfältet visas en funktionsdialogruta som visar alla alternativ som du kan välja. Observera att det även visar värden för det markerade området om de attributen är markerade. 

Det enklaste sättet att lägga till en summa-formel i kalkyl bladet är att använda autoSumma-guiden. Markera en tom cell direkt ovanför eller nedanför det område som du vill summera, gå till fliken Start eller formel i menyfliksområdet och tryck på Autosumma _GT_ sum. AutoSumma-guiden känner automatiskt av området som ska summeras och skapar formeln för dig. Det kan också fungera vågrätt om du markerar en cell till vänster eller till höger om området som ska summeras. Obs! det går inte att arbeta med icke angränsande områden, men vi går vidare i nästa avsnitt.

Du kan använda guiden Autosumma för att automatiskt skapa en Summa-formel.  Välj ett område ovanför/nedanför eller till vänster/höger om området som ska summeras och gå till fliken Formel i menyfliksområdet och markera Autosumma och SUMMA.


I dialog rutan autoSumma kan du välja andra vanliga funktioner som:

Autosumma lodrätt

Cell D6 visar summaformeln för Autosumma: =SUMMA(B2:B5)

Guiden Autosumma har automatiskt upptäckt att cellerna B2:B5 är området som ska summeras. Allt du behöver göra är att bekräfta det är att trycka på RETUR. Om du behöver lägga till/utelämna fler celler kan du hålla ned Skift > valfri piltangent tills ditt val matchar det du önskar och trycka på RETUR när du är klar.

IntelliSense-funktionsguide: SUMMANS (tal1, [tal2], ...) flytande tagg under den här funktionen är dess Intellisense-guide. Om du klickar på SUMMA eller namnet på funktionen ändras den till en blå hyperlänk som tar dig till hjälpavsnittet för funktionen. Om du klickar på de enskilda funktionselement markeras deras representativa delar i formeln. I det här fallet skulle endast B2:B5 markeras eftersom det finns bara en talreferens i den här formeln. Intellisense-taggen visas för vilken funktion som helst.

Autosumma vågrätt

Cell D2 visar summaformeln för Autosumma: =SUMMA(B2:C2)

Användning av SUMMA med osammanhängande områden.  Formeln i cell C8 är =SUMMA(C2:C3,C5:C6). Du kan också använda namngivna områden, så att formeln skulle bli =SUMMA(Vecka1,Vecka2)

Guiden Autosumma fungerar oftast bara för angränsande områden, så om du har tomma rader eller kolumner i summaområdet stoppar Excel vid det första mellanrummet. Då skulle du behöva SUMMA baserat på val, där du lägger till enskilda områden ett i taget. Om du skulle ha data i cell B4 i det här exemplet skulle Excel generera =SUMMA(C2:C6) eftersom det skulle känna igen ett angränsande område.

Du kan snabbt markera flera icke angränsande intervall med Ctrl + vänsterklick. Ange först ”=SUMMA(”, välj sedan dina olika intervall så lägger Excel automatiskt till kommaavgränsare mellan intervallen åt dig. Tryck på Retur när du är klar.

Tips: du kan använda Alt + = för att snabbt lägga till Summa-funktionen i en cell. Allt du behöver göra är att välja intervallet.

Obs! du kan se hur Excel har markerat de olika funktions områdena efter färg och de matchar själva formeln, så att C2: C3 är en färg och C5: C6 är en annan. Excel gör detta för alla funktioner såvida inte det refererade området finns på ett annat kalkyl blad eller i en annan arbets bok. För förbättrad tillgänglighet med hjälpmedels teknik kan du använda namngivna områden, till exempel "vecka1", "Week2" osv. och sedan referera till dem i din formel:

=SUMMA(Vecka1,Vecka2)

  1. Du kan absolut använda SUMMA med andra funktioner. Här är ett exempel som skapar en månatlig medelvärdesberäkning:

    Använda SUMMA med andra funktioner.  Formeln i cell M2 är=SUMMA(A2:L2)/ANTALV(A2:L2)  Obs!  Kolumnerna maj-november döljs för tydlighetens skull.
    • =SUMMM(A2:L2)/ANTALV(A2:L2)

  2. vilket tar SUMMAN i A2:L2 dividerat med antalet ej tomma celler i A2:L2 (maj till december är tomt).

  1. Ibland behöver du summera en viss cell i flera kalkylblad. Det kan vara frestande att klicka på varje blad och cell du vill ha och bara använda ”+” för att lägga till cellvärdena, men det är omständligt och kan skapa fel.

    • =Blad1!A1+Blad2!A1+Blad3!A1

    Du kan göra det mycket enklare med en 3D- eller 3-dimensionell SUMMA:

    3D-SUMMA – Formeln i cell D2 är =SUMMA(Blad1:Blad3!A2)
    • =SUMMA(Blad1:Blad3!A1)

    Detta summerar cellen i A1 i alla blad från Blad 1 till 3.

    Detta är särskilt praktiskt i situationer där du har ett enda blad för varje månad (januari-december) och du behöver summera dem på ett sammanfattningsblad.

    3D-SUMMAN för det namngivna bladet.  Formeln i D2 är=SUMMA(januari:december!A2)
    • =SUMMA(januari:december!A2)

    Detta summerar cell A2 i varje blad från januari till december.

    Meddelanden: Om dina kalkyl blad innehåller blank steg i deras namn, till exempel "försäljning i januari", måste du använda en apostrof när du refererar till blad namnen i en formel. Observera apostrofen före det första kalkyl blads namnet och återigen efter den sista.

    • =SUMMA(’försäljning i januari:försäljning i december’!A2)

    3D-metoden fungerar även med andra funktioner som medel, MIN, MAX, osv:

    • = MEDEL(Ark1:Ark3! A1)

    • = MIN(Ark1:Ark3! A1)

    • = MAX(Ark1:Ark3! A1)

Du kan enkelt utföra matematiska operationer med Excel på egen hand och genom att använda Excel-funktioner som SUMMA. I följande tabell visas operatorer som du kan använda samt vissa relaterade funktioner. Du kan ange operatorerna med hjälp av siffertangenterna på ditt tangentbord eller det numeriska tangentbordet (10 tangenter) om du har ett. Med Skift+8 kan du till exempel ange asterisken (*) för multiplikation.

Operator

Åtgärd

Exempel

+

Addition

=1+1

=A1+B1

=SUMMA(A1:A10)+10

=SUMMA(A1:A10)+B1

-

Subtraktion

=1-1

=A1-B1

=SUMMA(A1:A10)-10

=SUMMA(A1:A10)-B1

*

Multiplikation

=1*1

=A1*B1

=SUMMA(A1:A10)*10

=SUMMA(A1:A10)*B1

=PRODUKT(1,1) - Funktionen PRODUKT

/

Division

=1/1

=A1/B1

=SUMMA(A1:A10)/10

=SUMMA(A1:A10)/B1

=KVOT(1,1) - Funktionen KVOT

^

Exponentiering

=1^1

=A1^B1

=SUMMA(A1:A10)^10

=SUMMA(A1:A10)^B1

=UPPHÖJT.TILL(1,1) - Funktionen UPPHÖJT.TILL

Mer information finns i Använda Excel som miniräknare.

Andra exempel

  1. Anta att du vill använda en procentuell rabatt till ett område med celler som du har summerat.

    Använda operatorer med summa.  Formeln i cell B16 är = Summa (a2: A14) *-25%.  Formeln skapades korrekt om-25% var en cell referens i stället för = Summa (a2: A14) * E2
    • =SUMMA(A2:A14)*-25%

    skulle ge dig 25 % av det summerade området, men det hårdkodar 25 % i formeln och det kan vara svårt att hitta den senare om du behöver ändra den. Det är mycket bättre att placera dessa 25 % i en cell och referera till den istället där den är öppen och enkel att ändra, så här:

    • =SUMMA(A2:A14)*E2

    För att dividera istället för att multiplicera ersätter du bara ”*” med ”/”: =SUMMA(A2:A14)/E2

  2. Addera eller subtrahera från en SUMMA

    i. Du kan enkelt addera eller subtrahera från en summa med hjälp av + eller - så här:

    • =SUMMA(A1:A10)+E2

    • =SUMMA(A1:A10)-E2

Mer information finns i

Funktionen SUMMA

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×