Korrigera #VÄRDEFEL!-fel i funktionen SAMMANFOGA

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Viktigt!: I Excel 2016, Excel Mobile, och Excel Online har SAMMANFOGA ersatts av funktionen SAMMAN. SAMMANFOGA-funktionen är fortfarande tillgänglig för bakåtkompatibilitet, men du bör överväga att använda SAMMAN eftersom det är en mer robust funktion.

En av de vanligaste scenarierna där du stöter på #VÄRDEFEL! med SAMMANFOGA är när du försöker skapa en sträng som innehåller en cellreferens som innehåller ett fel, till exempel #VÄRDEFEL!.

I följande exempel vill vi sammanfoga D2, E2 och F2, och E2 har ett #VÄRDEFEL!.

#VÄRDEFEL!-fel i SAMMANFOGA

Fel i E2 gör att funktionen för att visa #VALUE! fel. För att det ska fungera måste du ersätta felet med ett annat värde än felet. Du kan skapa en formel som söker efter fel i cellreferensen och om så är fallet visa textsträngen där värdet 0 visas i stället för felet (eller kan du ersätta texten för 0, men du behöver radbryta text inom citattecken – ”Your Text”).

Den här formeln fungerar:

=OM(ÄRFEL(E2);SAMMANFOGA(D2;” ”;0;” ”;F2))

Funktionerna OM och ÄRFEL funktioner används som en lösning för att sammanfoga en sträng med felet #VÄRDEFEL!

Hur fungerar som? Om-funktionen används funktionen OMFEL för att avgöra om det finns ett fel i E2 och om det finns funktionen sammanfoga kombinerar värdena i D2, E2 och F2 (funktionen ersätter felet med 0), och visar den resulterande textsträngen. Observera formeln används också blanksteg (””) för att avgränsa värdena.

Åtgärda #VÄRDEFEL! med SAMMANFOGA i Excel 2003 och tidigare versioner

Om du får #VALUE! fel i Office Excel 2003 eller äldre versioner, måste du avmarkera alternativet övergång formel utvärdering (TFE) i Excel. Följ stegen som beskrivs i #VALUE! fel när Sammanfoga celler att lösa problemet.

Har du en specifik fråga om funktioner?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Se även

Korrigera #VÄRDEFEL!

Funktionen SAMMANFOGA

Funktionen SAMMAN

Översikt över formler i Excel

Hur du undviker felaktiga formler

Upptäck fel i formler

Alla Excel-funktioner (alfabetisk ordning)

Alla Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×