Kopiera en formel genom att dra i fyllningshandtaget i Excel 2016 för Mac

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Du kan snabbt kopiera formler till angränsande celler genom att använda fyllningshandtaget.

Fyllningshandtag

När du drar handtaget till andra celler visas olika resultat för varje cell i Excel.

Kopiera en formel genom att dra fyllningshandtaget

  1. Markera den cell som innehåller den formel du vill fylla de angränsande cellerna med.

  2. Håll markören i det nedre högra hörnet så att den ändras till ett plustecken (+), så här:

    Markör på fyllningshandtag

  3. Dra fyllningshandtaget nedåt, uppåt eller tvärs över de celler som du vill fylla. I det här exemplet dras fyllningshandtaget nedåt:

    Markör där fyllningshandtag dras nedåt

  4. När du släpper fylls formeln automatiskt i de andra cellerna:

    Värden visas för celler som har fyllts i

  5. Om du vill ändra hur celler ska fyllas klickar du på knappen Alternativ för Autofyll Knappen Alternativ för Autofyll som visas när du är klar med att dra och väljer sedan önskat alternativ.

Mer information om hur du kopierar formler finns i Kopiera och klistra in en formel i en annan cell eller ett annat kalkylblad.

Tips: 

  • Du kan också trycka på CTRL+D för att fylla i formeln nedåt i en kolumn. Markera den cell som innehåller den formel som du vill fylla på med. Markera cellerna under den. Tryck på CTRL+D.

  • Du kan också trycka på CTRL+R för att fylla i formeln till höger i en rad. Markera den cell som innehåller den formel som du vill fylla på med. Markera cellerna till höger om den. Tryck på CTRL+R.

När fyllning inte fungerar

Ibland fungerar det utmärkt att fylla celler och andra gånger fungerar det inte som du förväntar dig. Därför är det viktigt att kontrollera den första cellens cellreferenser.

Cellreferenser är helt enkelt pekare till andra celler. Anta till exempel att den första cellen innehåller den här formeln:


=SUMMA(A1;B1)


A1 och B1 är relativa referenser. Det innebär bara att referenserna ändras stegvis från A1, B1 till A2, B2 och så vidare när du fyller formeln nedåt, så här:

=SUMMA(A1;B1)

=SUMMA(A2;B2)

=SUMMA(A3;B3)

Andra gånger vill du inte att referenserna till andra celler ska ändras. Anta till exempel att du vill att den första referensen, A1, ska vara fast och att B1 ska ändras när du drar fyllningshandtaget. Då skriver du dollartecken i den första referensen, så här: =SUMMA($A$1;B1). Dollartecknen tvingar Excel att fortsätta peka på A1 när du fyller andra celler. Det ser ut så här:

=SUMMA($A$1;B1)

=SUMMA($A$1;B2)

=SUMMA($A$1;B3)

Referenser med dollartecken ($) kallas absoluta referenser. När du fyller nedåt fortsätter referensen till A1 att vara fast men referensen till B1 ändras till B2 och B3.

Visas inte fyllningshandtaget?

Om du inte ser fyllningshandtaget kan det bero på att det är dolt. Om du vill visa det igen:

  1. Klicka på InställningarExcel-menyn.

  2. Klicka på Redigera.

  3. Under Redigeringsalternativ markerar du kryssrutan Tillåt fyllningshandtaget och dra-och-släpp-cell.

Om automatisk arbetsboksberäkning inte är aktiverat beräknas inte formler om när du fyller celler. Så här aktiverar du det om det behövs:

  1. Klicka på InställningarExcel-menyn.

  2. Klicka på Beräkning.

  3. Under Beräkningsalternativ kontrollerar du att Automatisk är markerad.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×