Kontrollera stavning och grammatik i Office

Alla Microsoft Office-program kan kontrollera stavning och de flesta av dem kan kontrollera grammatik. 

Om stavning eller grammatik inte fungerar som förväntat läser du Stavnings- och grammatikkontrollen fungerar inte som förväntat. Om du vill kontroller stavning eller grammatik på ett annat språk än ditt standardspråk läse du Kontrollera stavning och grammatik på ett annat språk.

Använder du Office 365? Du kanske vill ta en titt på den nya kraftfulla funktionen Editor i Word! Mer information finns i Editor – skrivassistenten.

Köra stavnings- och grammatikkontrollen manuellt

Starta en kontroll av stavning och grammatik i dina filer genom att bara trycka på F7 eller följ anvisningarna nedan:

  1. Öppna de flesta Office-program: klicka på fliken Granska i menyfliksområdet. I Access eller InfoPath kan du hoppa över det här steget. I Project går du till fliken Projekt.

  2. Klicka på Stavning eller Stavning och grammatik.

    Knappen Stavning och grammatik i menyfliksområdet Granska

  3. Om stavfel hittas visas en dialogruta med det först felstavade ordet som identifierats.

  4. När du har bestämt hur du vill lösa felstavningen (ignorera den, lägga till den i programmets ordlista eller ändra den) går programmet vidare till nästa felstavade ord.

Klicka på en rubrik nedan för mer information.

De flesta Office-programmen kontrollerar möjliga stavfel och grammatiska fel medan du skriver, så du behöver inte göra något för att visa fel medan du arbetar. 

Meddelanden: 

  • Den automatiska stavnings- och grammatikkontrollen är inte tillgänglig i Access, Excel eller Project. Du kan starta en stavningskontroll manuellt genom att trycka på F7.

  • Den automatiska grammatikkontrollen är endast tillgänglig i Outlook, Word och PowerPoint 2013 (eller senare).

Office markerar möjliga stavfel med en röd, vågig linje:

Stavfel markeras med en röd vågig linje

Möjliga grammatiska fel markeras med en blå, vågig linje:

Möjligt språkfel markerat med en blå, vågig linje

Om stavfel eller grammatiska fel inte markeras kan den automatiska kontrollen vara inaktiverad. Du kan aktivera den automatiska stavnings- och grammatikkontrollen.

När du ser ett stavfel eller grammatiskt fel som du vill ha hjälp med att korrigera högerklickar du på det understrukna ordet eller frasen och väljer ett av alternativen för att åtgärda felet.

Om Office flaggar ord som felstavade men stavningen är som du vill ha det väljer du Lägg till i ordlista för att lära Office att inte flagga det ordet som felstavat i framtiden. Mer information om detta finns i: Lägg till och redigera ord i en ordlista för stavningskontroll.

Om du inte vill att Office ska markera möjliga fel med vågiga linjer medan du arbetar kan du inaktivera den automatiska stavnings- och grammatikkontrollen:

  1. Öppna alternativen för stavnings- och grammatikkontroll:

    • I OneNote, PowerPoint, Publisher, Visio och Word: Klicka på AlternativArkiv-menyn och klicka sedan på Språkkontroll.

    • I InfoPath: Klicka på pilen bredvid eller under Stavning och sedan på Stavningsalternativ på fliken Start.

    • I Outlook: Klicka på AlternativArkiv-menyn, klicka på E-post och klicka sedan på Stavning och autokorrigering.

  2. Markera eller avmarkera kryssrutan Kontrollera stavning medan du skriver. I program som har automatisk grammatikkontroll kan du också markera eller avmarkera kryssrutan Markera grammatikfel medan du skriver.

    Kryssrutan Kontrollera stavning medan du skriver

    Obs!: I Word kan du aktivera eller inaktivera stavningskontrollen för dokumentet du arbetar med eller för alla nya dokument. Välj ett alternativ i listan Undantag för och markera eller avmarkera kryssrutorna Dölj stavfel endast i det här dokumentet och Dölj grammatiska fel endast i det här dokumentet.

Om du inte vill att Office ska kontrollera grammatik alls (när du kör en stavningskontroll eller automatiskt medan du skriver) kan du inaktivera den:

  1. Öppna alternativen för stavnings- och grammatikkontroll:

    • I OneNote, PowerPoint, Publisher, Visio och Word: Klicka på AlternativArkiv-menyn och klicka sedan på Språkkontroll.

    • I InfoPath: Klicka på pilen bredvid eller under Stavning och sedan på Stavningsalternativ på fliken Start.

    • I Outlook: Klicka på AlternativArkiv-menyn, klicka på E-post och klicka sedan på Stavning och autokorrigering.

  2. Avmarkera kryssrutorna Markera grammatikfel medan du skriver och Kontrollera grammatik och stavning.

    Kryssrutor för grammatik

    Obs!: Alla Office-program har inte båda dessa alternativ.

I Word, Outlook, PowerPoint 2013 (eller senare) kan du tvinga fram en ny kontroll av ord och grammatik, som du tidigare hoppat över, på följande sätt:

  1. Öppna det dokument eller objekt som du vill kontrollera.

  2. På menyn Arkiv klickar du på Alternativ > Språkkontroll > Kontrollera igen. I Outlook hittar du detta under Arkiv > Alternativ > E-post > Stavning och autokorrigering

  3. Klicka på Ja när du ser varningsmeddelandet om att återställa stavnings- och grammatikkontrollen.

  4. Klicka på OK i dialogrutan för att gå tillbaka till dokumentet och sedan köra stavnings- och grammatikkontrollen igen.

Vi lyssnar!

Den här artikeln uppdaterades senast av Ben den 28 oktober 2019. Om du tyckte att den var användbar, eller om du inte tyckte det, kan du använda feedbackkontrollerna nedan och lämna några konstruktiva förslag på hur vi kan förbättra den.

Mer information finns i

Testa dokumentets läsbarhet

Stavnings- eller grammatikkontrollen flaggar text som jag inte vill eller förväntar mig att den ska flagga

Välja alternativ för grammatik och skrivregler i Office 2013 eller tidigare

Lägga till ord i ordlistan för stavningskontroll

Stavnings- eller grammatikkontrollen kontrollerar inte ord på ett annat språk på rätt sätt

Välja alternativ för autokorrigering av gemener/versaler, stavning och symboler

Kontrollera stavning innan du skickar ett meddelande i Outlook

Office för Mac-program söker automatiskt efter potentiella stavfel och grammatiska fel medan du skriver. Om du hellre vill vänta med att kontrollera stavning och grammatik tills du skrivit klart kan du stänga av den automatiska kontrollen eller kontrollera all stavning och grammatik på en gång.

Word

Kontrollera stavning och grammatik automatiskt medan du skriver

Word söker automatiskt efter och markerar möjliga stavfel med en röd, vågig linje.

Stavfel markeras med en röd vågig linje

Word söker också automatiskt efter och markerar möjliga grammatiska fel med en grön, vågig linje.

Grammatiskt fel som har markerats med en grön vågig linje

Tips: Om stavfel eller grammatiska fel inte markeras kan det hända att du måste aktivera den automatiska stavnings- och grammatikkontrollen. Det förklaras i nästa procedur.

När du ser ett stavfel eller språkligt fel ska du Ctrl-klicka på ordet eller frasen och välja ett av alternativen.

Grammatiskt fel med en snabbmeny som visar alternativ för att rätta det

Om ett ord felaktigt har markerats som felstavat i Word och du vill lägga till ordet i ordlistan så att Word känner igen det i framtiden läser du Lägga till och redigera ord i en ordlista för stavningskontroll

  1. På menyn Word klickar du på Inställningar > Stavning och grammatik.

  2. I dialogrutan Stavning och grammatik under Stavning, markerar eller avmarkerar du kryssrutan Kontrollera stavning medan du skriver.

  3. Under Grammatik markerar eller avmarkerar du kryssrutan Kontrollera grammatik medan du skriver.

  4. Stäng dialogrutan för att spara ändringarna.

  1. Klicka på Stavning och grammatik på fliken Granska.

  2. Om Word hittar ett möjligt fel öppnas dialogrutan Stavning och grammatik där stavfel visas med röd text och språkliga fel visas med grön text.

  3. Åtgärda ett fel genom att göra något av följande:

    • Ange korrigering i rutan och klicka sedan på Ändra.

    • Under Förslag klickar du på ordet du vill använda och sedan på Ändra.

    Hoppa över felet genom att göra något av följande:

    • Klicka på Ignorera om du vill hoppa över felet en gång.

    • Klicka på Ignorera alla om du vill hoppa över alla förekomster av felet.

    • Om det är ett språkligt fel klickar du på Nästa mening för att hoppa över den förekomsten av felet och flytta till nästa fel.

    Om du vill hoppa över ett felstavat ord i alla dokument klickar du på Lägg till för att lägga till det i ordlistan. Det här fungerar bara för stavfel. Du kan inte lägga till anpassad grammatik i ordlistan.

  4. När du har rättat, ignorerat eller hoppat över ett fel går Word vidare till nästa. När Word har avslutat granskningen av dokumentet visas ett meddelande om att stavnings- och grammatikkontrollen är klar.

  5. Klicka på OK för att återgå till dokumentet.

Du kan rensa eller återställa listan med ignorerade ord och grammatikregler så att Word kontrollerar stavning och grammatik du tidigare angett ska ignoreras.

Obs!: När du återställer listan med ignorerade ord rensas listan bara för det dokument du har öppet. Inga stavfel eller grammatiska problem du angett att Word ska ignorera i andra dokument påverkas.

  1. Öppna det dokument som du vill kontrollera.

  2. På menyn Verktyg pekar du på Stavning och grammatik och klickar sedan på Återställ ignorerade ord och grammatikregler.

    Rensa listorna över ord och grammatikregler som ignoreras i Word genom att klicka på Återställ ignorerade ord och grammatikregler.

    En varning visas om att åtgärden återställer stavnings- och grammatikkontrollen.

    Gör så att Word kontrollerar stavning och grammatik som du tidigare angav att Word skulle ignorera genom att klicka på Ja.
  3. Klicka på Ja för att fortsätta.

  4. Klicka på fliken Granska och sedan på Stavning och grammatik om du vill kontrollera stavning och grammatik.

Outlook

Kontrollera stavning och grammatik automatiskt medan du skriver

Som standard letar Outlook efter stavfel medan du skriver. I Outlook används en streckad röd understrykning för att ange möjliga stavfel och en streckad grön linje för att ange möjliga grammatiska fel.

Stavfel som har markerats med streckad röd understrykning

  1. När du ser ett ord med en streckad understrykning Ctrl-klickar du på ordet eller frasen och väljer ett av alternativen.

    Stavfel med meny som visar alternativ för att rätta det

  2. På snabbmenyn gör du något av följande:

    • Klicka på en av gissningarna högst upp på snabbmenyn.

    • Klicka på Ignorera stavning om du vill ignorera ordet en gång.

    • Klicka på alternativet för att lära in stavningen om du vill lägga till ordet i stavningsordlistan.

När du har öppnat ett e-postmeddelande:

  • Om du vill att stavfel ska korrigeras automatiskt i Outlook går du till Outlook-menyn och klickar på Inställningar. Klicka på Stavning och grammatik under Personliga inställningar. Klicka på rutan bredvid Kontrollera stavning medan du skriver.

  • Om du vill aktivera eller inaktivera automatisk grammatikkontroll går du till Outlook-menyn och klickar på Inställningar. Klicka på Stavning och grammatik under Personliga inställningar. Klicka på rutan bredvid Kontrollera grammatik medan du skriver.

Inställningen Kontrollera stavning medan du skriver

Du kan korrigera alla stavfel och grammatiska fel på samma gång när du skrivit klart ett meddelande eller andra Objekt.

  1. Redigera-menyn pekar du på Stavning och grammatik och klickar sedan på Stavning och grammatik...

  2. Gör något av följande:

    • I listan med förslag klickar du på det ord du vill använda eller anger en ny stavning i rutan högst upp. Klicka sedan på Ändra.

    • Klicka på Ignorera om du vill ignorera ordet och gå vidare till nästa felstavade ord.

    • Klicka på Lägg till om du vill lägga till ordet i stavningsordlistan.

Tips: Kortkommandot för att hoppa till nästa stavfel eller grammatiska fel är KOMMANDO + ; .

PowerPoint

Du kan kontrollera stavning i PowerPoint, men du kan inte kontrollera grammatik.

Kontrollera stavning automatiskt medan du skriver

PowerPoint söker automatiskt efter och markerar möjliga stavfel med en vågig, röd understrykning:

Stavfel markeras med en röd vågig linje

Tips: Om stavfel inte markeras kan det hända att du måste aktivera den automatiska stavningskontrollen. Det förklaras i nästa procedur.

När du ser ett stavfel ska du Ctrl-klicka eller högerklicka på ordet eller frasen och välja ett av förslagen.

  1. Klicka på Alternativ > StavningPowerPoint-menyn.

  2. I dialogrutan Stavning markerar eller avmarkerar du rutan Kontrollera stavning medan du skriver.

  1. Klicka på Stavning på fliken Granska.

  2. Om ett potentiellt fel upptäcks, öppnas fönstret Stavning, där mer information visas.

  3. Åtgärda ett fel genom att göra något av följande:

    • Rätta felet i bilden.

    • Klicka på något av de föreslagna orden i fönstret Stavning. Klicka på Ändra.

    Hoppa över felet genom att göra något av följande:

    • Klicka på Ignorera om du vill hoppa över felet en gång.

    • Klicka på Ignorera alla om du vill hoppa över alla förekomster av felet.

    • Klicka på Lägg till om du vill hoppa över ett felstavat ord i alla dokument och lägga till det i ordlistan.

  4. När du har rättat, ignorerat eller hoppat över ett fel går PowerPoint vidare till nästa. När stavningen i presentationen väl har granskats får du upp ett meddelande om det.

  5. Klicka på OK för att återgå till presentationen.

Excel

Du kan kontrollera stavning i Excel, men du kan inte kontrollera grammatik.

Kontrollera stavning på kommando

  1. Klicka på Stavning på fliken Granska.

    Obs!: Dialogrutan Stavning öppnas inte om inga stavfel identifieras, eller om det ord du försöker lägga till finns redan i ordlistan.

  2. Gör något av följande.

    Om du vill

    Gör följande

    Ändra ordet

    Klicka på det ord du vill använda under Förslag och klicka sedan på Ändra.

    Ändra varje förekomst av ordet i dokumentet

    Klicka på det ord du vill använda under Förslag och klicka sedan på Ändra alla.

    Ignorera ordet och gå vidare till nästa felstavade ord

    Klicka på Ignorera en gång.

    Ignorera alla förekomster av ordet i dokumentet och gå vidare till nästa felstavade ord

    Klicka på Ignorera alla.

Se även

Kontrollera stavning och grammatik på ett annat språk

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×