ICKE (Funktionen ICKE)

Använd funktionen ICKE, en av de logiska funktionerna, när du vill se till att ett värde inte är lika med ett annat.

Exempel

Exempel på funktionen inte att omvända argument.  E.G. = INTE (1 + 1 = 2)

Funktionen ICKE kastar om värdet för sitt argument.

En vanlig användning för funktionen ICKE är att utöka användbarheten för andra funktioner som utför logiska test. Funktionen OM t.ex. utför ett logiskt test och returnerar sedan ett värde som testet utvärderas till SANT och ett annat värde om testet utvärderas till FALSKT. Genom att använda funktionen ICKE som argumentet logiskt_test i funktionen OM kan du testa många olika villkor i stället för bara ett.

Syntax

ICKE(logisk)

Syntaxen för funktionen ICKE har följande argument:

  • Logisk    Obligatoriskt. Detta är ett värde eller ett uttryck som kan vara SANT eller FALSKT.

Anmärkningar

Om logisk är FALSKT, returnerar ICKE SANT; om logiskt är SANT returnerar ICKE FALSKT.

Exempel

Här är några generella exempel för hur du använder ICKE för sig själv och tillsammans med OM, OCH och ELLER.

Exempel på ICKE med funktionerna OM, OCH och ELLER

Formel

Beskrivning

=ICKE(A2>100)

A2 är ICKE större än 100

=OM(OCH(ICKE(A2>1),ICKE(A2<100)),A2,"Värdet ligger utanför intervallet")

50 är större än 1 (SANT), OCH 50 är mindre än 100 (SANT), så ICKE inverterar båda argumenten till FALSKT. OCH kräver att båda argumenten är SANT, så det returnerar resultatet om det är FALSKT.

=OM(ELLER(ICKE(A3<0),ICKE(A3>50)),A3,"Värdet ligger utanför intervallet")

100 inte är mindre än 0 (FALSKT) och 100 är större än 50 (SANT), så ICKE inverterar argumenten till SANT/FALSKT. ELLER kräver bara ett argument för att vara SANT, så det returnerar resultatet om det är SANT.

Beräkning av försäljningsprovision

Här är ett relativt vanligt scenario där vi måste beräkna om säljpersonal är berättigad till en bonus med ICKE med OM och OCH.

Exempel på beräkning av försäljningsbonus med OM, OCH och ICKE.  Formeln i cell E14 är =OM(OCH(ICKE(B14<$B$7),ICKE(C14<$B$5)),B14*$B$8,0)
  • =OM(OCH(ICKE(B14<$B$7),ICKE(C14<$B$5)),B14*$B$8,0)- OM Total försäljning är ICKE mindre är Säljmål, OCH Konton INTE är mindre är Kontomål, multiplicera Total försäljning med Provision-%, i annat fall returnera 0.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Närliggande avsnitt

Video: avancerade om-funktioner
Lär dig hur du kan använda kapslade funktioner i en formel
om funktion
och funktion

,Översikt över formler i Excel
Undvika felaktiga formler
Använd fel kontroll för att hitta fel i formler
i logiska Excel
-funktioner (referens)
funktioner (alfabetisk ordning)
Excel-funktioner (efter kategori)

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×