Funktionen SUMMA.OM

Du använder funktionen SUMMA.OM för att summera värdena i ett område som uppfyller villkor som du anger. Anta exempelvis att du i en kolumn som innehåller tal endast vill summera värden som är större än 5. Du kan då använda följande formel: =SUMMA.OM(B2:B25;">5")

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Det här videoklippet ingår i kursen Addera tal i Excel 2013.

Tips!: 

  • Om du vill kan du använda villkoret för ett område och summera motsvarande värden i ett annat område. Exempelvis summerar formeln =SUMMA.OM(B2:B5; "John"; C2:C5) endast värdena i området C2:C5, där motsvarande celler i området B2:B5 är lika med "John".

  • Information om hur du summerar celler baserat på flera villkor finns i avsnittet Funktionen SUMMA.OMF.

Syntax

SUMIF(range, criteria, [sum_range])

Syntaxen för funktionen SUMMA.OM har följande argument:

  • område   Obligatoriskt. Det cellområde som du vill beräkna baserat på villkoren. Celler i varje område måste vara tal eller namn, matriser eller referenser som innehåller tal. Tomma värden och textvärden ignoreras. Det valda området kan innehålla datum i normalt Excel-format (exempel finns nedan).

  • villkor   Obligatoriskt. Villkor i form av tal, uttryck, cellreferenser, text eller funktioner som anger vilka celler som ska läggas till. Villkoren kan exempelvis anges som 32, ">32", B5, "32", "äpplen" eller IDAG().

    Viktigt!: Alla textvillkor eller villkor som innehåller logiska eller matematiska symboler måste skrivas inom dubbla citattecken ("). Om villkoren är numeriska krävs inte dubbla citattecken.

  • summaområde   Valfritt. De faktiska celler du vill lägga till, om du vill lägga till andra celler än de som anges i argumentet område. Om argumentet summaområde utelämnas lägger Excel till de celler som anges i argumentet område (samma celler som villkoren används för).

  • Du kan använda jokertecken – frågetecken (?) och asterisk (*) – som argumentet villkor. Ett frågetecken representerar ett obestämt enskilt tecken och en asterisk representerar en obestämd teckenföljd. Om du vill söka efter ett verkligt frågetecken eller en verklig asterisk anger du ett tildetecken (~) före tecknet.

Kommentarer

  • Funktionen SUMMA.OM returnerar ogiltiga resultat när du använder den för att matcha strängar som är längre än 255 tecken eller mot strängen #VÄRDE!.

  • Argumentet summaområde måste inte ha samma storlek och form som argumentet område. Vilka faktiska celler som läggs till identifieras med hjälp av cellen längst upp till vänster i argumentet summaområde som startcell och därefter inkluderas celler som motsvarar storlek och form för argumentet område. Till exempel:

Om område är

Och summaområde är

Summeras cellerna

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Om argumenten område och summaområde för funktionen SUMMA.OM inte innehåller samma antal celler kan det ta längre tid än väntat att beräkna om kalkylbladet.

Exempel

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. Om du vill visa formelresultaten markerar du formlerna, trycker på F2 och sedan på Retur. Om det behövs kan du ändra kolumnbredden så att alla data visas.

Egendomsvärde

Provision

Data

100 000 kr

7 000 kr

250 000 kr

200 000 kr

14 000 kr

300 000 kr

21 000 kr

400 000 kr

28 000 kr

Formel

Beskrivning

Resultat

=SUMMA.OM(A2:A5;">160000";B2:B5)

Summan av provisionen för egendomsvärdena över 160 000 kr.

63 000 kr

=SUMMA.OM(A2:A5;">160000")

Summan av egendomsvärden över 160 000 kr.

900 000 kr

=SUMMA.OM(A2:A5;300000;B2:B5)

Summan av provisioner för egendomsvärden lika med 300 000 kr.

21 000 kr

=SUMMA.OM(A2:A5;">" & C2;B2:B5)

Summan av provisioner för egenskapsvärden större än värdet i C2.

49 000 kr

Exempel 2

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. Om du vill visa formelresultaten markerar du formlerna, trycker på F2 och sedan på Retur. Om det behövs kan du ändra kolumnbredden så att alla data visas.

Kategori

Mat

Försäljning

Grönsaker

Tomater

2 300 kr

Grönsaker

Selleri

5 500 kr

Frukt

Apelsiner

800 kr

Smör

400 kr

Grönsaker

Morötter

4 200 kr

Frukt

Äpplen

1 200 kr

Formel

Beskrivning

Resultat

=SUMMA.OM(A2:A7;"Frukt";C2:C7)

Summan av försäljningen av alla livsmedel i kategorin "Frukt".

2 000 kr

=SUMMA.OM(A2:A7;"Grönsaker";C2:C7)

Summan av försäljningen av alla livsmedel i kategorin "Grönsaker".

12 000 kr

=SUMMA.OM(B2:B7;"*er";C2:C7)

Summan av försäljningen av alla livsmedel som slutar med "er" (tomater, apelsiner och morötter).

4 300 kr

=SUMMA.OM(A2:A7;"";C2:C7)

Summan av försäljningen av alla livsmedel som ingen kategori har angetts för.

400 kr

Överst på sidan

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Se även

Med funktionen SUMMA.OMF lägger du till alla argument som uppfyller flera villkor

Med funktionen KVADRATSUMMA summerar du flera värden när en kvadrering har utförts på vart och ett av dem

Med funktionen ANTAL.OM räknar du endast de värden som uppfyller ett villkor

Med funktionen ANTAL.OMF räknar du endast de värden som uppfyller flera villkor

Funktionen IFS (Office 365, Excel 2016 och senare)

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Funktioner inom matematik och trigonometri

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×