Formler och funktioner

Funktionen SUMMA

Funktionen SUMMA

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Du lägger till värden med funktionen SUMMA, som ingår i matematiska och trigonometriska funktioner. Du kan lägga till enskilda värden, cellreferenser eller områden eller en blandning av alla tre.

Till exempel:

  • =SUMMA(A2:A10)

  • =SUMMA(A2:A10, C2:C10)

Din webbläsare har inte stöd för video. Installera Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

SUMMA(tal1,[tal2],...)

Argumentnamn

Beskrivning

tal1   . (obligatoriskt)

Det första talet som ska läggas till. Det kan vara en siffra som 4, en cellreferens som B6 eller ett cell- område som B2:B8.

tal2-255    (valfritt)

Det här är det andra talet du vill lägga till. Du kan ange upp till 255 tal på det här sättet.

I det här avsnittet beskrivs några beprövade metoder för att arbeta med SUMMA-funktionen. Mycket av det här kan användas för att arbeta med andra funktioner också.

Metoden =1+2 eller =A+B – Du kan skriva =1+2+3 eller =A1+B1+C2 och få helt korrekta resultat, men de här metoderna blir lätt fel av flera orsaker:

  1. Skrivfel – föreställ dig att du försöker ange fler och/eller mycket större värden som dessa:

    • =14598.93+65437.90+78496.23

    Försök att verifiera att posterna är korrekta. Det är mycket enklare att placera dessa värden i enskilda celler och använda en SUMMA-formel. Du kan också formatera värdena när de är i celler, vilket gör dem mycket mer lättlästa sedan när de ingår i en formel.

    Använda funktionen SUMMA i stället för hårdkodningsvärden i formler.  Formeln i cell D5 är =SUMMA(D2:D4)
  2. #VÄRDEFEL! fel vid referens av text i stället för tal

    Om du använder en formel som:

    • =A1+B1+C1 or =A1+A2+A3

    Exempel på en dålig formelkonstruktion.  Formeln i cell D2 är =A2+B2+C2

    Formeln kan bli fel om det finns icke-numeriska värden (text) i de refererade cellerna, vilket returnerar felet #VÄRDEFEL!. SUMMA ignorerar textvärden och ger dig bara summan av numeriska värden.

    Rätt formelkonstruktion.  Istället för =A2+B2+C2 är formeln för cell D2 =SUMMA(A2:C2)
  3. #REFERENS! fel vid borttagning av rader eller kolumner

    Felet #REFERENS! som orsakas av att en kolumn har tagits bort.  Formeln har ändrats till =A2+#REFERENS!+B2

    Om du tar bort en rad eller en kolumn uppdateras inte formeln så att den exkluderar den borttagna raden, och ett #REFERENS!-fel uppstår där en SUMMA-funktion uppdateras automatiskt.

    SUMMA-funktionen justeras automatiskt för infogade eller borttagna rader och kolumner
  4. Formler uppdaterar inte referenser när du infogar rader eller kolumner

    =A+B+C-formler uppdateras inte om du lägger till rader

    Om du infogar en rad eller kolumn uppdateras inte formeln så att den inkluderar den tillagda raden där en SUMMA-funktion uppdateras automatiskt (förutsatt att du inte är utanför området som formeln refererar till). Det här är extra viktigt om du förväntar dig att formeln ska uppdatera och inte gör det, eftersom det ger dig ofullständiga resultat som du kanske inte upptäcker.

    Exemplet återger en SUMMA-formel som automatiskt expanderade från =SUMMA(A2:C2) till =SUMMA(A2:D2) när en kolumn infogades
  5. SUMMA med enskilda cellreferenser jämfört med Områden

    Med hjälp av en formel som:

    • =SUMMA(A1,A2,A3,B1,B2,B3)

    blir det lika lätt fel när du infogar eller tar bort rader i det refererade området av samma orsaker. Det är mycket bättre att använda enskilda områden som:

    • =SUMMA(A1:A3,B1:B3)

    som uppdateras när du lägger till eller tar bort rader.

Problem

Vad gick fel

Min SUMMA-funktion visar #####, inte resultatet.

Kontrollera kolumnbredden. ##### innebär vanligtvis att kolumnen är för smal för att visa resultatet av formeln.

SUMMA-funktionen visar själva formeln som text, inte resultatet.

Kontrollera att cellen inte är formaterad som text. Markera cellen eller området i fråga och använd Ctrl+1 så att dialogrutan Formatera celler visas, och klicka på fliken Tal och välj det format du vill ha. Om cellen är formaterad som text och inte ändras när du ändrar formatet kan du behöva använda F2 > RETUR för att tvinga format att ändras.

Funktionen SUMMA uppdateras inte.

Kontrollera att Beräkning är inställd på Automatisk. På fliken Formel går du till Beräkningsalternativ. Du kan också använda F9 för tvinga kalkylbladet att beräkna.

Kontrollera att Beräkning är inställd på Automatisk.  På fliken Formel går du till Beräkningsalternativ.

Vissa värden adderas inte.

Endast numeriska värden kan adderas i funktionerna referens eller intervall. Tomma celler, logiska värden som SANT eller text ignoreras.

Felvärdet #NAMN? visas i stället för det förväntade resultatet.

Det här betyder vanligtvis att formeln är felstavad, som =summe(A1:A10) i stället för = SUMMA(a1:A10).

Funktionen SUMMA visar ett heltal, men den borde visa decimaler

Kontrollera cellformateringen så att du säkert vet att du valt att visa decimaler. Markera cellen eller området i fråga och använd Ctrl+1 så att dialogrutan Formatera celler visas, klicka på fliken Tal och välj format. Var noga med att ange det antal decimaler du vill ha.

  1. Jag vill bara addera/subtrahera/multiplicera/dividera tal Se den här videoserien om grundläggande matematiska beräkningar i Excel, eller Använda Excel som miniräknare.

  2. Hur visar jag fler/färre decimaler? Du kan ändra talformatet. Markera cellen eller området i fråga och använd Ctrl+1 så att dialogrutan Formatera celler visas. Klicka på fliken Tal och välj format. Var noga med att ange det antal decimaler du vill ha.

  3. Hur gör jag för att addera eller subtrahera gånger? Du kan addera och subtrahera gånger på ett par olika sätt. För att till exempel få fram skillnaden mellan 8:00 AM – 12:00 PM för löneändamål kan du använda: =("12:00 PM"-"8:00 AM")*24, det vill säga ta sluttiden minus starttiden. Observera att Excel beräknar gånger som en del av en dag, vilket innebär att du måste multiplicera med 24 för att få det totala antalet timmar. I det första exemplet använder vi =((B2-A2)+(D2-C2))*24 för att få summan av timmar från början till slut, minus en lunchpaus (8,50 timmar totalt).

    Om du bara adderar timmar och minuter och vill visa det på det sättet kan du summera, och behöver följaktligen inte multiplicera med 24. I det andra exemplet använder vi alltså =SUMMA(A6:C6) eftersom vi bara behöver det totala antalet timmar och minuter för tilldelade uppgifter (5:36, eller 5 timmar, 36 minuter).

    Beräkna gånger

    Mer information finns i: Addera eller subtrahera tid.

  4. Hur får jag skillnaden mellan datum? Du kan addera och subtrahera datum som med gånger. Här är ett mycket vanligt exempel på hur man räknar antalet dagar mellan två datum. Det är så enkelt som = B2-A2. Nyckeln till att arbeta med både datum och tider är att du börjar med slutdatum/sluttid och subtraherar startdatum/starttid.

    Beräkna skillnaden mellan datum

    Fler sätt att arbeta med datum finns i Beräkna skillnaden mellan två datum.

  5. Hur gör jag för att summera enbart synliga celler? Ibland när du döljer rader manuellt eller använder AutoFilter för att bara visa vissa data vill du kanske även endast summera de synliga cellerna. Du kan använda funktionen DELSUMMA. Om du använder en summarad i en Excel-tabell anges alla funktioner som du väljer från den nedrullningsbara listrutan Summa automatiskt som delsummor. Läs mer om hur du kan summera data i en Excel-tabell.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Mer information finns i

Mer information om SUMMA

Med funktionen SUMMA.OM lägger du endast till värden som uppfyller ett enda villkor

Med funktionen SUMMA.OMF lägger du endast till värden som uppfyller flera villkor

Med funktionen ANTAL.OM räknar du endast de värden som uppfyller ett villkor

Med funktionen ANTAL.OMF räknar du endast de värden som uppfyller flera villkor

Översikt över formler i Excel

Hur du undviker felaktiga formler

Hitta och korrigera fel i formler

Tangentbordsgenvägar i Excel för Windows

Kortkommandon i Excel för Mac

Funktioner inom matematik och trigonometri

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×