Formler och funktioner

Funktionen OM

Funktionen OM

Obs!: Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Om-funktionen är en av de mest populära funktionerna i Excel och du kan göra logiska jämförelser mellan ett värde och vad du förväntar dig.

Därför kan ett OM-uttryck ha två resultat. Det första resultatet är för om jämförelsen är sann och det andra är för om jämförelsen är falsk.

=OM(C2=”Ja”,1,2) betyder till exempel OM(C2 = Ja, returnera 1, annars returnera 2).

Hur du använder om:

  1. Markera en cell. Typ = om och en vänsterparentes (.

  2. Lägg till det villkor du vill testa och skriv ett kommatecken.

  3. Lägg till värdet som ska returneras om villkoret är sant och skriv ett kommatecken.

  4. Lägg till värdet som ska returneras om villkoret är falskt och skriv en högerparentes ).

  5. Tryck på Retur.

  6. Dra i handtaget för att använda funktionen om andra rader om det behövs.

Enkla exempel med OM

Cell D2 innehåller formeln =OM(C2="Ja";1;2)
  • =OM(C2=”Ja”,1,2)

I exemplet ovan anger cell D2: OM(C2 = Ja, returnera 1, annars, returnera 2)

Cell D2 innehåller formeln =OM(C2=1,"JA","NEJ")
  • =OM(C2=1,”Ja”,”Nej”)

I det här exemplet anger att formeln i cell D2: IF(C2 = 1, then return Yes, otherwise return No)som visas om-funktionen kan användas för att utvärdera både text och värden. Det kan även användas för att utvärdera fel. Du är inte begränsad till att bara kontrollera om en sak är lika med en annan och returnera ett enda resultat kan du också använda matematiska operatorer och ytterligare beräkningar beroende på dina villkor. Du kan även kapsla flera om-funktioner tillsammans för att kunna utföra flera jämförelser.

Formeln i cell D2 är =OM(C2>B2; "Över Budget", "Inom Budget")
  • = OM(C2>B2,”Över budget”,”Inom budget”)

I exemplet ovan anger OM-funktionen i D2 OM(C2 är större än B2, returnera ”Över Budget”, annars, returnera ”Inom Budget”)

Formeln i cell E2 är =OM(C2>B2;C2-B2;"")
  • =OM(C2>B2;C2-B2;0)

I exemplet ska vi returnera en matematisk beräkning i stället för ett textresultat. Formeln i E2 säger alltså OM(Faktiskt är större än Budgeterat, subtrahera Budgeterat belopp från Faktiskt belopp, annars returnera ingenting).

Formeln i Cell F7 är OM(E7="Ja";F5*0,0825;0)
  • =OM(E7=”Ja”;F5*0,0825;0)

I det här exemplet säger formeln i F7 OM(E7 = ”Ja”, beräkna totalbeloppet i F5 * 8,25 %, annars krävs ingen moms så returnera 0)

Obs!: Om du ska använda text i formler måste du skriva texten inom citattecken (t.ex. ”Text”). Det enda undantaget till detta är om du använder SANT eller FALSKT, vilket Excel förstår automatiskt.

Vanliga problem

Problem

Något gick fel

0 (noll) i cell

Det fanns inget argument för vare sig värde_om_sant eller värde_om_falskt. För att få rätt värde returnerat ska du lägga till argumenttext för de två argumenten, eller lägga till SANT eller FALSKT för argumentet.

#NAMN? i cell

Det här betyder vanligtvis att formeln är felstavad.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Se även

Beräkningsoperatorer och operatorer i Excel

Använda kapslade funktioner i en formel

Använda OM för att kontrollera om en cell är tom

Video: Avancerade OM-funktioner

Funktionen IFS (Office 365, Excel 2016 och senare)

Avancerade OM-funktioner – Arbeta med kapslade funktioner och undvika fallgropar

Utbildningsvideor: Avancerade OM-funktioner

Funktionen ANTAL.OM räknar värden baserat på ett enda villkor

Funktionen ANTAL.OMF räknar värden baserat på flera villkor

Funktionen SUMMA.OM räknar värden baserat på ett enda villkor

Funktionen SUMMA.OMF räknar värden baserat på flera villkor

Funktionen AND

Funktionen ELLER

Funktionen LETARAD

Översikt över formler i Excel

Hur du undviker felaktiga formler

Använd felkontroll om du vill hitta fel i formler

Logiska funktioner

Excel-funktioner (alfabetisk ordning)

Excel-funktioner (efter kategori)

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×