Använda PRODUKTSUMMA när du vill summera produkten av motsvarande värden i en eller flera matriser

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

PRODUKTSUMMA använder cellområden (eller matriser) som argument (de delar av formeln som gör det fungerar). Den multiplicerar tillsammans objekt i matriserna och sedan summeras resultatet.

Det här exemplet är en inköpslista, där en matris innehåller kostnaden för varje objekt och den andra matrisen anger hur många objekt som ska köpas.

Priser och kvantiteter som ska multipliceras och sedan summeras

  1. Om du vill skapa formeln genom att ange =PRODUKTSUMMA(B3:B6;C3:C6) och tryck på RETUR.

Varje cell i kolumn B multipliceras med motsvarande cell på samma rad i kolumn C, och resultaten adderas sedan. Det totala beloppet för varorna är 129,60 kr.

  1. För att använda en längre formel som ger samma resultat, typ = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 och tryck på RETUR.

När du trycker på Retur blir resultatet detsamma: 129,60 kr. Cell B3 multipliceras med C3, och resultatet adderas med resultatet av cell B4 gånger cell C4 och så vidare. Du kan tänka dig hur mycket enklare det är att använda PRODUKTSUMMA om du har tusentals (eller bara hundratals) rader.

Meddelanden: 

  • Kolumnerna eller raderna (matriserna) måste vara lika långa.

  • Om en cell innehåller text i stället för ett tal behandlas det som noll.

Exempel

Om du vill experimentera med PRODUKTSUMMA och matriserär här en Excel Online-arbetsbok med andra data än de vi använder i den här artikeln.

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

A

B

D

R

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Resultat

'=PRODUKTSUMMA(A2:B4;D2:E4)

=PRODUKTSUMMA(A2:B4;D2:E4)

Multiplicerar de två matrisernas alla komponenter (A2:B4 och D2:E4) och lägger sedan till produkterna – d.v.s 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Du kan också öppna den här arbetsboken i Excel för en utförligare upplevelse. Klickar du på Excel-ikonen i det nedre högra hörnet av arbetsboken Excel-ikon i Excel Online , spara filen på en lämplig plats på datorn och öppna den.

Överst på sidan

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×