Använda funktioner och kapslade funktioner i Excel-formler

Funktioner är fördefinierade formler som utför beräkningar med hjälp av särskilda värden, så kallade argument, i en viss ordning eller struktur. Funktioner kan användas för att utföra enkla eller komplexa beräkningar. Du hittar alla Excel-funktioner på fliken Formler i menyfliksområdet:

Fliken Formler i menyfliksområdet i Excel
  • Syntax för Excel-funktioner

    Följande exempel med funktionen AVRUNDA som avrundar ett tal i cell A10 illustrerar syntaxen för en funktion.

    Struktur på en funktion

    1. Struktur. Strukturen i en funktion börjar med ett likhetstecken (=) följt av funktionsnamnet, en inledande parentes, argumenten för funktionen avgränsade med semikolon och en avslutande parentes.

    2. Funktionsnamn. Om du vill visa en lista över tillgängliga funktioner klickar du i en cell och trycker på SKIFT+F3. Då öppnas dialogrutan Infoga funktion.

    Formler – dialogrutan Infoga funktion i Excel

    3. Arguments. Argumenten kan vara tal, text, logiska värden som SANT eller FALSKT, matriser, felvärden som #SAKNAS! eller cellreferenser. Det argument du anger måste ge ett giltigt värde för det argumentet. Argument kan även vara konstanter, formler eller andra funktioner.

    4. Argumentbeskrivningar. En beskrivning med syntax och argument visas medan du skriver funktionen. Skriv t.ex. =AVRUNDA( varpå beskrivningen visas. Beskrivningar visas endast för inbyggda funktioner.

    Obs!: Du inte behöver skriva funktioner med versaler, t.ex. =AVRUNDA, eftersom funktionsnamn i gemener automatiskt ändras till versaler när du trycker på Retur. Om du stavar ett funktionsnamn fel, t.ex. skriver =SUMA(A1:A10) i stället för =SUMMA(A1:A10), returneras ett #NAMN?-fel i Excel.

  • Ange Excel-funktioner

    När du skapar en formel som innehåller en funktion kan du använda dialogrutan Infoga funktion när du vill lägga till kalkylbladsfunktioner. När du väljer en funktion i dialogrutan Infoga funktion öppnas en funktionsguide där namnet på funktionen visas, dess argument, en beskrivning av funktionen och de olika argumenten, funktionens aktuella resultat och hela formelns aktuella resultat.

    Funktionsguiden i Excel

    Genom att använda funktionen Komplettera automatiskt för formel kan du snabbt skapa och redigera formler samtidigt som risken för syntaxfel minimeras. När du har skrivit ett likhetstecken (=) och de första bokstäverna i funktionsnamnet visas en dynamisk listruta under cellen med giltiga funktioner, argument och namn som matchar bokstäverna. Om du markerar ett alternativ i listrutan infogas det automatiskt.

    Komplettera automatiskt för formel i Excel

  • Kapsla Excel-funktioner

    Ibland kan du vara tvungen att använda en funktion som ett av argumenten i en annan funktion. T.ex. använder följande formel en kapslad MEDEL-funktion och jämför värdet med 50.

    Kapslade funktioner

    1. Funktionerna MEDEL och SUMMA är kapslade inom funktionen OM.

    Giltiga returvärden     När en kapslad funktion används som argument måste den kapslade funktionen returnera samma typ av värde som argumentet använder. Om argumentet t.ex. returnerar värdet SANT eller FALSKT måste den kapslade funktionen också returnera värdet SANT eller FALSKT. Om den inte gör det visas felvärdet #VÄRDEFEL!

    Nivåbegränsningar vid kapsling    En formel kan innehålla upp till sju nivåer med kapslade funktioner. När en funktion (vi kallar den funktion B) används som argument i en annan funktion (vi kallar den funktion A), fungerar funktion B som en funktion på den andra nivån. Både MEDEL och SUMMA är funktioner på den andra nivån, om de används som argument för funktionen OM. Om en funktion kapslas inuti den kapslade funktionen MEDEL är den en funktion på den tredje nivån och så vidare.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×