Office
Logga in

Använd argumentet tabellmatris i funktionen LETAUPP

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

När du skapar en formel som använder funktionerna LETARAD eller LETAKOLUMN kan ange du tabellmatrisargumentet är ett cellområde, till exempel D2:F39. Funktionen söker området för de data som du försöker hitta.

Tabellmatrisargumentet är alltid det andra argumentet i en LETARAD- eller LETAKOLUMN-funktion (det första argumentet är värdet du försöker hitta). Funktionerna fungerar inte utan tabellmatrisargumentet.

Det första argumentet kan vara ett specifikt värde som "41" eller "svensson", eller en cellreferens som F2. Det första argumentet ser ut så här:

=LETARAD(F2; ...

Tabellmatrisargumentet följer alltid på uppslagsvärdet, så här:

=LETARAD(F2;B4:D39; ...

Cellområdet som listas i tabellmatrisargumentet kan anges med relativa eller absoluta cellreferenser. Om du ska kopiera formeln till andra celler måste du använda absoluta cellreferenser (observera dollartecknen), så här:

=LETARAD(F2;$B$2:BD$39; ...

Om celler i tabellmatrisargumentet är på ett annat kalkylblad i arbetsboken ska argumentet innefatta kalkylbladets namn följt av ett utropstecken. Syntaxen ser ut så här:

=LETARAD(F2;Blad2!$C$14:E$42; ...

Den kolumn som innehåller de värden du försöker hitta är det tredje argumentet du anger. Det här kallas för uppslagskolumnen. Om de värden du vill se finns i kolumn D (den tredje kolumnen i tabellmatrisen) är det sista argumentet 3.

=LETARAD(F2;B4:D39;3)

Även om det är valfritt, rekommenderar vi att du använder ett fjärde argument, antingen Sant eller Falskt. Använd Falskt om du letar efter en exakt matchning.

=LETARAD(F2;B4:D39;3;Falskt)

Om du använder Sant eller lämnar det fjärde argumentet tomt returnerar funktionen en ungefärlig matchning till värdet i det första argumentet. Om det första argumentet är "berg" och du använder Sant returnerar funktionen LETARAD "Berg", "Bergholm" och så vidare. Men om du använder Falskt returnerar funktionen bara "Berg", en exakt matchning, och det är det de flesta vill.

För att göra det ännu knepigare att använda Sant kan funktionen returnera fel resultat om uppslagskolumnen – den kolumn du angav i det tredje argumentet – inte sorterar i stigande ordning (A till Ö eller lägsta till högsta tal).

Mer information om funktionerna LETARAD och LETAKOLUMN finns uppslags- och referensfunktioner (referens).

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×