Använd argumentet tabellmatris i funktionen LETAUPP

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

När du har skapat en LETARAD eller LETAKOLUMN funktion kan ange du ett cellområde, till exempel D2:F39. Området kallas tabellmatrisargumentet och ett argument är bara en del av data som en funktion behöver för att kunna köra. Funktionen söker i det här fallet cellerna för de data som du försöker hitta.

Argumentet tabellmatris är alltid det andra argumentet i funktionerna LETARAD eller LETAKOLUMN (det första är värdet du försöker hitta) och funktionerna fungerar inte utan det.

Det första argumentet, det värdet du försöker hitta, kan vara ett specifikt värde som "41" eller "svensson" eller en cellreferens om F2. Så det första argumentet kan se ut så här:

= LETARAD (F2, ...

Argumentet tabellmatris följer alltid uppslagsvärdet, så här:

= LETARAD (F2, B4:D39, ...

Cellområdet listas i argumentet tabellmatris kan använda relativa eller absoluta cellreferenser. Om du ska kopiera funktionen måste du använda absoluta referenser, så här:

= LETARAD (F2, $B$ 2: BD$ 39, ...

Cellerna i argumentet tabellmatris kan också vara på ett annat kalkylblad i arbetsboken. I så fall innefattar argumentet bladnamnet, och syntaxen ser ut så här:

= LETARAD (F2, Blad2! $C$ 14: E$ 42, ...

Kontroller att du skriver ett utropstecken efter bladnamnet.

Slutligen anger (whew), du en tredje argumentet kolumnen som innehåller de värden som du försöker hitta. Detta kallas min uppslagskolumn. I exemplet första används cellområdet B4 till D39 som löper över tre kolumner. Nu ska vi låtsas att de värden du vill se live i kolumn D, den tredje kolumnen i den cellområden, så att det sista argumentet är 3.

=LETARAD(F2;B4:D39;3)

Du kan använda ett valfritt fjärde argument, antingen Sant eller Falskt. Oftast vill du använda Falskt.

Om du använder Sant eller lämnar det fjärde argumentet tomt returnerar funktionen en ungefärlig match till värdet i det första argumentet. För att fortsätta exemplet: Om det första argumentet är "berg" och du använder Sant returnerar funktionen "Berg", "Bergholm" och så vidare. Men om du använder Falskt returnerar funktionen bara "Berg", en exakt match, och det är det de flesta vill.

Effektivisera användningen av SANT även svårare om din uppslagskolumn – den kolumn som du anger i din tredje argumentet – är inte sorterad i stigande ordning (A till ö eller lägsta till högsta talet), funktionen kan returnera fel resultatet. Mer information om som finns i Slå upp värden med LETARAD och andra funktioner.

Mer information om funktionerna LETARAD och LETAKOLUMN finns i:

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×