Visa, hantera och installera tillägg i Office-program

När du aktiverar ett tillägg lägger du till anpassade kommandon och nya funktioner i Office-program, som hjälper dig att höja produktiviteten. Eftersom tillägg kan utnyttjas av hackare för att skada datorn kan du använda säkerhetsinställningarna för tillägg för att ändra deras beteende.

Klicka på en rubrik nedan för mer information.

Klicka på Aktivera innehåll i meddelandefältet om du vet att tillägget kommer från en pålitlig källa.

Meddelandefältet med meddelandet En del aktivt innehåll har inaktiverats

Du kan visa och ändra inställningarna för tillägg i Säkerhetscenter, vilket beskrivs i följande avsnitt. Om säkerhetsinställningarna för tilläggen har angetts av ditt företag kanske du inte kan ändra alla alternativ.

  1. Klicka på Arkiv > Alternativ.

  2. Klicka på Säkerhetstjänster > Inställningar för Säkerhetscenter > Tillägg.

  3. Markera eller avmarkera önskade rutor.

Delen Tillägg i Säkerhetscenter

  • Kräv att programtillägg ska vara signerade av en betrodd utgivare     Markerad den här rutan om du vill att Säkerhetscenter ska kontrollera att tillägget kommer från en betrodd utgivare. Om utgivaren inte har definierats som betrodd initieras inte tillägget i Office-programmet och det visas ett meddelande om att tillägget har inaktiverats.

  • Inaktivera meddelande om osignerade tillägg (koden är fortsatt inaktiverad)     När du markerar rutan Kräv att programtillägg ska vara signerade av en betrodd utgivare blir det här alternativet tillgängligt. Tillägg som är signerade av en betrodd utgivare aktiveras, men osignerade tillägg inaktiveras.

  • Inaktivera alla programtillägg (kan försämra funktionaliteten)     Markera den här rutan om inga tillägg ska vara betrodda. Alla tillägg inaktiveras utan meddelande, och de övriga rutorna för tillägg blir otillgängliga.

Obs!: Den här inställningen börjar gälla först efter att du har avslutat och sedan startat om Office-programmet.

Om du arbetar med tillägg kanske du behöver veta mer om digitala signaturer och certifikat, som autentiserar ett tillägg, och om betrodda utgivare, alltså de programvaruutvecklare som ofta skapar tillägg.

  1. Klicka på Arkiv > Alternativ > Tillägg.

  2. Markera respektive tillägg så visas tilläggets namn, utgivaren, kompatibilitet, tilläggets lagringsplats på datorn, samt en beskrivning av tilläggets funktioner.

Visa delen Tillägg i Säkerhetscenter

Obs!: Om tillägget har blockerats av dataexekveringsskyddet (DEP) kan du läsa mer om det i Varför kraschar programtillägget?

  • Aktiva programtillägg     Alla tillägg som är registrerade och som används i Office-programmen.

  • Inaktiva programtillägg     Alla tillägg som finns på datorn men som inte är inlästa för tillfället. XML-scheman är exempelvis bara aktiva när dokumentet som hänvisar till dem är öppet. Ett annat exempel är COM-tillägg. Om kryssrutan för ett COM-tillägg är markerad, är tillägget aktivt. Om kryssrutan för ett COM-tillägg är avmarkerad, är tillägget inaktivt.

  • Dokumentrelaterade tillägg     Mallfiler som öppna dokument hänvisar till.

  • Avstängda programtillägg    Tillägg som har inaktiverats automatiskt eftersom de leder till att Office-program kraschar.

  • Tillägg     Tilläggets namn.

  • Utgivare     Den programvaruutvecklare eller det företag som har skapat tillägget.

  • Kompatibilitet     Läs om eventuella kompatibilitetsproblem.

  • Plats     Den här sökvägen anger var på datorn tillägget har installerats.

  • Beskrivning Den här texten beskriver hur tillägget fungerar.

Obs!: Det finns ett tilläggsalternativ för Microsoft Outlook i Säkerhetscenter, Använd inställningarna för makrosäkerhet för installerade tillägg. Det finns inga säkerhetsinställningar för tillägg för InfoPath.

Följ anvisningarna nedan när du hanterar och installerar tillägg.

  1. Klicka på Arkiv > Alternativ > Tillägg.

  2. Välj en typ av tillägg.

  3. Klicka på OK.

  4. Välj vilka tillägg du vill lägga till, ta bort, läsa in eller överföra. Du kan också bläddra och leta upp tillägg som du vill installera.

Om du prenumererar på ett tillägg via Office Store som du inte vill ha i fortsättningen kan du avbryta prenumerationen

  1. Öppna Office-programmet och gå till fliken Infoga i menyfliksområdet.

  2. Klicka på Mina tillägg i gruppen Tillägg

    På fliken Infoga i menyfliksområdet hittar du gruppen Tillägg där du kan hantera Excel-tillägg
  3. Välj Hantera mina tillägg

    I dialogrutan Office-tillägg visas de tillägg du har installerat. Klicka på Hantera mina tillägg för att hantera dem.
  4. Klicka på det program du vill avbryta och sedan på Hantera prenumeration under Åtgärd.

  5. I avsnittet Betalning och fakturering väljer du Avbryt prenumeration.

  6. Klicka på OK och sedan på Fortsätt.

När du är klar visas meddelandet "Du har avbrutit programprenumerationen" i kommentarsfältet i programlistan.

Vissa tillägg kanske inte är kompatibla med IT-avdelningens principer. Om detta är fallet för tillägg som nyligen installerats för Office-program inaktiveras tilläggen av dataexekveringsskyddet och programmet kanske kraschar.

Mer om DEP

Snabbreferens

Klicka på en rubrik nedan för mer information.

När du installerar den Microsoft Office 2007-systemet installeras flera COM-tillägg och registreras automatiskt på datorn.

Word, Excel, Access och PowerPoint

  1. Klicka på Microsoft Office-knappen Bild av Office-knappen , klicka på knappen Alternativ och sedan på Tillägg.

  2. Visa tillägg och programtillägg som kategoriserats enligt följande:

    • Aktiva programtillägg     Lista med de tillägg som är registrerade och som används i Office-programmen.

    • Inaktiva programtillägg    Lista med de tillägg som finns på datorn men som inte är inlästa. Till exempel är smarta etiketter eller XML-scheman endast aktiva när dokumentet som hänvisar till dem är öppet. Ett annat exempel är COM-tillägg som listas i dialogrutan COM-tillägg. Om kryssrutan för ett COM-tillägg är markerad är tillägget aktivt. Om kryssrutan för ett COM-tillägg är avmarkerad är tillägget inaktivt. Information om hur du öppnar dialogrutan COM-tillägg finns i nästa avsnitt, Inaktivera eller hantera installerade tillägg.

    • Relaterade dokument Tillägg    Lista med mallfiler som refereras till i öppna dokument.

    • Avstängda programtillägg     Lista med tillägg som har inaktiverats automatiskt eftersom de leder till att Office-program kraschar.

Outlook, InfoPath, Publisher och Visio

  1. Verktyg-menyn klickar du på Säkerhetscenter och sedan på Tillägg.

  2. Visa tillägg och programtillägg som kategoriserats enligt följande:

    • Aktiva programtillägg     Lista med de tillägg som är registrerade och som används i Office-programmen.

    • Inaktiva programtillägg    Lista med de tillägg som finns på datorn men som inte är inlästa. Till exempel är smarta etiketter eller XML-scheman endast aktiva när dokumentet som hänvisar till dem är öppet. Ett annat exempel är COM-tillägg som listas i dialogrutan COM-tillägg. Om kryssrutan för ett COM-tillägg är markerad är tillägget aktivt. Om kryssrutan för ett COM-tillägg är avmarkerad är tillägget inaktivt. Information om hur du öppnar dialogrutan COM-tillägg finns i nästa avsnitt, Inaktivera eller hantera installerade tillägg.

    • Dokument tillägg    Lista med mallfiler som refereras till av öppna dokument.

    • Avstängda programtillägg     Lista med tillägg som har inaktiverats automatiskt eftersom de leder till att Office-program kraschar.

Hantera tillägg kan innebära att aktivera eller inaktivera ett tillägg, lägga till eller ta bort ett tillägg och göra ett tillägg aktivt eller inaktivt.

Word, Excel, Access och PowerPoint

  1. Klicka på Microsoft Office-knappen Bild av Office-knappen , sedan på Word-alternativ och på Tillägg.

  2. I rutan Tillägg, identifiera det tillägg du vill aktivera eller inaktivera och kontrollera tilläggstypen i kolumnen Typ .

  3. Välj tilläggstypen i rutan Hantera och klicka sedan på .

  4. Markera eller avmarkera kryssrutan för de tillägg som du vill aktivera eller inaktivera och klicka sedan på OK.

Obs!: Tillägg av typen Dokumentkontroll aktiveras med en annan metod. De här tilläggen aktiveras automatiskt när du kontrollerar dokument efter dolda metadata eller personlig information. Om du vill kontrollera ett dokument klickar du på Microsoft Office-knappen, på Förbered och sedan på Kontrollera dokument.

Outlook, InfoPath, Publisher och Visio

  1. Verktyg-menyn klickar du på Säkerhetscenter och sedan på Tillägg.

  2. I rutan Tillägg, identifiera det tillägg du vill aktivera eller inaktivera och kontrollera tilläggstypen i kolumnen Typ .

  3. Välj tilläggstypen i rutan Hantera och klicka sedan på .

  4. Markera eller avmarkera kryssrutan för de tillägg som du vill aktivera eller inaktivera och klicka sedan på OK.

Tillägg och dokument kan lägga till anpassade knappar och kontroller i menyfliksområdet, som är en del av Microsoft Office Fluent-användargränssnittet. Alla anpassade kontroller i menyfliksområdet Office Fluent har särskilda skärmtips som identifierar kontrollens ursprung. I det här exemplet kommer kontrollen från RXDemo.xlsm och identifieras i kontrollens skärmtips.

Bild av menyfliksområdet

På så vis vet du varifrån de anpassade kontrollerna kommer och kan sedan ta bort eller uppdatera dokumentet, den globala mall eller det COM-tillägg som presenterar kontrollen. I föregående avsnitt får du lära dig hur du kan visa installerade COM-tillägg.

Som standard får installerade och registrerade tillägg köras utan avisering. Tillägg kan utnyttjas av hackare för att orsaka skada, till exempel sprida ett virus, så du kan använda säkerhetsinställningarna för tillägg för att ändra detta. Mer information finns i Visa eller ändra säkerhetsinställningar för tillägg längre fram i den här artikeln.

Om du eller administratören anger en högre säkerhetsinställning för tillägg och Säkerhetscenter upptäcker ett potentiellt osäkert tillägg som inte uppfyller dessa villkor, inaktiverar Säkerhetscenter koden som standard och meddelandefältet visas med information om ett potentiellt osäkert tillägg eller programtillägg.

Meddelandefält

Om du klickar på Alternativ i meddelandefältet öppnas en säkerhetsdialogruta där du kan välja att aktivera tillägget. I nästa avsnitt finns information om att fatta ett säkert beslut innan du klickar på ett alternativ.

Obs!: I Microsoft Office Outlook 2007 och Microsoft Office Publisher 2007 visas säkerhetsmeddelanden i dialogrutor och inte i meddelandefältet. Som standard tillåter Office Outlook 2007 alla installerade tillägg att köra. Om du vill ändra standardinställning kan du läsa mer i Visa eller ändra säkerhetsinställningar för tillägg längre fram i den här artikeln.

När du ändrar en säkerhetsinställning för tillägg påverkas bara det program där ändringen gjordes. Gör följande i de här Microsoft Office 2007-systemet-programmen:

Word, Excel, Access och PowerPoint

  1. Klicka på Microsoft Office-knappen Bild av Office-knappen och sedan på knappen Alternativ.

  2. Klicka på Säkerhetscenter, på Inställningar för Säkerhetscenter och sedan på Tillägg.

  3. Klicka på de alternativ du vill använda. De här inställningarna är inte valda som standard om du inte arbetar i en organisation och IT- administratör har ändrat standardinställningarna med hjälp av en administratörsprincip.

    • Kräv att programtillägg ska vara signerade av en betrodd utgivare Välj det här alternativet om du vill att Säkerhetscenter ska söka efter en digital signatur i den DLL-fil (Dynamic-Link Library) som innehåller tillägget. Om utgivaren inte är betrodd läser Office-programmet inte in tillägget och meddelandefältet visar ett meddelande om att tillägget har inaktiverats.

    • Inaktivera meddelande om osignerade tillägg (kod är fortsatt inaktiverad) Den här kryssrutan är endast tillgänglig om du har markerat kryssrutan Kräv att programtillägg ska vara signerade av en betrodd utgivare. I vissa situationer kanske DLL-filen som innehåller tillägget vara osignerad. I dessa fall tillägg aktiveras tillägg som är signerade av en betrodd utgivare, medan osignerade tillägg inaktiveras utan meddelande.

    • Inaktivera alla programtillägg (kan försämra funktionaliteten) Markera den här kryssrutan om inga tillägg ska vara betrodda. Alla tillägg inaktiveras utan meddelande, och de övriga kryssrutorna för tillägg blir otillgängliga.

      Obs!: Den här inställningen börjar gälla först sedan du har avslutat och sedan startat om Office-programmet.

Outlook

Som standard tillåter Outlook alla installerade tillägg att köra. Du kan begränsa Outlook att endast köra de tillägg som har signerats digitalt genom att använda inställningen Varningar för signerade makron, alla osignerade makron inaktiveras för tillägg, enligt följande:

  1. Gå till Verktyg-menyn och klicka på Säkerhetscenter.

  2. Klicka på Makrosäkerhet i det vänstra fönstret.

  3. Klicka på Varningar för signerade makron, alla osignerade makron inaktiveras.

  4. Klicka på Tillägg i det vänstra fönstret.

  5. Markera kryssrutan Använd inställningarna för makrosäkerhet för installerade tillägg.

InfoPath, Publisher och Visio

  1. Gå till Verktyg-menyn och klicka på Säkerhetscenter.

  2. Klicka på Tillägg.

  3. Klicka på de alternativ du vill använda. De här inställningarna är inte valda som standard om du inte arbetar i en organisation och IT- administratör har ändrat standardinställningarna med hjälp av en administratörsprincip.

    • Kräv att programtillägg ska vara signerade av en betrodd utgivare Välj det här alternativet om du vill att Säkerhetscenter ska söka efter en digital signatur i den DLL-fil (Dynamic-Link Library) som innehåller tillägget. Om utgivaren inte är betrodd läser Office-programmet inte in tillägget och meddelandefältet visar ett meddelande om att tillägget har inaktiverats.

    • Inaktivera meddelande om osignerade tillägg (kod är fortsatt inaktiverad) Den här kryssrutan är endast tillgänglig om du har markerat kryssrutan Kräv att programtillägg ska vara signerade av en betrodd utgivare. I vissa situationer kanske DLL-filen som innehåller tillägget vara osignerad. I dessa fall tillägg aktiveras tillägg som är signerade av en betrodd utgivare, medan osignerade tillägg inaktiveras utan meddelande.

    • Inaktivera alla programtillägg (kan försämra funktionaliteten) Markera den här kryssrutan om inga tillägg ska vara betrodda. Alla tillägg inaktiveras utan meddelande, och de övriga kryssrutorna för tillägg blir otillgängliga.

      Obs!: Den här inställningen börjar gälla först sedan du har avslutat och sedan startat om Office-programmet.

Om du försöker inaktivera ett tillägg och får meddelandet ”De går inte att ändra anslutningsläget för Office-tillägg under HKEY_LOCAL_MACHINE i registret”, gör du följande:

  1. Stäng Outlook om du har det öppet.

  2. Kontrollera att Outlook-tjänsten inte körs genom att göra följande:

    • Högerklicka på ett tomt område i Aktivitetsfältet, klicka på Aktivitetshanteraren och sedan på Processer.

    • Leta efter Microsoft Outlook i listan över processer:

      • Om Outlook inte finns på listan går du till steg 3.

      • Om Outlook finns på listan klickar du där och sedan på Avsluta aktivitet.

  3. Högerklicka på Outlook på Start-menyn och klicka sedan på Kör som administratör.

  4. Inaktivera de tillägg du vill inaktivera genom att följa stegen i avsnittet Inaktiveras eller hantera installerade tillägg tidigare i den här artikeln.

  5. Stäng Outlook.

  6. Öppna Outlook normalt (inte i administratörsläge).

När en säkerhetsdialogruta visas kan du aktivera tillägget för bara den aktuella sessionen genom att klicka på Aktivera tillägget enbart i den här sessionen, eller du kan låta det vara inaktiverat. Du bör endast aktivera tillägget om du är säker på att det är från en pålitlig källa.

Dialogrutan Säkerhetsalternativ för Microsoft Office

Alternativt kan du uttryckligen ange utgivaren som betrodd genom att klicka på Aktivera all kod som har publicerats av den här utgivaren. Då aktiveras tillägget och gör att all programvara från den utgivaren alltid är betrodd.

När säkerhetsdialogrutan visas i Office Outlook 2007 kan du aktivera tillägget för bara den aktuella sessionen genom att klicka på Aktivera programtillägg, eller du kan låta det vara inaktiverat. Du bör endast aktivera tillägget om du är säker på att det är från en pålitlig källa.

Säkerhetsmeddelande i Microsoft Office Outlook

Alternativt kan du uttryckligen ange utgivaren som betrodd genom att klicka på Anse alla dokument från den här utgivaren som betrodda. Då aktiveras tillägget och gör att all programvara från den utgivaren alltid är betrodd.

Du kan läsa mer om betrodda utgivare i artikeln om att lägga till, ta bort eller visa en betrodd utgivare.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×