Office
Logga in

VÄLJ (Funktionen VÄLJ)

I den här artikeln beskrivs formelsyntaxen för och användningen av funktionen VÄLJ i Microsoft Excel.

Beskrivning

Använder index_num för att returnera ett värde från listan med värdeargument. Du kan använda VÄLJ för att välja ett av upp till 254 värden baserade på indexnummer. Om t.ex. värde1 till och med värde7 är veckans dagar returnerar VÄLJ en av dagarna när ett tal mellan 1 och 7 används som index_num.

Syntax

VÄLJ(index_num; värde1; [värde2]; ...)

Syntaxen för funktionen VÄLJ har följande argument:

  • Index_num    Obligatoriskt. Anger vilket värdeargument som väljs. Index_num måste vara ett tal mellan 1 och 254 eller en formel eller referens till en cell som innehåller ett tal mellan 1 och 254.

    • Om index är 1 returnerar VÄLJ värde1. Om index är 2 returnerar VÄLJ värde2 o.s.v.

    • Om index är mindre än 1 eller större än numret på det sista elementet i listan returnerar VÄLJ felvärdet #Värdefel!.

    • Om index inte är ett heltal avkortas det till ett heltal innan det används.

  • Värde1;värde2;...     Värde 1 är obligatoriskt, efterföljande värden är valfria. 1 till 254 värdeargument från vilka funktionen VÄLJ väljer ett värde eller en funktion att bearbeta, baserat på argumentet index_num. Argumenten kan vara tal, cellreferenser, definierade namn, formler, funktioner eller text.

Kommentarer

  • Om index_num är en matris beräknas varje värde när VÄLJ beräknas.

  • Värdeargumenten till VÄLJ kan vara både referenser till intervall och enstaka värden.

    Formeln:

=SUMMA(VÄLJ(2;A1:A10;B1:B10;C1:C10))

beräknas till:

=SUMMA(B1:B10)

som returnerar ett värde som bygger på värdena i intervallet B1:B10.

Funktionen VÄLJ utförs först och returnerar referensen B1:B10. Sedan utförs funktionen SUMMA som använder resultatet av funktionen VÄLJ (B1:B10) som argument.

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. När du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur. Om det behövs kan du justera kolumnbredderna så att alla data visas.

Data

 

1:a

Spikar

2:a

Skruvar

3:e

Muttrar

Slutförd

Bultar

Formel

Beskrivning

Resultat

=VÄLJ(2;A2;A3;A4;A5)

Värdet för det andra argumentet i listan (värdet i cell A3)

2:a

=VÄLJ(4;B2;B3;B4;B5)

Värdet för det fjärde argumentet i listan (värdet i cell B5)

Bultar

=VÄLJ(3;"Bred";115;"global";8)

Värdet för det tredje argumentet i listan

global

Exempel 2

Data

2, 3

4,5

1,2

10

Formel

Beskrivning (Resultat)

Resultat

=SUMMA(A2:VÄLJ(2;A3;A4;A5))

Summerar cellområdet A2:A4. Funktionen VÄLJ returnerar A4 som den andra delen av området för funktionen SUMMA.

80

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×