Utvärdera en kapslad formel ett steg i taget

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Ibland är det svårt att förstå hur en kapslad formel beräknar det slutliga resultatet, eftersom det finns flera mellanliggande beräkningar och logiska tester. Med hjälp av dialogrutan Utvärdera formel kan du dock se de olika delarna av en kapslad formel utvärderade i den ordning formeln beräknas. Till exempel är formeln =OM(MEDEL(F2:F5)>50,SUMMA(G2:G5),0) enklare att förstå när du kan se följande mellanliggande resultat:

Steg som visas i dialogrutan

Beskrivning

=OM(MEDEL(F2:F5)>50,SUMMA(G2:G5);0)

Den kapslade formeln visas först. Funktionerna MEDEL och SUMMA är kapslade i funktionen OM.

=OM(40>50,SUMMA(G2:G5),0)

Cellområdet F2:F5 innehåller värdena 55, 35, 45 och 25, så resultatet av funktionen MEDEL(F2:F5) är 40.

=OM(Falskt;SUMMA(G2:G5),0)

40 är inte större än 50, så att uttrycket i det första argumentet i funktionen om (Logiskt_test) är FALSKT.

0

Funktionen om returnerar värdet för det tredje argumentet (argumentet värde_om_falskt). Funktionen Summa utvärderas inte eftersom det är det andra argumentet i funktionen om (argumentet värde_om_sant) och de returneras om uttrycket är uppfyllt.

  1. Markera cellen som du vill utvärdera. Endast en cell kan utvärderas i taget.

  2. Klicka på Utvärdera formel i gruppen Formelgranskning på fliken Formler.

    The Formula Auditing group on the Formulas tab

  3. Klicka på Utvärdera när du vill undersöka värdet för den understrukna referensen. Resultatet av utvärderingen visas i kursiv stil.

    Om den understrukna delen av formeln refererar till en annan formel klickar du på Stega in. Då visas den andra formeln i rutan Utvärdering. Klicka på Stega till procedurslut när du vill gå tillbaka till föregående cell och formel.

    Obs!: Knappen Stega in är inte tillgänglig när en referens visas i formeln för andra gången eller om formeln refererar till en cell i en annan arbetsbok.

  4. Fortsätt tills alla delar av formeln har utvärderats.

  5. Om du vill visa utvärderingen igen klickar du på Starta om.

    Om du vill avsluta utvärderingen klickar du på Stäng.

    Meddelanden: 

    • Vissa delar av formler som använder funktionerna om och välja utvärderas inte och #saknas visas i rutan utvärdering.

    • Om en referens är tom, visas värdet noll (0) i rutan Utvärdering.

    • Följande funktioner räknas om varje gång kalkylbladet ändras och kan orsaka Utvärdera formel skiljer sig från vad som visas i cellen: SLUMP, områden, INDEX, förskjutning, CELL, indirekt, rader, kolumner, nu, idag, SLUMP.mellan.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×