Utvärdera en kapslad formel ett steg i taget

Ibland är det svårt att förstå hur en kapslad formel beräknar det slutliga resultatet, eftersom det finns flera mellanliggande beräkningar och logiska tester. Med hjälp av dialogrutan Utvärdera formel kan du dock se de olika delarna av en kapslad formel utvärderade i den ordning formeln beräknas. Formeln = om (medel (i F2: F5) >50, Summa (G2: G5), 0) är lättare att förstå när du kan se följande mellanliggande resultat:

Steg som visas i dialogrutan

Beskrivning

=OM(MEDEL(F2:F5)>50,SUMMA(G2:G5);0)

Den kapslade formeln visas först. Funktionerna MEDEL och SUMMA är kapslade i funktionen OM.

=OM(40>50,SUMMA(G2:G5),0)

Cellområdet F2:F5 innehåller värdena 55, 35, 45 och 25, så resultatet av funktionen MEDEL(F2:F5) är 40.

=OM(Falskt;SUMMA(G2:G5),0)

40 är inte större än 50, så uttrycket i det första argumentet i funktionen om (logisk_test-argumentet) är falskt.

0

Funktionen OM returnerar värdet för det tredje argumentet (värde_om_falskt). Funktionen Summa utvärderas inte eftersom det är det andra argumentet för funktionen om (argumentet värde_om_sant) och det returneras endast när uttrycket är sant.

  1. Markera cellen som du vill utvärdera. Endast en cell kan utvärderas i taget.

  2. Klicka på Utvärdera formel i gruppen Formelgranskning på fliken Formler.

    Gruppen Formelgranskning på fliken Formler

  3. Klicka på Utvärdera när du vill undersöka värdet för den understrukna referensen. Resultatet av utvärderingen visas i kursiv stil.

    Om den understrukna delen av formeln är en referens till en annan formel klickar du på stega i så att den andra formeln visas i rutan utvärdering . Klicka på Stega för att gå tillbaka till föregående cell och formel.

    Obs!: Knappen Stega in är inte tillgänglig när en referens visas i formeln för andra gången eller om formeln refererar till en cell i en annan arbetsbok.

  4. Fortsätt tills alla delar av formeln har utvärderats.

  5. Om du vill visa utvärderingen igen klickar du på Starta om.

    Om du vill avsluta utvärderingen klickar du på Stäng.

    Meddelanden: 

    • Vissa delar av formler som använder funktionerna om och välja utvärderas inte och #N/A visas i rutan utvärdering .

    • Om en referens är tom visas värdet noll (0) i rutan Utvärdering.

    • Formler med cirkel referenser kanske inte utvärderas som förväntat. Om cirkel referenser önskas kan du Aktivera iterativ beräkning.

    • Följande funktioner räknas om varje gång kalkyl bladet ändras och kan orsaka att utvärdera formel ger resultat som skiljer sig från vad som visas i cellen: slump, offset, cell, indirekt, nu, idag, slump, info och Summa (i vissa scenarier).

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Mer information finns i

Hur du undviker felaktiga formler

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×