Upptäck fel i formler

Formler kan ibland resultera i felaktiga värden och oväntade resultat. Följande är några verktyg som du kan använda för att hitta och undersöka orsakerna till dessa fel och hitta lösningar till dem.

Obs!: Det här avsnittet behandlar tekniker som kan hjälpa dig korrigera formelfel. Det är inte en uttömmande förteckning över metoder för att korrigera varje tänkbart formelfel. Om du behöver hjälp med specifika fel kan du söka efter frågor som liknar dina i Excel Community-forumet eller publicera en egen fråga.

Länk till Excel Community-forumet

Lär dig hur du skriver en enkel formel

Formler är ekvationer som utför beräkningar på värden i kalkylbladet. En formel inleds med ett likhetstecken (=). Följande formel adderar till exempel 3 till 1.

=3+1

En formel kan också innehålla följande: funktioner, referenser, operatorer och konstanter.

Delar av en formel

Delar av en formel

  1. Funktioner: ingår i Excel, funktioner är programmerade formler som utför specifika beräkningar. Funktionen PI() t.ex. returnerar värdet på pi: 3,142...

  2. Referenser: referera till enskilda celler eller cellområden. A2 returnerar värdet i cell A2.

  3. Konstanter: tal eller textvärden som anges direkt i en formel, t.ex. 2.

  4. Operatorer: Operatorer: Operatorn ^ (cirkumflex) upphöjer ett tal till en exponent och operatorn * (asterisk) multiplicerar. Använd + och – för att addera och subtrahera värden samt / för division.

    Obs!: Vissa funktioner kräver det som kallas för argument. Argument är de värden som vissa funktioner använder för att utföra beräkningarna. Vid behov anges argumenten mellan funktionens parenteser (). Funktionen PI har inget argument och är därför tom. Vissa funktioner kräver ett eller flera argument och kan ha utrymme för ytterligare argument. Du måste använda kommatecken eller semikolon, beroende på dina nationella inställningar, för att avgränsa argument.

Funktionen SUMMA kräver t.ex. bara ett argument men har plats för totalt 255 argument.

Funktionen SUMMA

=SUMMA(A1:A10) är ett exempel på användningen av ett argument.

=SUMMA(A1:A10;C1:C10) är ett exempel på användningen av flera argument.

I följande tabell finns en sammanfattning av några av de vanligaste felen som en användare kan göra när användaren skriver en formel samt förklaringar för hur du korrigerar dem.

Se till att du

Mer information

Börjar varje funktion med ett likhetstecken (=)

Om du glömmer att inleda formeln med ett likhetstecken är det möjligt att det du skriver visas som text eller som ett datum. Om du till exempel skriver SUMMA(A1:A10) visas textsträngen i ExcelSUM(A1:A10) och formeln beräknas inte. Om du skriver 11/2 visas datumet 2-nov i Excel (om cellformatet är Allmänt) i stället för 11 delat med 2.

Matcha alla inledande och avslutande parenteser

Kontrollera att alla parenteser ingår i ett parentespar (inledande och avslutande). När du använder en funktion i en formel är det viktigt att varje parentes är rätt placerad för att funktionen ska fungera ordentligt. Formeln =OM(B5<0);"Ogiltigt";B5*1,05) fungerar till exempel inte eftersom den innehåller två avslutande parenteser och endast en inledande parentes, där det endast får finnas en av varje. Den korrekta formeln ska se ut så här: =OM(B5<0;"Ogiltigt";B5*1,05).

Definiera ett område genom att använda kolon

När du hänvisar till ett cellområde ska du använda ett kolon (:) för att separera hänvisningen till den första cellen i området och hänvisningen till den sista cellen i området. T.ex. =SUMMA(A1:A5) och inte =SUMMA(A1 A5), vilket skulle returnera ett #SKÄRNING!-fel.

Ange alla argument som behövs

Vissa funktioner har obligatoriska argument. Kontrollera också att du inte har angett för många argument.

Ange rätt typ av argument

För vissa funktioner som SUMMA är numeriska argument obligatoriska. För andra funktioner som ERSÄTT är ett textvärde för minst ett av argumenten obligatoriskt. Om du använder fel datatyp för ett argument kan oväntade resultat returneras eller ett fel visas i Excel.

Kapsla inte in fler än 64 funktioner

Du kan ange eller kapsla högst 64 funktionsnivåer i en funktion.

Omge namn på andra kalkylblad med enkla citattecken

Om en formel hänvisar till värden eller celler i andra kalkylblad eller arbetsböcker, och namnet på den andra arbetsboken eller det andra kalkylbladet innehåller blanksteg eller icke-alfanumeriska tecken, måste du omge namnet med enkla citattecken ('), som i ='Kvartalsvisa data'!D3 eller =‘123’!A1.

Placera ett utropstecken (!) efter ett kalkylbladsnamn när du refererar till det i en formel

Om du till exempel vill returnera värdet från cell D3 i ett kalkylblad med namnet Kvartalsdata i samma arbetsbok använder du den här formeln: ='Kvartalsdata'!D3.

Ta med sökvägen till externa arbetsböcker

Kontrollera att alla externa referenser innehåller ett arbetsboksnamn och sökvägen till arbetsboken.

En referens till en arbetsbok omfattar namnet på arbetsboken och måste omges av hakparenteser ([Arbetsboknamn.xlsx]). Referensen måste också innehålla namnet på kalkylbladet i arbetsboken.

Om arbetsboken som du vill referera till inte är öppen i Excel kan du fortfarande ta med en referens till den i en formel. Du anger den fullständiga sökvägen till filen, som i följande exempel: =RADER('C:\Mina dokument\[Verksamhet kvartal2.xlsx]Försäljning'!A1:A8). Den här formeln returnerar antalet rader i området med cell A1 till och med A8 i den andra arbetsboken (8).

Obs!: Om den fullständiga sökvägen innehåller blanksteg, som i exemplet ovan, måste du omge sökvägen med enkla citattecken (i början av sökvägen och efter namnet på kalkylbladet, före utropstecknet).

Skriv tal utan formatering

Formatera inte tal när du skriver in dem i formler. Om du till exempel vill ange värdet 1 000 kr skriver du in 1000 i formeln. Om du anger ett kommatecken i ett tal kan det tolkas i Excel som ett tecken som avgränsar värden i olika formelargument, beroende på nationella inställningar. Om du vill att talen i formelresultat ska visas med tusentals- eller miljontalsavgränsare eller valutasymboler formaterar du cellerna efter att du har skrivit in talen.

Om du till exempel vill summera 3100 till värdet i cell A3 och du skriver in formeln =SUMMA(3,100,A3) summeras talen 3 och 100 i Excel och sedan adderas summan med värdet från A3 i stället för att addera 3100 till A3, vilket skulle vara =SUMMA(3100,A3). På samma sätt visas ett fel i Excel om du skriver in formeln =ABS(-2,134) eftersom funktionen ABS bara tillåter ett argument: =ABS(-2134).

Du kan använda vissa regler för att söka efter fel i formler. Dessa regler garanterar inte att kalkylbladet blir felfritt men de kan vara till stor hjälp för att hitta vanliga misstag. Du kan aktivera och inaktivera dessa regler individuellt.

Fel kan markeras och korrigeras på två sätt: ett fel i taget (som i en stavningskontroll) eller omedelbart när de inträffar i kalkylbladet medan du skriver data.

Du kan åtgärda ett fel med hjälp av alternativen som visas eller så kan du ignorera felet genom att klicka på Ignorera fel. Om du ignorerar ett fel i en viss cell, visas felet i cellen inte i ytterligare felkontroller. Däremot kan du återställa alla tidigare ignorerade fel så att de visas igen.

  1. Klicka på Arkiv > Alternativ > Formler.

    I Excel 2007 klickar du på Microsoft Office-knappen Bild av Office-knappen > Excel-alternativ > Formler.

  2. Under Felkontroll markerar du Aktivera felkontroll i bakgrunden. Eventuella fel som hittas markeras med en triangel i cellens övre vänstra hörn.

    Cell med ett formelproblem
  3. Du kan byta färg på triangeln som indikerar fel genom att välja en annan färg i rutan Visa fel med följande färg.

  4. Markera eller avmarkera kontrollrutorna under Felkontrollregler i Excel för någon av följande regler:

    • Celler som innehåller formler som resulterar i fel: En formel använder inte förväntad syntax, förväntade argument eller förväntade datatyper. Följande felvärden visas #DIVISION/0!, #SAKNAS!, #NAMN?, #SKÄRNING!, #OGILTIGT!, #REFERENS! eller #VÄRDEFEL!. Varje felvärde har olika orsaker som åtgärdas på olika sätt.

      Obs!: Om du skriver ett felvärde direkt i en cell lagras den som felvärdet, men markeras inte som ett fel. Om en formel i en annan cell hänvisar till cellen, returnerar formeln dock värdet från cellen.

    • Inkonsekvent beräknad kolumnformel i tabeller: En beräknad kolumn kan innehålla individuella formler som skiljer sig från huvudkolumnformeln, vilket skapar ett undantag. Undantag i beräknade kolumner skapas när du gör något av följande:

      • Anger data som inte är en formel i en cell i en beräknad kolumn.

      • Anger en formel i en cell i en beräknad kolumn och använder sedan CTRL + Z eller klickar på Ångra Knappbild i verktygsfältet Snabbåtkomst.

      • Anger en ny formel i en beräknad kolumn som redan innehåller ett eller flera undantag.

      • kopierar data i den beräknade kolumnen som inte matchar den beräknade kolumnens formel Om den kopierade informationen innehåller en formel skriver formeln över informationen i den beräknade kolumnen.

      • flyttar eller tar bort en cell i ett annat kalkylbladsområde som en av raderna i en beräknad kolumn refererar till.

    • Celler som innehåller årtal angivna med två siffror: Cellen innehåller ett textdatum som kan tolkas som fel århundrade när det används i formler. Datumet i formeln =ÅR("1/1/31") kan till exempel både vara 1931 och 2031. Använd den här regeln för att kontrollera tvetydiga textdatum.

    • Tal formaterade som text eller som föregås av en apostrof Cellen innehåller tal som lagras som text. Detta förekommer främst när data importeras från andra källor. Eftersom tal som lagras som text kan resultera i sorteringsproblem bör dessa celler omvandlas till tal. ‘=SUMMA(A1:A10) visas som text.

    • Formler stämmer inte överens med andra formler i regionen Formeln matchar inte mönstret i närliggande formler. Ofta skiljer sig endast intilliggande formler från varandra i fråga om vilka referenser de använder. I följande exempel med fyra formler som ligger intill varandra visar Excel ett fel bredvid formeln =SUMMA(A10:C10) i cell D4 eftersom de formler som ligger i närheten ökar stegvis med en rad med den formeln ökar stegvis med åtta rader – Excel förväntar sig formeln =SUMMA(A4:C4).

      Excel visar ett fel när en formel inte matchar mönstret i närliggande formler

      Om referenserna i en formel inte är konsekventa med de som används i de angränsande formlerna visar Excel ett fel.

    • Formler som utesluter celler i en region: En formel tar kanske inte automatiskt med referenser till data som du lägger till mellan originalområdet för data och cellen som innehåller formeln. Den här regeln jämför referensen i formeln med de faktiska områdena i cellerna som gränsar till den cell som innehåller formeln. Om den intilliggande cellen innehåller ytterligare värden och inte är tom visar Excel ett fel bredvid formeln.

      Excel infogar till exempel ett fel bredvid formeln =SUMMA(D2:D4) när den här regeln används, eftersom cellerna D5, D6 och D7 befinner sig intill de celler som refereras till i formeln och även till den cell som innehåller formeln (D8) och de celler som innehåller data som skulle ha refererats till i formeln.

      Excel visar ett fel när en formel hoppar över celler i ett område
    • Olåsta celler med formler: Formeln är inte låst för skydd. Som standard är alla celler i ett kalkylblad låsta så att de inte kan ändras när kalkylbladet är skyddat. På så sätt undviker du oavsiktliga misstag som att råka ta bort eller ändra formler. Det här felet indikerar att cellen har konfigurerats som olåst men att kalkylbladet inte har skyddats. Kontrollera om du vill att cellen ska vara låst eller olåst.

    • Formler som hänvisar till tomma celler: Formeln innehåller en referens till en tom cell. Detta kan orsaka oavsiktliga resultat (se exemplet nedan).

      Anta att du vill beräkna medelvärdet av talen i följande kolumn med celler. Om tredje cellen är tom tas den inte med i beräkningen och resultatet blir då 22,75. Om den i stället innehåller 0 blir resultatet 18,2.

      Excel visar ett fel när en formel refererar till tomma celler
    • Ogiltiga data har matats in i den här tabellen: En tabell innehåller ett verifieringsfel. Kontrollera verifieringsinställningen för cellen genom att klicka på Dataverifiering i gruppen Dataverktyg på fliken Data.

  1. Välj det kalkylblad som du vill söka efter fel i.

  2. Om kalkylbladet är manuellt beräknat beräknar du om det genom att trycka på F9.

    Om dialogrutan Felkontroll inte visas klickar du på knappen Felkontroll i gruppen Formelgranskning på fliken Formler.

  3. Om du har ignorerat fel tidigare kan du kontrollera dem igen på följande sätt: Klicka på Arkiv > Alternativ > Formler.

    Klicka på Återställ ignorerade fel > OK i avsnittet Felkontroll.

    Felkontroll

    Obs!: Om du återställer ignorerade fel återställs alla fel i alla blad i den aktuella arbetsboken.

    Tips: Det kanske hjälper om du flyttar dialogrutan Felkontroll till precis under formelfältet.

    Dra dialogrutan Felkontroll till precis under formelfältet.
  4. Klicka på någon av åtgärdsknapparna till höger i dialogrutan. Vilka åtgärder som är tillgängliga varierar beroende på typen av fel.

  5. Klicka på Nästa.

Obs!: Om du klickar på Ignorera fel ignoreras felet även i kommande felkontroller.

  1. Klicka på knappen Felkontroll Ikon för felkontroll som visas bredvid cellen och sedan på önskat alternativ. Vilka kommandon som är tillgängliga varierar beroende på typen av fel. Den första posten beskriver felet.

    Om du klickar på Ignorera fel ignoreras felet även i kommande felkontroller.

    Dra dialogrutan Felkontroll till precis under formelfältet.

Om en formel inte kan utvärdera ett resultat korrekt visas ett felvärde i Excel, t.ex. #####, #DIVISION/0!, #SAKNAS!, #NAMN?, #SKÄRNING!, #OGILTIGT!, #REFERENS! eller #VÄRDEFEL!. Varje typ av fel inträffar av olika anledningar, och har olika lösningar.

Följande tabell innehåller länkar till artiklar som beskriver felen i detalj. Länkarna innehåller också en kort beskrivning som hjälper dig att komma igång.

Ämne

Beskrivning

Korrigera ett ####-fel

Det här felmeddelandet visas i Excel när en kolumn inte är tillräckligt bred för att visa alla tecken i en cell eller om en cell innehåller negativa värden för datum eller tid.

En formel som subtraherar ett framtida datum från ett tidigare datum, till exempel =06/15/2008-07/01/2008, kan till exempel ge ett negativt värde.

Tips: Försök att autoanpassa cellen genom att dubbelklicka mellan kolumnrubrikerna. Om ### visas p.g.a. att Excel inte kan visa alla tecken åtgärdas det av det här.

#-fel

Korrigera #DIVISION/0!-fel

Det här felmeddelandet visas i Excel när ett tal divideras med antingen noll (0) eller en cell som inte innehåller något värde.

Tips: Lägg till en felhanterare som i exemplet nedan, d.v.s. =OM(C2;B2/C2;0)

Felhanteringsfunktioner som OM kan användas till att dölja fel

Korrigera #SAKNAS!-fel

Det här felmeddelandet visas i Excel när ett värde inte är tillgängligt för en funktion eller formel.

Om du använder en funktion som LETARAD finns det du försöker hitta i sökområdet? Oftast inte.

Försök använda OMFEL för att hantera #SAKNAS!-fel I det här fallet kan du använda:

=OMFEL(LETARAD(D2;$D$6:$E$8;2;SANT);0)

#SAKNAS!-fel

Korrigera #NAMN?-fel

Det här felet visas när Excel inte känner igen text i en formel. Ett områdesnamn eller namnet på en funktion kan till exempel vara felstavat.

Obs!: Om du använder en funktion kontrollerar du att funktionsnamnet är rättstavat. I det här fallet är SUMMA felstavat. Rätta stavfelet så korrigeras det i Excel.

Excel visar #NAMN?-fel när ett funktionsnamn är felstavat

Korrigera #SKÄRNING!-fel

Det här felmeddelandet visas i Excel när du anger en korsning av två områden som inte korsar varandra (kors). En skärningsoperator är ett blanksteg som avgränsar referenser i en formel.

Obs!: Kontrollera att områdena är korrekt avgränsade. Områdena C2:C3 och E4:E6 skär inte varandra och därför returneras formeln =SUMMA(C2:C3 E4:E6) #SKÄRNING!-felet. Placera ett semikolon mellan C- och E-områdena för att åtgärda felet, d.v.s. =SUMMA(C2:C3;E4:E6)

#SKÄRNING!-fel

Korrigera #OGILTIGT!-fel

Det här felet visas i Excel när en formel eller en funktion innehåller ogiltiga numeriska värden.

Använder du en funktion som upprepas, t.ex. IR eller RÄNTA? Om så är fallet beror troligtvis #OGILTIGT!-felet på att funktionen inte kan hitta ett resultat. Läs hjälpavsnittet för lösningsanvisningar.

Korrigera #REFERENS!-fel

Det här felmeddelandet visas i Excel när en cellreferens inte är giltig. Du kan till exempel ha tagit bort celler som hänvisas till av andra formler, eller så kanske du har klistrat in celler som du flyttat ovanpå celler som hänvisas till av andra formler.

Råkade du ta bort en rad eller kolumn? Vi tog bort kolumn B i formeln =SUMMA(A2;B2;C2) och se vad som hände.

Använd Ångra (CTRL + Z) för att ångra borttagningen, återskapa formeln eller använd en sammanhängande områdesreferens, =SUMMA(A2:C2) i det här fallet, som uppdateras automatiskt när kolumn B tas bort.

Excel visar #REFERENS!-fel när en cellreferens är ogiltig

Korrigera #VÄRDEFEL!

Det här felet visas i Excel om formeln innehåller celler som innehåller olika datatyper.

Använder du matematiska operatorer (+, -, *, / och ^) med olika datatyper? Prova i så fall med att använda en funktion i stället. I det här fallet åtgärdar du problemet med =SUMMA(F2:F5).

#VÄRDEFEL!-fel

När celler inte är synliga i ett kalkylblad kan du titta på cellerna och cellernas formler i verktygsfältet Bevakningsfönster. Bevakningsfönster gör det enkelt att kontrollera, granska eller bekräfta formelberäkningar och resultat i stora kalkylblad. Med hjälp av Bevakningsfönster behöver du inte bläddra flera gånger eller gå till olika delar av kalkylbladet.

Bevakningsfönster gör det enkelt att övervaka de formler som används i ett kalkylblad

Det här verktygsfältet kan flyttas eller dockas på samma sätt som alla andra verktygsfält. Du kan t.ex. docka det längst ned i fönstret. Verktygsfältet håller reda på följande cellegenskaper: 1) arbetsbok, 2) blad, 3) namn (om cellen har ett motsvarande namngivet område), 4) celladress, 5) värde och 6) formel.

Obs!: Du kan endast ha en bevakning per cell.

Lägga till celler i Bevakningsfönster

  1. Markera de celler du vill bevaka.

    Om du vill markera alla celler i ett kalkylblad med formler klickar du på Sök och markera i gruppen Redigera på fliken Start (eller så använder du CTRL + G eller CONTROL + G på en Mac-dator) > Gå till Special > Formler.

    Dialogrutan Gå till special
  2. Klicka på Bevakningsfönster i gruppen Formelgranskning på fliken Formler.

  3. Klicka på Lägg till bevakning.

    Klicka på Lägg till bevakning för att lägga till en bevakning i kalkylbladet
  4. Bekräfta att du har markerat alla celler som du vill bevaka och klicka på Lägg till.

    Ange det cellområde du vill bevaka i Lägg till bevakning
  5. Flytta gränslinjen på höger sida om kolumnrubriken om du vill ändra bredden på en kolumn i Bevakningsfönster.

  6. Om du vill visa den cell som en post i verktygsfältet Bevakningsfönster refererar till dubbelklickar du på posten.

    Obs!: Celler med externa referenser till andra arbetsböcker visas i verktygsfältet Bevakningsfönster endast när andra arbetsböcker är öppna.

Ta bort celler från Bevakningsfönster

  1. Om verktygsfältet Bevakningsfönster inte visas klickar du på Bevakningsfönster i gruppen Formelgranskning på fliken Formler.

  2. Markera cellerna som du vill ta bort.

    Om du vill markera flera celler trycker du på CTRL och klickar sedan på cellerna.

  3. Klicka på Ta bort bevakning.

    Ta bort bevakning

Ibland är det svårt att förstå hur en kapslad formel beräknar det slutliga resultatet, eftersom det finns flera mellanliggande beräkningar och logiska tester. Med hjälp av dialogrutan Utvärdera formel kan du dock se de olika delarna av en kapslad formel utvärderade i den ordning formeln beräknas. Till exempel är formeln =OM(MEDEL(D2:D5)>50;SUMMA(E2:E5);0) enklare att förstå när du kan se följande mellanliggande resultat:

Med Utvärdera formel kan du se hur olika delar av en kapslad formel utvärderas

I dialogrutan Utvärdera formel

Beskrivning

=OM(MEDEL(D2:D5)>50;SUMMA(E2:E5);0)

Den kapslade formeln visas först. Funktionerna MEDEL och SUMMA är kapslade i funktionen OM.

Cellområdet D2:D5 innehåller värdena 55, 35, 45 och 25, så resultatet av funktionen MEDEL(D2:D5) är 40.

=OM(40>50;SUMMA(E2:E5);0)

Cellområdet D2:D5 innehåller värdena 55, 35, 45 och 25, så resultatet av funktionen MEDEL(D2:D5) är 40.

=OM(FALSKT;SUMMA(E2:E5);0)

Eftersom 40 inte är större än 50 är uttrycket i det första argumentet i funktionen OM (argumentet logiskt_test) falskt.

Funktionen OM returnerar värdet för det tredje argumentet (värde_om_falskt). Funktionen SUMMA utvärderas inte eftersom den är det andra argumentet till funktionen OM (värde_om_sant), och det returneras endast om uttrycket är sant.

  1. Markera cellen som du vill utvärdera. Endast en cell kan utvärderas i taget.

  2. Välj Utvärdera formel i gruppen Formelgranskning på fliken Formler.

  3. Klicka på Utvärdera när du vill undersöka värdet för den understrukna referensen. Resultatet av utvärderingen visas i kursiv stil.

    Om den understrukna delen av formeln refererar till en annan formel klickar du på Stega in. Då visas den andra formeln i rutan Utvärdering. Klicka på Stega till procedurslut när du vill gå tillbaka till föregående cell och formel.

    Knappen Stega in är inte tillgänglig när en referens visas i formeln för andra gången eller om formeln refererar till en cell i en annan arbetsbok.

  4. Fortsätt klicka på Utvärdera tills alla delar av formeln har utvärderats.

  5. Om du vill visa utvärderingen igen klickar du på Starta om.

  6. Om du vill avsluta utvärderingen klickar du på Stäng.

Meddelanden: 

  • Vissa delar av formler som använder funktionerna OM och VÄLJA utvärderas inte – i dessa fall visas #SAKNAS i rutan Utvärdering.

  • Om en referens är tom visas värdet noll (0) i rutan Utvärdering.

  • Följande funktioner räknas om varje gång kalkylbladet ändras och kan göra så att resultaten i dialogrutan Utvärdera formel skiljer sig från vad som visas i cellen: SLUMP, OMRÅDEN, INDEX, FÖRSKJUTNING, CELL, INDIREKT, RADER, KOLUMNER, NU, IDAG, SLUMP.MELLAN.

Har du en specifik fråga?

Ställ en fråga i Excel-communityforumet

Hjälp oss att göra Excel bättre

Har du förslag på hur vi kan förbättra nästa version av Excel? Titta i så fall på avsnitten i Excel User Voice.

Mer information finns i

Visa relationerna mellan formler och celler

Video: Åtgärda felaktiga formler (Excel 2010)

Undvika felaktiga formler

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×