Summera värden baserat på flera villkor

Om du vill summera värden med fler än ett villkor, till exempel den sammanlagda försäljningen av en viss produkt i en viss region, använder du funktionen SUMMA.OMF i en formel.

Här är ett exempel där vi har två villkor: Vi vill ha fram den sammanlagda försäljningen av kött (från kolumn C) i region Syd (från kolumn A).

Data i ett Excel-kalkylblad

Du använder den här formeln:

=SUMMA.OMF(D2:D11;A2:A11;”Syd”;C2:C11;”kött”)Resultatet är 14719 och så här fungerar formeln.

=SUMMA.OMF är en aritmetisk formel. Den beräknar antal, vilket i det här fallet finns i kolumn D. Så börja med att berätta för formeln var talen finns:

  • =SUMMA.OMF(D2:D11;

Med andra ord vill du att formeln ska summera talen i kolumnen om de uppfyller villkoren. Det cellområdet är det första argumentet eller de första data som funktionen behöver för att köras.

Sedan vill du få fram data som uppfyller två villkor. Du anger det första villkoret genom att berätta för funktionen var dessa data finns (A2:A11) och vilket villkoret är, det vill säga ”Syd”. Observera kommatecknen mellan de olika argumenten.

  • =SUMMA.OMF(D2:D11;A2:A11;”Syd”;

Citattecken runt ”Syd” anger för Excel att textdata används.

Till sist anger du argumenten för det andra villkoret – det cellområde (C2:C11) som innehåller ordet ”kött” plus själva ordet (inom citattecken) så att Excel kan matcha det. Avsluta formeln med ett avslutande parentestecken ) och tryck sedan på Retur så får du resultatet 14719.

  • =SUMMA.OMF(D2:D11;A2:A11;”Syd”;C2:C11;”kött”)

Om du skriver funktionen SUMMA.OMF och inte kommer ihåg argumenten är det lätt att få hjälp. När du har skrivit =SUMMA.OMF( visas Komplettera automatiskt för formel under formeln, med en lista med argument i rätt ordning.

Om vi tittar på bilden av Komplettera automatiskt för formel och listan med argument är i vårt exempel summaområde D2:D11, kolumnen med tal du vill summera, villkorsområde1 A2.A11, kolumnen med data där villkor1 ”Syd” finns.

Använda Komplettera automatiskt för formel om du vill ange funktionen SUMMA.OMF

När du skriver visas resten av argumenten i Komplettera automatiskt för formel, villkorsområde2 är C2:C11, kolumnen med data där villkor2 ”kött” finns.

Ge det ett försök

Kopiera alla data i tabellen nedan och klistra in dem i cell A1 i ett nytt kalkylblad. Du kanske vill justera kolumnbredderna så att du ser formlerna bättre.

Område

Säljare

Typ

Försäljning

Söder

Ito

Drycker

3571

Väst

Lannin

Mejeri

3338

Öst

Makovec

Drycker

5122

Norr

Makovec

Mejeri

6239

Söder

Hedlund

Spannmål

8677

Söder

Lannin

Kött

45,0

Söder

Lannin

Kött

7673

Öst

Makovec

Spannmål

664

Norr

Lannin

Spannmål

1500

Söder

Hedlund

Kött

6596

Formel

 

Beskrivning

Resultat

=SUMMA.OMF(D2:D11;A2:A11;
"Syd";C2:C11;"Kött")

Summerar köttförsäljningen i
Kolumn C i den södra
området i kolumn A (resultatet är 14719).

'=SUMMA.OMF(D2:D11;A2:A11;
"Syd";C2:C11;"Kött")

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×