Steg 4 – Dela makron med andra

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Det som är viktigt att förstå om delning av makron är att de lagras i Office-filen, så du måste dela den filen med andra. Om du har skapat ett makro i Word måste du dela filen som en makroaktiverad Word-mall (.dotm) eller ett makroaktiverat Word-dokument (.docm). Om du har skapat ett makro i Excel måste du dela filen som en makroaktiverad Excel-arbetsbok (.xlsm) eller en makroaktiverad Excel-mall (.xltm).

Om du har skapat ett Word-makro måste du utföra några extra steg när du ska dela ditt makro:

Skapa den tomma Word-mallen

  1. Öppna ett nytt Word-dokument.

  2. Öppna Arkiv-menyn och klicka på Spara som.

  3. Namnge filen global_macros.dotm.

  4. I listrutan Format väljer du Makroaktiverad Word-mall (*.dotm) som Format.

  5. Välj var du vill spara filen på nätverket.

  6. Klicka på Spara och stäng sedan mallen.

Exportera Word-makrot från dokumentet

Gör på följande sätt när du ska exportera det makro du spelade in i Steg 1:

  1. Öppna dokumentet eller mallen som innehåller det makro du vill exportera.

  2. På menyn Verktyg pekar du på Makro och klickar på Makron.

  3. Välj det makro du vill exportera och klicka på Redigera. Välj makro som ska exporteras

  4. Klicka på Arkiv > Exportera fil i Visual Basic Editor.

  5. Spara makrot i samma mapp som den makroaktiverade mallen, global_macros.dotm.

Importera Word-makrot till den nya tomma mallen

  1. Öppna global_macros.dotm och klicka på Verktyg > Makro > Visual Basic Editor.

  2. Importera makrot genom att klicka på Arkiv > Importera fil, gå till den mapp dit du exporterade makrot, markera filen och klicka på Öppna.

  3. Spara modulen, avsluta Visual Basic Editor och avsluta Word.

Nu kan du dela ditt makro med andra och säga åt dem att följa stegen nedan för att installera makrot på sin dator.

Installera mall: konfigurera Word för användning av ditt makro

  1. Placera filen global_macro.dotm på följande plats:

    • Word för Mac 2011: Macintosh HD: Users: <användarnamn>: Library: Application Support: Microsoft: Office: User Templates: My Templates

    • Word 2003 eller senare i Windows: C:\Documents and Settings\<användarnamn>\Application Data\Microsoft\Word\STARTUP

      Obs!:  <användarnamn> är användarens inloggningsnamn.

  2. Klicka på Word > Inställningar i Word.

Word-egenskaper

  1. Klicka på Sökvägar i avsnittet Personliga inställningar

  2. Välj Autostart från listan Sökvägar och klicka på Ändra.

Sökväg

  1. Kontrollera att Word använder den mapp där du lagt filen global_macro.dotm som startmapp.

  2. Klicka på Välj så att du stänger dialogrutan Välj en mapp och sedan på OK för att stänga dialogrutan Sökvägar.

Det sista steget är att ange att Word ska använda filen global_macros.dotm när programmet startar.

  1. Klicka på Verktyg > Mallar och tillägg i Word.

  2. Markera filen global_macros.dotm i listan och klicka på OK.

    Tips:  Om du inte ser din mall i listan ligger inte filen global_macros.dotm i startmappen för Word. Gå tillbaka till steg 1 och kontrollera att mappen Autostart är samma mapp som den där du lagrade filen global_macros.dotm.

Ange Global mall i Word

 Steg 1 – kom igång med makroinspelningsfunktionen

Steg 2 – läsa och förstå koden

Steg 3 – lär dig grunder i programmering

Steg 4 – dela ut ditt makro till andra

Steg 5 – verkliga exempel

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×