Spara till SharePoint (Power Pivot)

Du kan spara Excel-arbetsböcker som har Power Pivot-datamodeller till en SharePoint-webbplats som har utökats med funktioner för åtkomst till datamodeller. När arbetsboken har publicerats, avgör behörigheter och dokumentegenskaper i SharePoint hur andra kan visa och använda arbetsboken.

Innan du börjar

För att du ska kunna publicera arbetsböcker i SharePoint måste du ha tillräcklig behörighet, rätt programvara och kunskap om hur du ska förbereda arbetsboken för publicering.

Serverprogramvara

Om du vill se arbetsböcker i en webbläsare måste den SharePoint-server som du använder ha PowerPivot för SharePoint och Excel Services. Båda tjänsterna krävs för bearbetning och rendering av arbetsböcker i SharePoint.

Du kan ibland avgöra om du har rätt programvara genom att granska biblioteken och snabbmenyerna på webbplatsen, men du kan behöva fråga SharePoint-administratören om serverprogramvaran som krävs finns installerad. Om webbplatsen innehåller Power Pivot-galleriet, finns Power Pivot för SharePoint installerat. På liknande sätt gäller att om du kan öppna en Excel-arbetsbok i ett webbläsarfönster utan att behöva hämta filen till Excel-programmet, så körs Excel Services på SharePoint-servern.

Om du planerar att schemalägga automatiska datauppdateringar för en arbetsbok måste du kontrollera med serveradministratören att de dataleverantörer som du importerar data ifrån också finns tillgängliga på servern.

Behörigheter

När du sparar ett dokument till SharePoint avgör SharePoint-behörigheterna vem som kan visa, redigera eller ta bort ditt arbete. I följande tabell beskrivs vilka SharePoint-behörigheter som beviljar specifika rättigheter till de arbetsböcker som du publicerar:

Kommandot Behörighet

Rättigheter

Visa

Alla med behörigheten Visa kan öppna arbetsboken genom att gå till filens URL-adress. Behörigheten Visa kan också tillåta en person att använda arbetsboken som en skrivskyddad extern datakälla för andra Excel-arbetsböcker eller rapporter.

Delta

Behörighetsnivån Delta är mer kraftfull eftersom den ger behörighet att lägga till, redigera eller ta bort dokument i SharePoint-bibliotek.

Fullständig behörighet

Fullständig behörighet omfattar alla de behörigheter som ingår i Delta, plus möjligheten att skapa eller hantera listan eller biblioteket och ångra utcheckningar.

Åtkomst till alla SharePoint-webbplatser eller -bibliotek beviljas via behörigheter som en webbplatsadministratör eller webbplatsägare tilldelar till grupper eller enskilda användare.

De flesta personer har behörigheterna Visa eller Delta. Du kan se vilka behörigheter du har genom att titta på menyn Webbplatsåtgärder på SharePoint-webbplatsen. Om det enda alternativet på menyn är Visa allt webbplatsinnehåll, har du behörigheten Visa. Då kan du inte publicera filer till SharePoint-webbplatsen. Om du ser en längre lista med objekt, eller om Biblioteksverktyg visas i menyfliksområdet, så har du behörigheten Delta.

Förbereda arbetsboken

Innan du publicerar en Excel-arbetsbok som innehåller PowerPivot-data bör du förbereda dokumentet med hjälp av den här checklistan:

  1. Läs om hur du skapar en arbetsbok med anslutningsinformation som fortsätter att fungera efter att filen har publicerats.

  2. Förstå säkerhetsöverväganden vid publicering av PowerPivot-data i SharePoint.

  3. Du kan förbättra den visuella presentationen av arbetsboken i SharePoint med hjälp av följande förslag:

    • Ge dina Excel-kalkylblad beskrivande namn. Kalkylbladsnamn blir sidetiketter när dokumentet publiceras till PowerPivot-galleriet.

    • Inaktivera oanvända visuella element. I Excel-fönstret, i området Visa på menyfliken Visa, stänger du av Stödlinjer, Formelfältet och Rubriker.

    • Dölj Excel-kalkylblad som är tomma eller som inte är relevanta för rapporten. I Excel-fönstret högerklickar du på en flik för ett kalkylblad och väljer Dölj Blad.

    • Markera cellen A1 innan du sparar och publicerar arbetsboken. När en publicerad fil öppnas i ett webbläsarfönster hamnar fokus på den senast aktiva cellen i arbetsboken. Genom att placera markören i cell A1 försäkrar du dig om att det övre vänstra hörnet i kalkylbladet är placerat längst upp till vänster i webbläsarfönstret.

Kontrollera autentiserings- och uppdateringsinställningarna

För bästa resultat ska du använda standardinställningarna i Excel för autentisering och uppdatering av data.

Kontrollera Windows-autentisering

Som standard är Windows-autentisering angiven i Excel. Det innebär att identiteten för den person som använder arbetsboken används vid åtkomst till data i datamodeller. Om du behåller standardinställningen kan PowerPivot-serverprogramvaran samla in exakt information om vem som använder PowerPivot-arbetsböcker, så att du kan samarbeta bättre med de kolleger som använder dina data. Om du anger Ingen eller ett SSS-ID (Secure Store Service), registreras användningsdata för arbetsboken för det oövervakade Excel Services-användarkontot (eller för SSS-ID:t) istället för någon verklig person i organisationen.

  1. I Excel klickar du på Befintliga anslutningar på menyfliken Data.

  2. Klicka på en anslutning i arbetsboken > Öppna i dialogrutan Befintliga anslutningar.

  3. Klicka på Egenskaper > Definition > Autentiseringsinställningar.

  4. Kontrollera att Använd den autentiserade användarens konto är markerat.

Ange uppdateringsinställningar

Uppdateringsinställningar kan påverka förhandsgranskningar av PowerPivot-arbetsböcker i PowerPivot-galleriets bibliotek. Om arbetsboken t.ex. har egenskapen Uppdatera när filen öppnas och Excel Services är konfigurerat för att utfärda en varning vid datauppdateringsåtgärder, visas en miniatyrbild av Excels varning för datauppdatering istället för en förhandsgranskningsbild av dokumentet.

  1. I Excel klickar du på Anslutningar > Egenskaper på menyfliken Data.

  2. Under Användningen > Uppdatera, markerar eller avmarkerar du kryssrutan Uppdatera data när filen öppnas i enlighet med följande rekommendationer, beroende på hur åtkomst till datamodellens data sker:

Åtkomst till data

Rekommendation för Uppdatera

Inbäddade i arbetsboken (vanligaste situationen)

Avmarkera kryssrutan Uppdatera data när filen öppnas. Eftersom alla data är inbäddade är det onödigt att uppdatera dem varje gång du öppnar arbetsboken.

Lagras som en extern datakälla (t.ex. om du konfigurerar en extern dataanslutning i en arbetsbok i stället för att importera data)

Markera kryssrutan Uppdatera data när filen öppnas. Eftersom data ligger på en annan plats vill du att uppdatering ska ske, så att eventuella nya dataändringar samlas in.

Om du vill tillåta generering av förhandsgranskningsbilder ber du SharePoint-administratören att anpassa inställningen Varna vid uppdatering i Excel Services. Mer information finns i Skapa en betrodd plats för PowerPivot-webbplatser på TechNet.

Datauppdateringsåtgärder på serversidan (gäller för arbetsböcker som du sparar i SharePoint och schemalägger för PowerPivot-datauppdatering).

Markera kryssrutan Uppdatera data när filen öppnas. Eftersom datauppdatering har schemalagts för arbetsboken aktiveras automatiskt egenskapen Uppdatera data när filen öppnas på den här arbetsboken av Power Pivot för att säkerställa att pivottabellcachen ersätts med nyare data. Om du avmarkerar kryssrutan, markeras den automatiskt när du sparar arbetsboken i SharePoint.

Välj en plats för filen

Dokument som du delar på en webbplats sparas vanligen i ett dokumentbibliotek. Delade dokument är det vanligaste dokumentbiblioteket, men en SharePoint-webbplats som har Power Pivot för SharePoint har ofta Power Pivot-gallerier där du kan förhandsgranska, använda egna biblioteksvyer och enkelt få åtkomst till konfigurationsscheman för datauppdatering för arbetsboken.

Du måste välja en SharePoint-server som har PowerPivot för SharePoint. Om du publicerar på en server som inte har Power Pivot-serverprogramvaran, kommer inte data att läsas in när du öppnar dokumentet från ett bibliotek.

Du kan välja att lagra arbetsboken i Delade dokument, PowerPivot-galleri eller något annat dokumentbibliotek. För att kunna använda de här platserna måste du känna till URL-adressen till biblioteket. På en SharePoint-webbplats med standardinställningar används följande URL-adresser till biblioteken:

  • http://<server name>/Shared%20Documents

  • http://<server name>/PowerPivot%20Gallery

  • Om du vill hitta URL-adressen till ett bibliotek kan du högerklicka på ett dokument i biblioteket och välja Egenskaper. URL-adressen visar SharePoint-sökvägen till dokumentet. Se till att markera hela URL-adressen med hjälp av musen. Ibland kan långa URL-adresser vara delvis dolda.

  • Du måste troligen redigera URL-adressen innan du kan använda den. Mer specifikt innebär det att om URL-adressen inbegriper egenskaperna visningsprogram och källa, bör du ta bort de egenskaperna för att få en användbar sökväg bestående av namn på server, plats och bibliotek. Exempelvis kan man från följande URL-adress härleda den faktiska URL-sökvägen genom att behålla det fetstilta och ta bort resten: http://Contoso/Sales/_layouts/xlviewer.aspx?id=/PowerPivot%20Gallery/ContosoSales.xlsx&Source=http%3A%2F%2FContoso%2FPowerPivot%2520Gallery%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1. Utifrån URL-egenskapen skulle den verkliga sökvägen du bör använda i publiceringssyfte vara 'http://Contoso/Sales/PowerPivot%20Gallery/ContosoSales.xlsx' om du publicerade filen ContosoSales.xlsx, eller bara 'http://Contoso/Sales/PowerPivot%20Gallery' om du endast vill ha platsen och biblioteket.

  • När du väljer en plats bör du välja ett bibliotek som är tillgängligt för de personer som du vill dela arbetsboken med. Du kan behöva begära behörighet till bibliotek eller dokument för att säkerställa att arbetsboken är tillgänglig.

Spara filen till SharePoint

  1. I Excel klickar du på Arkiv > Spara som > SharePoint eller Webbplatser > Bläddra, och väljer sedan en plats.

  2. I dialogrutan Spara som anger du ett namn på filen i rutan Filnamn om du använder en befintlig plats. Alternativt, om du väljer Bläddra efter en plats anger du hela eller en del av URL-adressen till SharePoint-webbplatsen. Om du anger en del av URL-adressen, t.ex. http://<servernamn> ska du klicka på Spara för att öppna en anslutning till servern du angav och sedan bläddra efter biblioteket som du vill använda på webbplatsen. Det finns exempel på en URL-adress för SharePoint under Välj en plats för filen i det här avsnittet.

  3. Publicera arbetsboken i biblioteket genom att klicka på Spara.

Kontrollera att dokumentet visas i biblioteket i ett webbläsarfönster. Nyligen publicerade dokument visas i listan. Inställningar för bibliotek avgör var dokumentet ska visas (t.ex. sortering i stigande ordning efter datum eller i alfabetisk ordning efter namn). Du kan behöva uppdatera webbläsarfönstret för att de senaste tilläggen ska visas.

Överför en PowerPivot-arbetsbok från SharePoint

Ett annat sätt att lägga till en PowerPivot-arbetsbok är att överföra den från en SharePoint-webbplats. Använd den här metoden om du vill starta från SharePoint.

  1. Öppna ett dokumentbibliotek i en SharePoint-webbplats.

  2. Klicka på Dokument > Överför dokument > Överför dokument under Biblioteksverktyg.

  3. Bläddra till platsen för den sparade .xlsx-filen, markera den och klicka sedan på OK.

Filen laddas upp till SharePoint-webbplatsen och visas i mappen. Du kan behöva klicka på uppdateringsknappen i webbläsaren för att den ska visas. Den kan nu öppnas i SharePoint. Du kan berätta för andra var filen finns genom att dela URL-adressen till filen med dem.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×