Slå upp värden med LETARAD, INDEX eller PASSA

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

För att söka efter ett värde i en stor lista kan du använda funktionen LETARAD. Funktionen LETARAD används ofta men funktionen LETAKOLUMN och INDEX ihop med PASSA kan fungera bra för dig också.

Så här används LETARAD med tillhörande argument:

=LETARAD(<sökvärde>,<uppslagsområde>,<kolumn>,<ungefärlig matchning>)

Exempel: =LETARAD(21500,C2:E7,3,FALSE)

  • Det första argumentet – en del som behövs för att funktionen ska fungera – är det värde du vill söka på. Det kan vara en cellreferens som B2 eller ett värde som "Berg" eller 21500.

  • Det andra argumentet är det cellområde som du tror innehåller det värde du vill hitta.

    Viktigt!: Med LETARAD måste den kolumn som innehåller värdet eller cellreferensen du söker på vara längst till vänster i området.

  • Det tredje argumentet är den kolumn i uppslagscellområdet som innehåller värdet du vill se.

Det fjärde argumentet är, visserligen valfri ange de flesta FALSKT (eller 0). Varför? Eftersom det här tvingar fram funktionen för att söka efter en exakt matchning i rutan Sök. Du kan ange inga argument eller SANT, men om en exakt matchning inte hittas returneras närmasteungefärlig matchning– och vanligtvis flesta vilja förhindra att en ungefärlig matchning.

Om du vill visa hur en ungefärlig matchning kan vara allvarliga fel, anta att du letar efter pris för en webbdel med ID 2345768, men du byter två tal och skriver fel i formeln så här: =VLOOKUP(2345678,A1:E7,5). formeln returnerar priset för fel part eftersom LETARAD hitta närmaste tal mindre än eller lika med det nummer du angett (2345678). Du kan få fakturering en kund felaktigt på grund av felet.

Om du anger FALSE eller 0 i argumentet för ungefärlig matchning och det inte finns någon exakt matchning returneras #SAKNAS i cellen i stället för fel värde, något som du har mycket bättre nytta av. I det här fallet anger inte #SAKNAS att du skrev formeln fel (utom felskrivet nummer), det betyder att 2345678 inte hittades, men du sökte efter 2345768.

I det här exemplet visas hur funktionen fungerar. När du anger ett värde i cell B2 (det första argumentet) söker LETARAD igenom cellerna C2:E7 (det andra argumentet) och returnerar den närmaste ungefärliga matchningen från den tredje kolumnen i området, det vill säga kolumn E (det tredje argumentet).

Ett vanligt användande av funktionen LETARAD

I det här exemplet är det fjärde argumentet tomt så funktionen returnerar en ungefärlig matchning.

Använda funktionen LETAKOLUMN

När du har lärt dig hur LETARAD fungerar kan du även använda funktionen LETAKOLUMN på motsvarande sätt. Du anger samma argument, men värdena hämtas från rader i stället för från kolumner.

Andvända INDEX tillsammans med PASSA

Om du inte vill vara begränsad till sökningar i kolumnen längst till vänster kan du använda en kombination av funktionerna INDEX och PASSA. En formel som använder dessa ihop är lite mer komplicerad än en formel med funktionen LETARAD, men den kan vara mer kraftfull och det finns användare som föredrar INDEX/PASSA-kombinationen över funktionen LETARAD.

Det här exemplet visar en kort lista där värdet vi söker efter, Chicago, inte finns med i kolumnen längst till vänster. Därför kan vi inte använda funktionen LETARAD. I stället använder vi funktionen PASSA för att hitta Chicago i området B1:B11. Det finns i rad 4. Sedan används det värde som uppslagsargument och hittar Chicagos population i fjärde kolumnen (kolumn D). Formeln som används visas i cell A14.

Använda INDEX och PASSA för att slå upp ett värde

Mer information om LETAUPP-funktioner

Överst på sidan

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×