Slå upp värden med LETARAD, INDEX eller PASSA

Du har en lista över företagets siffror och vill veta hur många anställda som finns i varje kontor. Kalkylbladet är stort, så hur ska du göra? Använd funktionen LETARAD. Funktionerna LETARAD och LETAKOLUMN är de två mest användbara funktionerna tillsammans med INDEX and PASSA.

Obs!:  Om du försöker hitta uppslagsguiden är den funktionen inte längre en del av Excel.

Här är en snabb tillbakablick på hur du använder funktionen LETARAD.

=LETARAD (B2;C2:E7:3;SANT)

Det första argumentet – den datauppgift som funktionen behöver för att fungera – är det värdet du vill hitta. Det kan vara en cellreferens eller ett hård värde som "Berg" eller 21 000. Det andra argumentet är det cellområde som du tror innehåller det värde du vill hitta. I det här exemplet är det C2–C7. Det tredje argumentet är den kolumn i cellområdet som innehåller värdet du vill hitta.

Det fjärde argumentet är valfritt. Du anger Sant eller Falskt. Om du anger SANT eller lämnar argumentet tomt returnerar funktionen en ungefärlig match av värdet du angav i det första argumentet. Om du anger FALSKT matchar funktionen värdet som angavs i det första argumentet. Med andra ord får du mer flexibilitet om du lämnar det fjärde argumentet tomt eller anger SANT.

I det här exemplet visas hur funktionen fungerar. När du anger ett värde i cell B2 (det första argumentet) söker LETARAD igenom cellerna C2-E7 (det andra argumentet) och returnerar den närmaste ungefärliga matchen från den tredje kolumnen i området, det vill säga kolumn E (det tredje argumentet).

Ett vanligt användande av funktionen LETARAD

Det fjärde argumentet är tomt så funktionen returnerar en ungefärlig match. Om den inte gjorde det skulle du ha behövt ange ett av värdena i kolumn C eller D för att få ett resultat över huvud taget.

När du har lärt dig LETARAD borde inte funktionen LETAKOLUMN vara så svår att använda. Du anger samma argument men värdena hämtas från rader i stället för från kolumner.

Testa själv

Om du vill prova på sökfunktionerna innan du börjar använda dem kan du använda några av dessa exempeldata. Många gillar att använda LETARAD och LETAKOLUMN medan andra föredrar INDEX och PASSA tillsammans. Prova varje metod och se vilken du gillar bäst.

LETARAD på arbetet

Kopiera alla celler i den här tabellen och klistra in dem i cell A1 i en tom arbetsbok i Excel.

Tips!    Innan du klistrar in data i Excel anger du kolumnbredden för kolumn A till C till 250 bildpunkter och klickar på Radbryt text (fliken Start, gruppen Justering).

Densitet

Viskositet

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beskrivning

Resultat

'=LETARAD(1;A2:C10;2)

Söker med en ungefärlig matchning efter värdet 1 i kolumn A, identifierar det största värde som är mindre än eller lika med 1 i kolumn A, d.v.s. 0,946, och returnerar sedan värdet från kolumn B på samma rad.

=LETARAD(1;A2:C10;2)

'=LETARAD(1;A2:C10:3;SANT)

Söker med en ungefärlig matchning efter värdet 1 i kolumn A, identifierar det största värde som är mindre än eller lika med 1 i kolumn A, d.v.s. 0,946, och returnerar sedan värdet från kolumn C på samma rad.

=LETARAD(1;A2:C10:3;SANT)

'=LETARAD(0,7;A2:C10;3;FALSKT)

Söker med en exakt matchning efter värdet 0,7 i kolumn A. Eftersom det inte finns någon exakt matchning i kolumn A, returneras ett fel.

=LETARAD(0,7;A2:C10;3;FALSKT)

'=LETARAD(0,1;A2:C10:3;SANT)

Söker med en ungefärlig matchning efter värdet 0,1 i kolumn A. Eftersom 0,1 är mindre än det minsta värdet i kolumn A, returneras ett fel.

=LETARAD(0,1;A2:C10;2;SANT)

'=LETARAD(2;A2:C10:3;SANT)

Söker med en ungefärlig matchning efter värdet 2 i kolumn A, identifierar det största värde som är mindre än eller lika med 2 i kolumn A, d.v.s. 1,29, och returnerar sedan värdet från kolumn B på samma rad.

=LETARAD(2;A2:C10;2;SANT)

LETAKOLUMN på arbetet

Kopiera alla celler i den här tabellen och klistra in dem i cell A1 i en tom arbetsbok i Excel.

Tips!    Innan du klistrar in data i Excel anger du kolumnbredden för kolumn A till C till 250 bildpunkter och klickar på Radbryt text (fliken Start, gruppen Justering).

Axlar

Lager

Bultar

4.

4.

9

5.

7

10

6.

8

11

Formel

Beskrivning

Resultat

'=LETAKOLUMN("Axlar"; A1:C4; 2; SANT)

Slår upp Axlar i rad 1 och returnerar värdet från rad 2 som är i samma kolumn (kolumn A).

=LETAKOLUMN("Axlar";A1:C4;2;SANT)

'=LETAKOLUMN("Lager"; A1:C4; 3; FALSKT)

Slår upp Lager i rad 1 och returnerar värdet från rad 3 som är i samma kolumn (kolumn B).

=LETAKOLUMN("Lager";A1:C4;3;FALSKT)

'=LETAKOLUMN("B"; A1:C4; 3; SANT)

Slår upp B i rad 1 och returnerar värdet från rad 3 som är i samma kolumn. Eftersom en exakt match för "B" inte hittas används i stället det högsta värdet i rad 1 som är mindre än "B": "Axlar" i kolumn A.

=LETAKOLUMN("B";A1:C4;3;SANT)

'=LETAKOLUMN("Bultar"; A1:C4; 4)

Slår upp Bultar i rad 1 och returnerar värdet från rad 4 som är i samma kolumn (kolumn C).

=LETAKOLUMN("Bultar";A1:C4;4)

'=LETAKOLUMN(3; {1;2;3\"a";"b";"c"\"d";"e";"f"}; 2; SANT)

Slår upp talet 3 i en matriskonstant med tre rader och returnerar värdet från rad 2 i samma kolumn (i det här fallet tredje kolumnen). Det finns tre rader med värden i matriskonstanten, varje rad är avgränsad med ett omvänt snedstreck (\). Eftersom "c" hittas i rad 2 och i samma kolumn som 3 returneras värdet "c".

=LETAKOLUMN(3; {1;2;3\"a";"b";"c"\"d";"e";"f"}; 2; SANT)

Använda INDEX och PASSA

I det här exemplet returneras de tidigaste fakturanumret och motsvarande datum för varje stad med hjälp funktionerna INDEX och PASSA. Eftersom data returneras som ett tal formaterar vi det till ett datum med funktionen TEXT. Funktionen INDEX användare resultatet av funktionen PASSA som dess argument. Kombinationen av INDEX och PASSA används två gånger i vardera formel – först för att returnera fakturanumret och sedan för att returnera datumet.

Kopiera alla celler i den här tabellen och klistra in dem i cell A1 i en tom arbetsbok i Excel.

Tips!    Innan du klistrar in data i Excel anger du kolumnbredden för kolumn A till D till 250 bildpunkter och klickar på Radbryt text (fliken Start, gruppen Justering).

Faktura

Ort

Fakturadatum

Tidigaste faktura efter stad med datum

3115

Atlanta

2012-04-07

="Atlanta = "&INDEX($A$2:$C$33;PASSA("Atlanta";$B$2:$B$33;0);1)& ", fakturadatum: " & TEXT(INDEX($A$2:$C$33;PASSA("Atlanta";$B$2:$B$33;0);3);"åååå-mm-dd")

3137

Atlanta

2012-04-09

="Austin = "&INDEX($A$2:$C$33;PASSA("Austin";$B$2:$B$33;0);1)& ", fakturadatum: " & TEXT(INDEX($A$2:$C$33;PASSA("Austin";$B$2:$B$33;0);3);"åååå-mm-dd")

3154

Atlanta

2012-04-11

="Dallas = "&INDEX($A$2:$C$33;PASSA("Dallas";$B$2:$B$33;0);1)& ", fakturadatum: " & TEXT(INDEX($A$2:$C$33;PASSA("Dallas";$B$2:$B$33;0);3);"åååå-mm-dd")

3191

Atlanta

2012-04-21

="New Orleans = "&INDEX($A$2:$C$33;PASSA("New Orleans";$B$2:$B$33;0);1)& ", fakturadatum: " & TEXT(INDEX($A$2:$C$33;PASSA("New Orleans";$B$2:$B$33;0);3);"åååå-mm-dd")

3293

Atlanta

2012-04-25

="Tampa = "&INDEX($A$2:$C$33;PASSA("Tampa";$B$2:$B$33;0);1)& ", fakturadatum: " & TEXT(INDEX($A$2:$C$33;PASSA("Tampa";$B$2:$B$33;0);3);"åååå-mm-dd")

3331

Atlanta

2012-04-27

3350

Atlanta

2012-04-28

3390

Atlanta

2012-05-01

3441

Atlanta

2012-05-02

3517

Atlanta

2012-05-08

3124

Austin

2012-04-09

3155

Austin

2012-04-11

3177

Austin

2012-04-19

3357

Austin

2012-04-28

3492

Austin

2012-05-06

3316

Dallas

2012-04-25

3346

Dallas

2012-04-28

3372

Dallas

2012-05-01

3414

Dallas

2012-05-01

3451

Dallas

2012-05-02

3467

Dallas

2012-05-02

3474

Dallas

2012-05-04

3490

Dallas

2012-05-05

3503

Dallas

2012-05-08

3151

New Orleans

2012-04-09

3438

New Orleans

2012-05-02

3471

New Orleans

2012-05-04

3160

Tampa

2012-04-18

3328

Tampa

2012-04-26

3368

Tampa

2012-04-29

3420

Tampa

2012-05-01

3501

Tampa

2012-05-06

Mer information om LETAUPP-funktioner

Överst på sidan

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×