Skapa villkorliga formler

Ofta behöver du testa om ett villkor är sant eller falskt och göra logiska jämförelser mellan uttryck. Du kan använda funktionerna OCH, ELLER, ICKE och OM för att skapa villkorliga formler.

Exempelvis används följande argument i OM-funktionen.

Formel med funktionen OM

Formel som använder funktionen OM

Bild av knapp  logisk_test: Det villkor som du vill utvärdera.

Bild av knapp  värde_om_sant: Det värde som ska returneras om villkoret är sant.

Bild av knapp  värde_om_falskt: Det värde som ska returneras om villkoret är falskt.

Mer information om hur du skapar formler finns i Skapa eller ta bort en formel.

Vad vill du göra?

Skapa en villkorlig formel som resulterar i ett logiskt värde (SANT eller FALSKT)

Skapa en villkorlig formel som resulterar i en annan beräkning eller i andra värden än SANT eller FALSKT

Skapa en villkorlig formel som resulterar i ett logiskt värde (SANT eller FALSKT)

Använd funktionerna och operatorerna OCH, ELLER och ICKE om du vill utföra den här åtgärden, som i exemplet nedan.

Exempel

Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

Hur kopierar jag ett exempel?

  1. Markera exemplet i den här artikeln.

    Viktigt!: Markera inte rad- eller kolumnrubrikerna.

    välja ett exempel från hjälpen i Excel 2013 för Windows

    Markera ett exempel i hjälpen

  2. Tryck på CTRL+C.

  3. Skapa en tom arbetsbok eller ett tomt kalkylblad i Excel.

  4. Markera cell A1 i kalkylbladet och tryck på CTRL+V.

Viktigt!: För att exemplet ska fungera måste du klistra in det i cell A1 i kalkylbladet.

  1. Om du vill växla mellan att visa resultaten och de formler som returnerar resultaten trycker du på CTRL+` (grav accent). Du kan också gå till fliken Formler och klicka på knappen Visa formler i gruppen Formelgranskning.

När du har kopierat exemplet till ett tomt kalkylblad kan du anpassa det efter dina behov.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Data

15

9

8

Skruvar

Muttrar

Formel

Beskrivning (resultat)

=OCH(A2>A3;A2<A4)

Fastställer om värdet i cell A2 är större än värdet i A3 och även om värdet i A2 är mindre än värdet i A4. (FALSKT)

=ELLER(A2>A3;A2<A4)

Fastställer om värdet i cell A2 är större än värdet i A3 eller om värdet i A2 är mindre än värdet i A4. (SANT)

=ICKE(A2+A3=24)

Fastställer om summan av värdena i cellerna A2 och A3 inte är lika med 24. (FALSKT)

=ICKE(A5="Skruvar")

Fastställer om värdet i cell A5 inte är lika med "Skruvar". (FALSKT)

=ELLER(A5<>"Skruvar";A6 = "Muttrar")

Fastställer om värdet i cell A5 inte är lika med "Skruvar" eller om värdet i A6 är lika med "Muttrar". (SANT)

Mer information om hur du använder de här funktionerna finns i Funktionen OCH, Funktionen ELLER och Funktionen ICKE.

Överst på sidan

Skapa en villkorlig formel som resulterar i en annan beräkning eller i andra värden än SANT eller FALSKT

Använd funktionerna och operatorerna OM, OCH och ELLER för att utföra den här åtgärden, som i exemplet nedan.

Exempel

Detta blir enklare att förstå om du kopierar exemplet till ett kalkylblad.

Hur kopierar jag ett exempel?

  1. Markera exemplet i den här artikeln.

Viktigt!: Markera inte rad- eller kolumnrubrikerna.

välja ett exempel från hjälpen i Excel 2013 för Windows

Markera ett exempel i hjälpen

  1. Tryck på CTRL+C.

  2. Skapa en tom arbetsbok eller ett tomt kalkylblad i Excel.

  3. Markera cell A1 i kalkylbladet och tryck på CTRL+V.

Viktigt!: För att exemplet ska fungera måste du klistra in det i cell A1 i kalkylbladet.

  1. Om du vill växla mellan att visa resultaten och de formler som returnerar resultaten trycker du på CTRL+` (grav accent). Du kan också gå till fliken Formler och klicka på knappen Visa formler i gruppen Formelgranskning.

När du har kopierat exemplet till ett tomt kalkylblad kan du anpassa det efter dina behov.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Data

15

9

8

Skruvar

Muttrar

Formel

Beskrivning (resultat)

=OM(A2=15;"OK";"Inte OK")

Om värdet i cell A2 är lika med 15, returnera "OK". I annat fall, returnera "Inte OK". (OK)

=OM(A2<>15;"OK";"Inte OK")

Om värdet i cell A2 inte är lika med 15, returnera "OK". I annat fall, returnera "Inte OK". (Inte OK)

=OM(ICKE(A2<=15);"OK";"Inte OK")

Om värdet i cell A2 inte är mindre än eller lika med 15, returnera "OK". I annat fall, returnera "Inte OK". (Inte OK)

=OM(A5<>"SKRUVAR";"OK";"Inte OK")

Om värdet i cell A5 inte är lika med "SKRUVAR", returnera "OK". I annat fall, returnera "Inte OK". (Inte OK)

=OM(OCH(A2>A3;A2<A4);"OK";"Inte OK")

Om värdet i cell A2 är större än värdet i A3 och värdet i A2 också är mindre än värdet i A4, returnera "OK". I annat fall, returnera "Inte OK". (Inte OK)

=OM(OCH(A2<>A3;A2<>A4);"OK";"Inte OK")

Om värdet i cell A2 inte är lika med A3 och värdet i cell A2 inte är lika med värdet i A4, returnera "OK". I annat fall, returnera "Inte OK". (OK)

=OM(ELLER(A2>A3;A2<A4);"OK";"Inte OK")

Om värdet i cell A2 är större än värdet i A3 eller om värdet i A2 är mindre än värdet i A4, returnera "OK". I annat fall, returnera "Inte OK". (OK)

=OM(ELLER(A5<>"Skruvar";A6<>"Muttrar");"OK";"Inte OK")

Om värdet i cell A5 inte är lika med "Skruvar" eller värdet i cell A6 inte är lika med "Muttrar", returnera "OK". I annat fall, returnera "Inte OK". (Inte OK)

=OM(ELLER(A2<>A3; A2<>A4);"OK";"Inte OK")

Om värdet i cell A2 inte är lika med värdet i A3 eller om värdet i A2 inte är lika med värdet i A4, returnera "OK". I annat fall, returnera "Inte OK". (OK)

Mer information om hur du använder de här funktionerna finns i Funktionen OM, Funktionen OCH och Funktionen ELLER.

Överst på sidan

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×