Skapa ett kopplat dokument eller kopplad e-post i Publisher

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Du kan använda funktionen koppla dokument eller koppla e-post när du vill skapa ett stort antal dokument som till största delen är identiska men även innehåller viss unik information. Du kan till exempel använda funktionen koppla dokument för att skapa individuellt anpassade publikationer med personliga anteckningar eller unika adresser och hälsningsfraser. Du kan också använda dokumentkoppling när du vill skapa produktinformation som du vill anpassa innan du skickar den till specifika personer. Texten i publikationen är alltid densamma, men namn och adress är olika för varje mottagare.

I den här artikeln

Välja Koppla dokument eller Koppla e-post

Skapa eller ansluta till mottagarlistan

Förbereda publikationen

Skapa den kopplade publikationen

Avbryta en koppling

Välja Koppla dokument eller Koppla e-post

Det första du ska göra är att välja om du vill koppla dokument för utskrift eller koppla e-post för onlinedistribution.

  • Klicka på fliken Utskick och välj antingen Koppla dokument eller Koppla e-post.

Skapa eller ansluta till mottagarlistan

Om du vill koppla dokument måste du öppna en ny eller befintlig publikation och sedan ansluta till en datakälla (en fil som innehåller den unika information som du vill inkludera). En datafil kan innehålla en lista med namn och adresser, produktdata eller bilder. Datafilen kan ha en mängd olika format, till exempel:

  • Lista över Outlook-kontakter

  • Excel-kalkylblad

  • Word-tabeller

  • Access-databastabeller

  • Textfiler i vilka flikar eller semikolon avgränsar kolumnerna och stycketecken avgränsar raderna

Du kan ansluta till en befintlig lista eller datakälla, eller så kan du skapa en ny mottagarlista. Om du bara vill använda vissa poster i listan kan du filtrera listan med ett specifikt kriterium. Du kan också sortera objekten i alfabetisk ordning.

Obs!: Om du vill koppla bilder till sidorna i publikationen måste datakällan innehålla antingen filnamn eller sökvägar för bildfilerna som du vill koppla. Inkludera inte de verkliga bilderna i datakällan.

Välj mottagare från menyfliksområdet

Använda en befintlig lista

  1. Klicka på Utskick > Välj mottagare > Använd befintlig lista.

    Som standard lagras datakällor i Publisher i mappen Mina datakällor. Du kan behöva bläddra för att hitta datakällan.

  2. Klicka på önskad datakälla i dialogrutan Välj datakälla och klicka sedan på Öppna.

    Beroende på vilken typ av datakälla du väljer kan andra dialogrutor visas där du ska ange specifik information. Om datakällan till exempel är en Excel-arbetsbok med information på flera kalkylblad måste du markera det kalkylblad som innehåller den information du vill ha.

Välja från Outlook-kontakter

  1. Klicka på Utskick > Välj mottagare > Välj från Outlook-kontakter.

    Om du uppmanas att välja en e-postprofil klickar du på den profil du vill använda och sedan på OK.

  2. Klicka på önskad kontaktlista i dialogrutan Välj kontakter och klicka sedan på OK.

    Alla kontakter i mappen visas i dialogrutan Koppla dokument för mottagare, där du kan filtrera och sortera listan med mottagare som ska inkluderas i kopplingen.

Skapa en ny lista

Om du inte har någon befintlig lista att ansluta till kan du skapa en ny lista.

  1. Klicka på Utskick > Välj mottagare > Skriv ny lista.

  2. I dialogrutan Ny adresslista skriver du informationen för den första posten i de fält som är relevanta för ditt utskick.

    Obs!:  Om du vill ändra standardkolumnerna klickar du på Anpassa kolumner och lägger till, tar bort, byter namn på eller ändrar ordningen på kolumnerna i listan.

  3. När du har skrivit in informationen för den första posten klickar du på Ny post.

  4. Upprepa steg 2 och 3 tills du är klar med att lägga till poster och klicka sedan på OK.

  5. Ange ett namn på adresslistan i dialogrutan Spara adresslista i rutan Filnamn och spara den.

    Obs!: Som standard sparar Publisher adresslistor i mappen Mina datakällor. Det är bäst att spara adresslistan i den mappen eftersom den också är standardmappen där Publisher söker efter datakällor.

    Alla kontakter i den nya listan visas i dialogrutan Koppla dokument för mottagare, där du kan filtrera och sortera listan med mottagare som ska inkluderas i kopplingen.

Välj mottagare

I dialogrutan Koppla dokument för mottagare kan du välja de mottagare som du vill inkludera i kopplingen. Markera kryssrutorna bredvid de mottagare som du vill ska ingå, och avmarkera kryssrutorna bredvid de mottagare som du inte vill ska ingå.

Om du bara vill använda vissa poster i listan kan du filtrera listan efter ett visst fält eller kriterium. När du en gång har filtrerat listan kan du använda kryssrutorna för att inkludera eller utelämna poster.

Filtrera objekt i listan:

  1. Klicka på pilen bredvid kolumnrubriken för det objekt som du vill filtrera efter.

  2. Klicka på något av följande:

    • Med (Tomma) visas alla poster där motsvarande fält är tomt.

    • Med (Ifyllda) visas alla poster där motsvarande fält innehåller information.

    • Med (Avancerat) öppnas dialogrutan Filtrera och sortera, som du kan använda för att filtrera på flera villkor. Du kan också klicka på Filtrera under Förfina mottagarlistan i dialogrutan Koppla dokument för mottagare för att öppna dialogrutan Filtrera och sortera.

    • Du kan snabbt markera eller avmarkera alla objekt genom att markera eller avmarkera kryssrutans kolumnrubrik.

      Tips: Om datakällan innehåller poster som delar samma information och det finns tio eller färre unika värden i kolumnen, kan du filtrera efter specifik information. Om det till exempel finns flera adresser som har Australien som land/region kan du filtrera på Australien.

      I dialogrutan Koppla dokument för mottagare visas bara de angivna posterna. Klicka på (Alla) om du vill visa alla poster igen.

Om du vill se objekten i alfabetisk ordning kan du sortera objekten i listan.

Sortera objekt i listan:

  • Klicka på kolumnrubriken för det objekt som du vill sortera efter i dialogrutan Koppla dokument för mottagare. Om du till exempel vill visa listan i alfabetisk ordning efter efternamn klickar du på kolumnrubriken Efternamn.

  • Om du vill sortera efter flera kriterier klickar du på Sortera i dialogrutan Koppla dokument för mottagare. I dialogrutan Filtrera och sortera som visas väljer du de villkor som du vill sortera efter.

Överst på sidan

Förbereda publikationen

Med en dokumentkoppling skapas många dokument från en enda mall med hjälp av platshållarinformation och unik information som läggs till i platshållarinformationen i varje dokument. När du har fått ihop mottagarlistan kan du färdigställa huvudmallen.

Infoga en textruta

  1. Klicka på Infoga > Rita textruta Bild av knapp .

  2. Peka i publikationen på den plats där du vill att ena hörnet på textrutan ska vara, och dra sedan diagonalt tills textrutan har rätt storlek.

Lägga till den text du vill ha i varje version

  • Klicka i textrutan och skriv in den text du vill ska visas i varje version av den kopplade publikationen.

Lägga till datafält i publikationen

Infoga dokumentkopplingsfält

  1. I den kopplade publikationen klickar du i textrutan där du vill infoga datafältet.

  2. Infoga något av följande:

    • Adressblock med namn, adress och annan information:

      1. I gruppen Skriv och infoga fält klickar du på Adressblock.

      2. Klicka på de adresselement som du vill inkludera i dialogrutan Infoga adressblock och klicka sedan på OK.

        Obs!: Om namnen på datafälten i datakällan inte matchar namnen på de fält som Publisher använder för adressblocket, kanske du behöver klicka på Matcha fält i dialogrutan Infoga adressblock. I dialogrutan Matcha fält använder du listrutorna för att välja fält från datakällan som motsvarar Publisher-fälten.

    • Hälsningsraden

      1. I gruppen Skriv och infoga fält klickar du på Hälsningsrad.

      2. Välj format för hälsningsraden, vilket innefattar hälsningsfras, namnformat och skiljetecken efter frasen, i dialogrutan Hälsningsrad.

      3. Välj vilken text som ska visas om mottagarnamnet inte kan tolkas av Publisher, till exempel när datakällan inte innehåller något förnamn eller efternamn för mottagaren utan bara ett företagsnamn, och klicka sedan på OK.

        Obs!:  Om namnen på datafälten i datakällan inte matchar namnen på de fält som Publisher använder för hälsningsraden, kanske du behöver klicka på Matcha fält i dialogrutan Hälsningsrad. I dialogrutan Matcha fält använder du listrutorna för att välja fält från datakällan som motsvarar Publisher-fälten.

    • Bild

      1. I gruppen Skriv och infoga fält klickar du på Bild och sedan på Lägg till bildfält.

      2. Välj bildfältet som ska infogas i dialogrutan Lägg till bildfält.

      3. Obs!: Om du vill koppla bilder till sidorna i publikationen måste datakällan innehålla antingen filnamn eller sökvägar för bildfilerna som du vill koppla. Inkludera inte de verkliga bilderna i datakällan.

    • Enskilda fält med information

      • I gruppen Skriv och infoga fält väljer du Infoga kopplingsinstruktion och klickar sedan på de fält som du vill inkludera i textrutan.

Formatera datafälten

Du kan använda format på datafälten och annan text du har lagt till (t.ex. en hälsning som Hej eller en hälsningsfras som Bästa...) om du vill ändra utseendet på kopplade data. När du vill formatera kopplade data måste du formatera datafälten i den kopplade publikationen.

I den kopplade publikation väljer du det fält som innehåller den information som du vill formatera.

  • Om fältet är ett Adressblock eller en Hälsningsfras väljer du Format i gruppen Skriv och infoga fält.

  • Om fältet är ett enskilt datafält går du till menyn Verktyg för textruta, klickar på Teckensnitt och väljer de alternativ du vill använda.

  • Om det valda fältet kan identifieras i Publisher som ett tal, valuta, datum eller tid, klickar du på Format och ändrar formateringen av hur dessa typer av fält ska visas.

Förhandsgranska mottagardata i datafälten i publikationen

Du kan granska hur publikationen kommer att visas med verkliga data i de kopplade fälten.

Om du vill förhandsgranska publikationen klickar du på Förhandsgranska resultat och gör sedan något av följande:

  • Om du vill förhandsgranska poster i ordning klickar du på navigeringsknapparna Knappen Framåt Knappen Bakåt för att se hur varje post visas i den kopplade publikationen.

    Informationen från den första posten i din datakälla fyller på kopplingsinstruktionerna. Du kan inte redigera datakällans poster på sidorna i publikationen, men du kan formatera, flytta eller ta bort datafält där.

  • Om du vill söka efter och förhandsgranska en viss post i datakällan klickar du på Sök efter en mottagare och anger sedan sökvillkoren i dialogrutan Sök post.

Om du vill kan du göra ändringar i mottagarlistan. Gör något av följande:

  • Om du vill utesluta en viss mottagare från kopplingen klickar du på Utelämna denna mottagare.

  • Om du vill ändra listan över mottagare klickar du på Redigera mottagarlista och gör sedan ändringarna i dialogrutan Koppla dokument för mottagare.

När du är klar med den kopplade publikationen och har fört in alla kopplingsinstruktionerna går du till Arkiv > klickar på Spara som, namnger publikationen och klickar på Spara.

Överst på sidan

Skapa den kopplade publikationen

När du vill skapa den kopplade publikationen klickar du på Slutför och koppla och följer anvisningarna nedan för att skriva ut, förhandsgranska, spara den, lägga till de kopplade sidorna i en annan publikation eller skicka dem via e-post.

Slutföra dokumentkopplingen

Skriva ut den kopplade publikationen

  1. Klicka på Koppla till skrivare.

  2. I området Skriv ut väljer du utskriftsalternativ och klickar sedan på OK.

    Viktigt!: Om du vill skriva ut olika uppsättningar av kopplade data, till exempel olika namn och adresser, klickar du på Flera sidor per ark i avsnittet Utskriftsalternativ på varje pappersark. Om du väljer Flera kopior per ark kommer varje pappersark att innehålla flera kopior av samma data.

    Skriv ut flera sidor per ark

Spara den kopplade publikationen för senare användning

Om du vill redigera de kopplade sidorna, spara dem för senare användning eller skriva ut dem vid ett senare tillfälle kan du samla ihop och spara alla kopplade sidor som en enda ny kopplad publikation som innehåller verkliga data istället för kopplingsinstruktioner.

  1. Klicka på Koppla till ny publikation.

  2. I den nya publikationen, i åtgärdsfönstret Koppla dokument, klickar du på Spara den här publikationen. Namnge den nya publikationen och klicka på Spara.

Lägga till de kopplade sidorna i en befintlig publikation

Om du planerar att lägga till de kopplade sidorna i slutet av en befintlig publikation ska du kontrollera att den kopplade publikationen matchar den befintliga publikationen på följande sätt:

  • Sidstorlek (höjd och bredd)

  • Sidvy (enkelsidigt eller dubbelsidigt uppslag)

  • Publikationstyp (webb eller utskrift)

  • Sidordning (vänster till höger eller höger till vänster)

Publisher lägger till kopplade sidor i en ny eller befintlig publikation, men kan inte lägga till dem i en öppen publikation. Om en publikation som du vill koppla till är öppen måste du spara och stänga den innan du kan slutföra kopplingen.

  1. Klicka på Lägg till i befintlig publikation.

  2. Leta reda på publikationen där du vill lägga till de kopplade sidorna i dialogrutan Öppna publikation och klicka sedan på Öppna.

  3. Spara uppdateringarna genom att i den befintliga publikationen klicka på Spara den här publikationen i åtgärdsfönstret Koppla dokument.

Skicka e-postmeddelanden

Om du använder funktionen Koppla e-post kommer det enda alternativet under Slutför och koppla att vara Skicka e-postmeddelande.

  1. Klicka på Skicka e-postmeddelande.

  2. Välj mottagarfältet i listrutan Till i dialogrutan Koppla dokument, till e-post. I de flesta fall är det E-postadress.

  3. Under Ämne skriver du ämnesraden. Under Objekt som ska infogas klickar du på de datafält som du vill infoga i ämnesraden.

  4. Klicka på Alternativ för att ange andra alternativ som du vill använda, till exempel mottagare för Kopia eller Hemlig kopia eller bifogade filer och klicka på Skicka.

Spara den kopplade publikationen

Om du även sparar publikationen som innehåller de kopplade fälten kan du gå tillbaka och redigera fälten och skapa en ny kopplad publikation. Gör så här för att spara den kopplade publikationen:

  1. Klicka på Arkiv > Spara.

  2. Ge publikationen ett namn och klicka på Spara.

Överst på sidan

Avbryta en koppling

Du kan avbryta en koppling om du vill koppla bort en kopplad publikation eller en mall för kopplad katalog från datakällan.

  1. Klicka på fliken Utskick > Välj mottagare och sedan på Avbryt koppling.

    Avbryt koppling

  2. När du tillfrågas om du vill avbryta kopplingen klickar du på Ja.

    Obs!: Om du avbryter en dokumentkoppling omvandlas fält som inte är Adressfält, Hälsningsfraser och Adressblock till vanlig text.

Överst på sidan

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Hade du nytta av den här informationen?

Hur kan vi förbättra den?

Hur kan vi förbättra den?

För att skydda din integritet bör du inte ange någon kontaktinformation i feedbacken. Granska våra sekretesspolicy.

Tack för din feedback!