Skapa ett histogram

Ett histogram är ett stapeldiagram som visar frekvensdata.

Obs!: I det här avsnittet går det bara att skapa ett histogram. Information om diagram för Pareto (sorterat histogram) finns i skapa ett Pareto-diagram.

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på Infoga > Infoga statistikdiagram > Histogram.

    Kommando för histogram som nås via knappen Infoga statistiskt diagram

    Du kan också skapa ett histogram från fliken alla diagram i rekommenderade diagram.

Tips: 

  • Använd flikarna design och format för att anpassa utseendet på diagrammet.

  • Om flikarna inte visas kan du lägga till Diagramverktyg i menyfliksområdet genom att klicka var som helst i histogrammet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på den vågräta axeln i diagrammet, klicka på Formatera axeloch klicka sedan på alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i följande tabell för att bestämma vilka alternativ du vill ställa in i åtgärds fönstret Formatera axel .

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet om kategorierna (vågrät axel) är textbaserade i stället för numeriska. I histogrammet grupperas samma kategorier och värdena summeras på värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatiskt

    Det här är standardinställningen för histogram. Lager plats bredden beräknas med hjälp av Glenns normala referens regel.

    Fackbredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryss rutan om du vill skapa en lager plats för alla värden ovanför värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimal tal i rutan.

    Fack för värden under (underflow bin)

    Markera den här kryss rutan om du vill skapa en lager plats för alla värden under eller lika med värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimal tal i rutan.

    Åtgärdsfönstret Formatera axlar

Tips: Om du vill veta mer om diagrammet histogram och hur du visualiserar statistik data kan du läsa det här blogg inlägget i histogram-, Pareto-och låddiagram från Excel-teamet. Du kanske också är intresse rad av andra nya diagram typer som beskrivs i det här blogg inlägget.

Automatiskt alternativ (Scott ' normal referens regel)   

Formel för alternativet Automatisk

Scotts normalreferensregel försöker minimera snedvridningen i varians för histogrammet jämfört med datauppsättningen, samtidigt som normalfördelade data förutsätts.

Alternativet spill lager plats   

Formel för alternativet Lagerplats för överskott

Alternativet lager plats för under flöde   

Formel för alternativet Lagerplats för underskott
  1. Kontrol lera att du har läst in Analysis ToolPak. Mer information finns i läsa in Analysis ToolPak i Excel.

  2. Skriv indata i en kolumn på kalkylbladet och lägg till en etikett i den första cellen om du vill.

    Se till att använda kvantitativa numeriska data, t.ex. artikelantal eller testpoäng. Histogramverktyget fungerar inte med kvalitativa numeriska data, t.ex. identifieringsnummer som angetts som text.

  3. I nästa kolumn skriver du lagerplatsnumren i stigande ordning och lägger till en etikett i den första cellen om du vill.

    Det är en bra idé att använda dina egna facknummer, eftersom de kan vara mer värdefulla för din analys. Om du inte anger några facknummer skapar histogramverktyget jämnt fördelade fackintervall genom att använda minimi- och maximivärdena i indataområdet som start- och slutpunkter.

  4. Klicka på Data > Dataanalys.

    Knappen Dataanalys i gruppen Dataanalys

  5. Klicka på Histogram > OK.

    Dialogrutan Dataanalys

  6. Under Indata gör du följande:

    1. I rutan Indataområde anger du cellreferensen för det dataområde som innehåller indatanumren.

    2. I rutan Fackintervall anger du cellreferensen för det område som har facknumren.

      Om du använde kolumnetiketter på kalkylbladet kan du ta med dem i cellreferenserna.

      Tips: I stället för att ange referenser manuellt, kan du klicka på Knappen Minimera och tillfälligt dölja dialogrutan för att välja områden på kalkylbladet. Om du klickar på knappen igen expanderas dialogrutan.

  7. Om du tog med kolumnetiketter i cellreferenserna markerar du rutan Etiketter.

  8. Under Utdataalternativ väljer du en utdataplats.

    Du kan placera histogrammet i samma kalkylblad, ett nytt kalkylblad i samma arbetsbok eller i en ny arbetsbok.

  9. Markera en eller fler av följande rutor:

    Pareto (sorterat histogram) Visa data i fallande frekvensordning.

    Ackumulerad procent     Visar ackumulerad procent och lägger till en rad med ackumulerad procent i histogramdiagrammet.

    Diagramutdata     Visar ett inbäddat histogramdiagram.

  10. Klicka på OK.

    Om du vill anpassa histogrammet kan du ändra text etiketterna och klicka någonstans i diagrammet för att använda diagram element, diagram formatoch diagram filter knappar till höger om diagrammet.

  1. Markera data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka Infoga > Diagram.

    Knappen Diagram i gruppen Illustrationer på fliken Infoga i Word
  3. Klicka på histogram under alla diagrami dialog rutan infoga diagram och klicka på OK.

Tips: 

  • Använd flikarna design och format i menyfliksområdet om du vill anpassa diagrammets utseende.

  • Om flikarna inte visas kan du lägga till Diagramverktyg i menyfliksområdet genom att klicka var som helst i histogrammet.

Flikarna Design och Format för Diagramverktyg

  1. Högerklicka på den vågräta axeln i diagrammet, klicka på Formatera axeloch klicka sedan på alternativ för axel.

    Kommandot Formatera axel på snabbmenyn
  2. Använd informationen i följande tabell för att bestämma vilka alternativ du vill ställa in i åtgärds fönstret Formatera axel .

    Alternativ

    Beskrivning

    Efter kategori

    Välj det här alternativet om kategorierna (vågrät axel) är textbaserade i stället för numeriska. I histogrammet grupperas samma kategorier och värdena summeras på värdeaxeln.

    Tips: Om du vill räkna antalet förekomster för textsträngar lägger du till en kolumn och fyller den med värdet "1", och ritar sedan histogrammet och ställer in lagerplatserna på Efter kategori.

    Automatiskt

    Det här är standardinställningen för histogram.

    Fackbredd

    Ange ett positivt decimaltal för antalet datapunkter i varje intervall.

    Antal lagerplatser

    Ange antalet lagerplatser för histogrammet (inklusive lagerplatserna för spill och underskott).

    Lagerplats för spill

    Markera den här kryss rutan om du vill skapa en lager plats för alla värden ovanför värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimal tal i rutan.

    Fack för värden under (underflow bin)

    Markera den här kryss rutan om du vill skapa en lager plats för alla värden under eller lika med värdet i rutan till höger. Om du vill ändra värdet anger du ett annat decimal tal i rutan.

    Åtgärdsfönstret Formatera axlar

Tips: Om du vill veta mer om diagrammet histogram och hur du visualiserar statistik data kan du läsa det här blogg inlägget i histogram-, Pareto-och låddiagram från Excel-teamet. Du kanske också är intresse rad av andra nya diagram typer som beskrivs i det här blogg inlägget.

Följ de här stegen för att skapa ett histogram i Excel för Mac:

  1. Välj data.

    (Det här är ett typiskt exempel på data för ett histogram.)

    Data som används för att skapa exempelhistogrammet ovan
  2. Klicka på fliken Infoga i menyfliksområdet och klicka sedan på Ikonen statistik diagram (statistisk ikon) och välj histogramunder histogram.

Tips: 

  • Använd flikarna diagram design och format för att anpassa diagrammets utseende.

  • Om flikarna diagram design och format inte visas klickar du någonstans i histogrammet för att lägga till dem i menyfliksområdet.

Om du vill skapa ett histogram i Excel 2011 för Mac måste du ladda ned ett tillägg från tredje part. Se: jag hittar inte Analysis ToolPak i Excel 2011 för Mac för mer information.

I Excel Online kan du visa ett histogram (ett stapeldiagram som visar frekvens data), men du kan inte skapa det eftersom det kräver Analysis ToolPak, ett Excel tillägg som inte stöds i Excel Online.

Om du har Excel-programmet kan du använda knappen Redigera i Excel för att öppna Excel på Skriv bordet och skapa histogrammet.

Knappen Redigera i Excel

  1. Tryck för att markera dina data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du använder en telefon trycker du på ikonen Redigera Ikonen Redigera för att Visa menyfliksområdet. och sedan på Start.

  3. Tryck på infoga > diagram > histogram.

    Om det behövs kan du anpassa diagrammets element.

    Obs!: Den här funktionen är endast tillgänglig om du har en Office 365-prenumeration. Om du har en prenumeration på Office 365 ska du kontrollera att du har den senaste versionen av Office.

    Prova Office 365 eller den senaste versionen av Excel

  1. Tryck för att markera dina data.

    Data som används för att skapa exempelhistogrammet ovan
  2. Om du använder en telefon trycker du på redigerings ikonen Ikonen Redigera för att Visa menyfliksområdet och sedan på Start.

  3. Tryck på infoga > diagram > histogram.

Du kan skapa ett histogram i Excel genom att ange två typer av data – de data som du vill analysera och de lager plats nummer som representerar de intervall som du vill mäta frekvensen för. Du måste ordna data i två kolumner i kalkyl bladet. Dessa kolumner måste innehålla följande data:

  • Ange data    Det här är de data som du vill analysera med Histogram-verktyget.

  • Lager plats nummer    De här talen representerar de tidsintervall som du vill att histogrammet ska använda för att mäta indata i data analysen.

När du använder verktyget histogram räknar Excel antalet data punkter i varje data lager plats. En data punkt är inkluderad på en viss lager plats om numret är större än det lägsta gräns värde som är lika med eller mindre än det högsta gräns värdet för data lager platsen. Om du utelämnar lager plats Excel området skapas en uppsättning jämnt fördelade lager platser mellan minimi-och maximivärden för indata.

Resultatet av analys av histogram visas i ett nytt kalkyl blad (eller i en ny arbets bok) och visar en tabell med histogram och ett stapeldiagram som visar data i histogramm tabellen.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community, få support i Answers-communityn eller föreslå en ny funktion eller förbättringar på Excel User Voice.

Obs!:  Den här sidan har översatts automatiskt och kan innehålla grammatiska fel och andra felaktigheter. Vår avsikt är att innehållet ska vara användbart för dig. Skulle du vilja svara på om informationen var till hjälp? Här är den engelska artikeln som en referens.

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×