Office
Logga in

Skapa ett datavisualiserardiagram

Obs!:  Vi vill kunna erbjuda dig bästa möjliga supportinnehåll så fort som möjligt och på ditt språk. Den här sidan har översatts med hjälp av automatiserad översättning och kan innehålla grammatiska fel eller andra felaktigheter. Vår avsikt är att den här informationen ska vara användbar för dig. Vill du berätta för oss om informationen är till hjälp längst ned på sidan? Här är artikeln på engelska som referens.

Vill du automatiskt skapa ett detaljerat och stilrent Visio-flödesschema från en Excel-arbetsbok? Du kan göra det med hjälp av mallarna för datavisualisering. Alla mallar har en associerad Excel-arbetsbok som används för att konvertera processdata till ett flödesschema i Visio. Du kan också använda en egen anpassad Excel-mall, mappa Excel-data till former med guiden Skapa diagram från data och automatiskt skapa diagrammet. Du kan även lägga till fler kolumner med data i Excel som konverteras till Visio-formdata.

Visio har också stöd för tvåvägssynkronisering mellan Visio-diagrammet och Excel-arbetsboken. Du kan inte bara skapa flödesschema, utan genom att redigera data i Excel och uppdatera diagrammet från Visio kan du också göra ändringar i Visio-diagrammet och sedan uppdatera Excel-data i diagrammet. 

Översikt över datavisualiserare

Möjligheten att använda datavisualiserarmallar är endast tillgänglig med Visio Online abonnemang 2 på utgivningskanalen Aktuell. Om du inte är säker på vilken version av Visio du använder väljer du Arkiv > Konto > Om Visio. Se Visio Online abonnemang 2 om du vill veta mer om prenumerationsversionen av Visio.

Om du inte ser datavisualiserarmallarna eller har andra frågor om att komma igång går du till sidan Vanliga frågor och svar om Datavisualiseraren.

Obs!: Om du vill använda den här funktionen måste du ha en Office 365-prenumeration. Om du har en prenumeration på Office 365 bör du kontrollera att du har den senaste versionen av Office. Om du är IT-ansvarig och hanterar Office 365-uppdateringsprocessen rekommenderar vi att du tar en titt på kanalutgivningssidan. Där kan du se vilka uppdateringar som tillhandahålls i de olika kanalerna.

Artikelinnehåll

Skapa ett datavisualiserardiagram

Innan du börjar

Samla ihop dina idéer och arbeta med dem som ett utkast på papper eller som pennanteckning. Det här första utkastet kan hjälpa dig att snabbt få igång arbetet och göra de följande stegen smidigare.

Om du vill skapa ett datavisualiserardiagram kan du arbeta samtidigt i Excel och Visio. Det kan vara enklare att arbeta i två fönster på din Windows-enhet eller i en miljö med flera bildskärmar. När du visuellt kan jämföra arbetet mellan Excel och Visio ser du lättare att du gör vad du har för avsikt att göra.

Rekommenderas    Titta på det här Microsoft Office-videoklippet om du vill se det i praktiken: Datavisualiserare: Demo.

Fas 1: Välj en datavisualiserarmall

  1. Öppna Visio eller välj Arkiv > Nytt om du redigerar ett diagram.

  2. Välj MALLAR.

    Kommandot MALLAR
  3. Välj Flödesschema.

    Kommandot Flödesschema
  4. Välj enkelt flödesschema - Data Visualizer, Korsfunktionellt flödesschema - Data Visualizer eller revisionsdiagram - Data Visualizer.

    Datavisualiserarmallar

    En datavisualiserarmall har en Excel-ikon i det övre vänstra hörnet.

Mer information om flödesscheman och deras former finns i Skapa ett enkelt flödesschema och Skapa ett korsfunktionellt flödesschema.

Fas 2: Skapa en Excel-arbetsbok

  1. Välj Excel-datamall i förhandsgranskningen av mallen.

    Välja länken Excel-datamall

    Observera    att om du vill använda samma urval Excel-mallar som används i den här artikeln för referens, kan du ladda ned dem med länkarna nedan:

  2. Välj Arkiv > Spara, ange dator, nätverksserver eller SharePoint-dokumentbibliotek, ange ett filnamn och välj sedan Spara.

  3. Om du vill lägga till ett nytt kalkylblad längst ned i arbetsboken väljer du Nytt blad Knappen Nytt blad .

  4. Skapa en Excel-tabell. Mer information om hur du använder Excel-tabeller finns i Översikt över Excel-tabeller, Skapa eller ta bort en Excel-tabell och Ändra storlek på en tabell genom att lägga till eller ta bort rader och kolumner.

  5. Lägga till kolumner och rader i tabellen som används för att skapa Visio-diagrammet. Det finns särskilda villkor för kolumnrubriker i Excel och värden. Använd avsnittet hur Excel-kolumnerna interagera med Visio-flödesschema komponenter som en visuell guide.

Fas 3: Lägg till ytterligare formdata i Excel-tabellen (valfritt)

  1. Undersök fliken Processkarta i Excel-mallen. Kolumnerna i Excel-tabellen har färgerna blå och grön. Färgen ger en visuell ledtråd om skillnaden mellan kolumnerna.

    De blå kolumnerna används för att skapa flödesschemat i Visio-diagrammet. Alla kolumner läggs också till som formdata.

  2. Om du vill lägga till ytterligare formdata kan du lägga till en eller flera kolumner i Excel-tabellen.

    De gröna kolumnerna indikerar ytterligare formdata som du kan lägga till i varje form. Du kan lägga till valfritt antal ytterligare kolumner. Som standard är inte dessa data synliga i diagrammet, om du inte lägger till datagrafik. Om du vill visa formdata i Visio-diagrammet väljer du Data > Formdatafönster. Mer information om formdata och datagrafik finns i Lägga till data i former och Datagrafik, en översikt.

Fas 4: Skapa ett Visio-diagram med guiden

  1. Gå tillbaka till Visio och välj din måttenhet i förhandsgranskningen av mallen och välj sedan Skapa.

  2. Gör följande på den första sidan i guiden Skapa diagram från data:

    1. Välj en mall under Vilket diagram vill du skapa från data: Enkelt flödesschema, Korsfunktionellt flödesschema (vågrätt) eller Korsfunktionellt flödesschema (lodrätt).

    2. Välj en arbetsbok i en lista över de senast använda arbetsböckerna under Välj Excel-arbetsboken eller välj Bläddra och leta reda på den arbetsbok som du skapade i fas 2.

    3. Välj tabellen som innehåller dina Excel-processdata under Välj en tabell eller ett anpassat område i arbetsboken.

    4. Välj Slutför. Då godkänns alla standardvärden som Visio fyller i för de andra sidorna i guiden.

Därmed skapas diagrammet automatiskt i en behållare. Beroende på storleken på flödesschemat läggs ytterligare Visio-sidor till.

Fas 5: Spara Visio-diagrammet

  • Välj Arkiv > Spara, leta reda på en plats, ange ett filnamn och välj sedan Spara.

Det är en bra idé att ha Excel- och Visio-filerna på samma plats eftersom de samverkar.

Fas 6: Synkronisera data och diagram

När du har skapat ett diagram med datavisualiseraren kanske du vill göra ändringar i det. Visio har stöd för dubbelriktad synkronisering mellan källdata och diagrammet.

Tips    Behåll båda filerna synkroniserade och uppdaterade när du är klar med dem. Uppdatera diagrammet när du ändrar Excel-data: uppdatera Excel-data när du ändrar diagrammets innehåll.

Ändra data i Excel och sedan uppdatera diagrammet

  1. Ändra källdata i Excel-tabellen. Du kan lägga till, uppdatera eller ta bort rader.

  2. Spara Excel-arbetsboken.

  3. I Visio aktiverar du fliken Dataverktygsdesign i menyfliksområdet genom att klicka i diagrambehållaren och sedan välja Uppdatera diagram.

Resultatet blir att ändringar du gjort i Excel-arbetsboken visas i Visio-diagrammet. Obs!

  • Om du har gjort ändringar i diagrammet som kan gå förlorade när du har uppdaterat, visas dialogrutan Konflikt vid uppdatering av diagram i Visio.

  • Uppdateringen ändrar endast former och anslutningar i behållaren.

  • Alla formateringsändringar som du gör för former och kopplingar i behållaren bevaras.

  • Se till att ha alla diagramformer och kopplingslinjer i behållaren. Andra objekt på sidan som är utanför behållaren påverkas inte. Mer information om behållare finns i Förtydliga strukturen i diagram med hjälp av behållare och listor.

Ändra diagrammets innehåll och uppdatera sedan Excel-data

  1. Göra ändringar i Visio-diagrammet. Du kan lägga till, uppdatera eller ta bort former och kopplingar.

  2. Om Excel-arbetsboken finns på en stationär dator eller en nätverksserver ska du kontrollera att den har sparats och stängts.

  3. Aktivera fliken Dataverktygsdesign i menyfliksområdet genom att klicka i diagrambehållaren och sedan välja Uppdatera källdata.

Resultatet blir att ändringar du gjort i Visio-diagrammet uppdateras i Excel-arbetsboken . Om data går förlorade i Excel visas dialogrutan Konflikt med att uppdatera källdata i Visio. Undvik problem genom att följa metodtipsen:

  • Spara en säkerhetskopia av Excel-data innan du skriver över ändringarna.

  • Använd en Excel-tabell som datakälla, inte ett anpassat område, i Excel-arbetsboken. När du har valt Skriva över i dialogrutan Uppdatera källdata omvandlar Visio det anpassade området i en Excel-tabell.

  • Använd inte formler i Excel-datakällan. Efter att du valt Skriv över i dialogrutan Uppdatera källdata omvandlar Visio formeln till formelresultatet.

  • Du har skapat diagrammet med hjälp av följande alternativ i guiden Skapa diagram från data, där datakolumner mappas till funktioner och faser: Mappa > Fler alternativ > Behåll ordningen på kolumnvärdena från dina data för att skapa > Välj funktion eller Banor eller Välj fas eller tidslinje. I det här fallet kräver Visio ytterligare en kolumn i dina data som representerar kopplingen mellan formerna. När du har valt Skriv över i dialogrutan Uppdatera källdata kan den extra kolumnen läggas till.

  • Du har skapat ett korsfunktionellt flödesschema med båda banor och faser baserade på ordningen på datavärden i Excel. Du har skapat diagrammet med hjälp av följande alternativ i guiden Skapa diagram från data, där datakolumner kopplas till processteg och -aktiviteter: Mappning > Specificera hur processteg/-aktiviteter ska kopplas > Koppla sekventiellt. I det här fallet kräver Visio ytterligare en kolumn i dina data som representerar kopplingen mellan formerna. Om du ändrar ordning på banor eller faser i diagrammet ändras ordningen i datakällan. När du har valt Skriv över i dialogrutan Uppdatera källdata följer banorna och faserna i diagrammet inte längre dataordningen i Excel-arbetsboken.

Fas 7: Anpassa interaktionen mellan Excel-tabellen och Visio-diagrammet (valfritt)

Det finns tillfällen då du kanske vill anpassa skapandet av dina datavisualiserardiagram. Du kanske till exempel vill använda olika former för att uppfylla din organisations standarder, eller mappa till olika kolumnnamnen i Excel-tabellen.

  1. När du väljer Skapa för att öppna guiden Skapa diagram från data och du har angett värden på första sidan (se fas 4) väljer du Nästa eller Tillbaka för att visa varje sida i guiden.

  2. Välj Hjälp (?) för mer information om hur du anpassar varje alternativ på sidan. Mer information finns i Använda guiden Skapa diagram från data.

Överst på sidan

Hur Excel-kolumner interagerar med Visio-flödesschemakomponenter

Använd följande bildgenomgång för att förstå hur varje Excel-kolumn används för att skapa Visio-flödesschemat.

Processteg-ID   Ett tal som identifierar varje form i flödesschemat. Den här kolumnen är obligatorisk och varje värde i Excel-tabellen måste vara unikt och får inte vara tomt. Det här värdet visas inte i flödesschemat.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: Processteg-ID

Beskrivning av processteg   Text som läggs till i varje form i flödesschemat.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: Beskrivning av processteg

ID för nästa steg   Processteg-ID för nästa form i sekvensen. En förgreningsform har två nästa steg och representeras av kommaavgränsade tal, till exempel 4,5. Du kan ha fler än två nästa steg.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: ID för nästa steg

Kopplingsetikett   För förgreningsformer representeras kopplingsetiketter som text avgränsad med ett kommatecken, till exempel Ja,Nej. Ja motsvarar 4 och Nej motsvarar 5 i exemplet.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: Kopplingsetikett

Formtyp   Den formtyp som du vill representera i Visio-diagrammet, till exempel Process eller Beslut. Microsoft rekommenderar att du använder listrutor för att verifiera dina val.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: Formtyp

Funktion och fas    Den funktion (eller simbana) och fas (eller tidslinje) som varje form tillhör. Den här kolumnen gäller endast för ett korsfunktionellt flödesschema och ignoreras i ett enkelt flödesschema.

Interaktion mellan Excel-processkartan och Visio-flödesschemat: Funktion och fas

Överst på sidan

Använda andra stenciler för att skapa ett datavisualiserardiagram

Förutom Data Visualizer-mallar kan använda du också stenciler från andra mallar när du skapar ett diagram som Data Visualizer. Till exempel Skapa processdiagram för ekonomiska transaktioner och lagerhantering. Det finns andra processorienterade stenciler inklusive BPMN grundläggande och arbete Flow objekt mallar. Du kan även lägga till egna former med hjälp av Mina former-stencil. Mer information finns i Skapa, spara, och dela egna stenciler.

  1. Öppna ett datavisualiserardiagram (enkelt flödesschema eller korsfunktionellt flödesschema) som du redan har skapat.

  2. Välj Skapa för att öppna guiden Skapa diagram från data och när du har angett värden på första sidan väljer du Nästa tills sidan Forma mappning visas i guiden.

  3. Lägg till en eller flera stenciler med hjälp av alternativet Fler former.

  4. Markera en form och mappa till datavärden för kolumnen Formtyp genom att dra den.

Överst på sidan

Använda datagrafik i diagram

Du kan förbättra diagrammet genom att lägga till datagrafik, som kan synliggöra formdata i diagrammet. I praktiken kan du förvandla diagrammet till en instrumentpanel för processen där datagrafiken visar prestationsindikatorer med hjälp av ikoner baserat på dina formdata.

  1. Öppna datavisualiserardiagrammet.

    Välj den behållare för vilken du vill använda datagrafik.

  2. Välj Data > Datagrafikfält.

  3. Markera de datagrafikfält du vill lägga till i diagrammet.

    Använda datagrafik för Visio-datavisualiserardiagram

    Datagrafik tillämpas på hela diagrammet. Om du vill dölja datagrafik för vissa former ska du behålla datakolumnvärdena tomma i Excel-arbetsboken för dessa rader.

  4. Om du vill kan du ange ytterligare alternativ på fliken Data. Mer information finns i Datagrafik, en översikt.

Överst på sidan

Nästa steg

Här är några uppgifter som du kanske vill utföra när du har skapat ett datavisualiserardiagram.

  • Teman    Ett tema i Visio är en uppsättning färger och effekter som du kan lägga till i en ritning med en enkel klickning. Med teman kan du snabbt skapa ritningar med en professionell design. Mer information finns i Skapa ritningar med ett professionellt utseende med teman.

  • Layout    I Visio finns instruktioner och automatiska verktyg vars funktion är att se till att formerna i diagrammen är rätt justerade och har rätt avstånd till varandra. Det får ritningen att bli så tydlig som möjligt och ger den ett välordnat utseende. Mer information finns i Justera och placera former i ett diagram.

  • Exportera    Du kan exportera ett datavisualiserardiagram med tillhörande Excel-arbetsbok till ett Visio-mallpaket (.vtpx). I ett Visio-mallpaket sparas diagraminställningar, stenciler och data så att andra får en startpunkt när de snabbt vill skapa egna datavisualiserardiagram. Andra användare kan installera mallpaketet lokalt. Mer information finns i Exportera och installera ett mallpaket för Datavisualiserare.

Överst på sidan

Utöka dina Office-kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×