Skapa en pivottabell med en extern datakälla

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

Möjligheten att analysera alla data kan hjälpa dig att göra bättre affärsbeslut. Men ibland kan det vara svårt att veta var man ska börja, speciellt om du har stora datamängder som lagras utanför Excel, till exempel en Microsoft Access eller Microsoft SQL server-databas, eller en OLAP-kubfil (Online Analytical Processing). I så fall kan du ansluta till den externa datakällan och sedan skapa en pivottabell för att summera, analysera, upptäcka och presentera data.

Så här skapar du en pivottabell genom att använda en befintlig extern dataanslutning:

  1. Klicka på en cell i kalkylbladet.

  2. Klicka på Infoga > Pivottabell.

    Knappen Pivottabell på fliken Infoga

  3. Klicka på Använd en extern datakälla i dialogrutan Skapa pivottabell under Välj de data som du vill analysera.

    Dialogrutan Skapa pivottabell med Använd en extern datakälla markerat

  4. Klicka på Välj anslutning.

  5. Låt Alla anslutningar vara markerat i rutan Visa på fliken Anslutningar eller välj den anslutningskategori med den datakälla du vill ansluta till.

Om du vill återanvända eller dela en befintlig anslutning använder du en anslutning från Anslutningar i den här arbetsboken.

  1. Välj den anslutning du vill ha i listan med anslutningar och klicka sedan på Öppna.

  2. Välj en plats under Välj var du vill att pivottabellrapporten ska placeras.

    • Om du placerar en pivottabell i ett nytt kalkylblad som startar på cell A1 väljer du Nytt kalkylblad.

    • Om du vill placera pivottabellen i det aktiva kalkylbladet väljer du På detta kalkylblad och anger sedan den cell där du vill att pivottabellen ska börja i rutan Plats.

  3. Klicka på OK.

    Excel lägger till en tom pivottabell och visar fältlistan så att du kan Visa de fält som du vill använda och Ordna om dem om du vill skapa en egen layout.

    Fältlistan som visar externa datafält

  4. Markera rutan bredvid ett fältnamn i fältlistan för att placera fältet i ett standardområde i områdesavsnittet för Fältlistan.

    Vanligtvis läggs ickenumeriska fält till i området Rader, numeriska fält i området Värden och datum- och tidfält läggs till i området Kolumner. Du kan flytta fält till andra områden om du behöver.

    Tips:  Du kan också högerklicka på ett fältnamn och sedan markera Lägg till i rapportfilter, Lägg till i kolumnetiketter, Lägg till i radetiketter eller Lägg till i värden för att placera fältet i områdesavsnittet eller dra ett fält från fältavsnittet till ett område i områdesavsnittet.

    Använd Fältlistan för att ytterligare Ändra pivottabelldata genom att högerklicka på fälten i områdesavsnittet och sedan välja det önskade området eller genom att dra fälten mellan områdena i områdesavsnittet.

Ansluta till en ny extern datakälla

Så här skapar du en ny extern dataanslutning SQL-servern och importerar data till Excel som en tabell eller pivottabell:

  1. Klicka på Data > Från andra källor.

Knappen Från andra källor på fliken Data

  1. Klicka på den anslutning du vill ha

    • Klicka på Från SQL Server för att skapa en anslutning till en SQL-Server-tabell.

    • Klicka på Från Analysis Services för att skapa en anslutning till en SQL Server Analysis-kub.

  2. Följ stegen i Guiden Dataanslutning för att skapa anslutningen.

    • Ange databasservern och specificera hur du vill logga in på servern på sida 1.

    • Ange databasen, tabellen eller frågan som innehåller de data du vill ha, på sida 2.

    • Ange anslutningsfilen du vill skapa på sida 3.

Om du vill skapa en ny anslutning till en Access-databas och importera data i Excel som en tabell eller pivottabell gör du följande:

  1. Klicka på Data > Från åtkomst.

Knappen Från åtkomst på fliken Data

  1. Lokalisera den databas du vill ansluta till i dialogrutan Välj datakälla och klicka sedan på Öppna.

  2. Välj den tabell du vill ha i dialogrutan Välj tabell och klicka sedan på OK.

Om det finns flera tabeller markerar du rutan Aktivera markering av flera tabeller så att du kan kryssa i rutorna för de tabeller du vill ha och sedan klickar du på OK.

  1. Välj hur du vill visa data i din arbetsbok och var du vill sätta dem i dialogrutan Importera data och klicka sedan på OK.

Tabellerna är automatiskt läggs till i datamodellenoch Access-databasen läggs till i dina Arbetsboksanslutningar.

Mer information om pivottabeller

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×