Skapa en datamodell i Excel

Viktigt!: Den här artikeln är maskinöversatt, se ansvarsfriskrivningen. Den engelska versionen av den här artikeln finns här för din referens.

En datamodell är en ny metod för att integrera data från flera tabeller effektivt bygga en relationsdatakälla i en Excel-arbetsbok. I Excel används datamodeller transparent, vilket ger tabelldata som används i pivottabeller, pivotdiagram och Power View-rapporter. Innan du dyker ner i information du kanske vill backa ett steg och titta på en video eller vidta vår utbildning för på Get & transformering och Power Pivot.

Obs!: I den här artikeln beskrivs datamodeller i Excel 2013. Samma datamodeller och Power Pivot-funktionerna i Excel 2013 gäller emellertid också för Excel 2016. Det finns effektivt lilla skillnaden mellan följande versioner av Excel.

För det mesta märker du inte ens att datamodellerna finns där. I Excel åskådliggörs de som en samling tabeller i en fältlista. Om du vill arbeta direkt med en datamodell måste du använda tilläggsprogrammet Microsoft Office Power Pivot i Microsoft Excel 2013.

Om du importerar relationsdata och väljer flera tabeller skapas det en modell automatiskt:

  1. Använd dig av Data > Hämta externa data i Excel för att importera data från Access eller någon annan relationsdatabas som innehåller flera relaterade tabeller.

  2. Uppmanas du att markera en tabell. Markera Aktivera markering av flera tabeller.

    Dialogrutan Välj tabell

  3. Markera två eller fler tabeller, klicka på Nästa och sedan på Slutför.

  4. Välj önskat datavisualiseringsalternativ i Importera data, t.ex. en pivottabell i ett nytt blad, och skapa rapporten.

Nu har du en datamodell som innehåller alla tabeller som du importerat. Eftersom du har valt alternativet Pivottabellrapport finns modellen med i den fältlista som du sedan använder för att skapa en pivottabellrapport.

Listan Pivottabellfält

Vad kan du göra med den här modellen? Du kan använda den för att skapa pivottabeller, pivotdiagram och Power View-rapporter i samma arbetsbok. Du kan ändra den genom att lägga till eller ta bort tabeller. Och om du använder Power Pivot-tilläggsprogrammet kan du även utöka modellen genom att lägga till beräknade kolumner, beräknade fält, hierarkier och KPI:er.

Visualiseringsalternativet är viktigt när du skapar en datamodell. Du kan välja Pivottabellrapport, Pivotdiagram eller Power View-rapport för datavisualisering. Dessa alternativ gör det möjligt att arbeta med alla tabellerna tillsammans. Om du istället hade valt Tabell hade alla importerade tabeller placerats i ett separat blad. Genom att ordna tabellerna så här kan de användas individuellt, men för att kunna använda alla tabellerna tillsammans krävs en pivottabell, ett pivotdiagram eller en Power View-rapport.

Meddelanden: 

  • Modeller skapas på implicit väg om du importerar två eller fler tabeller till Excel på samma gång.

  • Modeller skapas uttryckligen när du använder tillägget Power Pivot för att importera data. I tillägget representeras modellen i layouten med flikar, där varje flik innehåller tabelldata. Finns i Hämta data med hjälp av Power Pivot-tilläggsprogrammettill grunderna för import av data med hjälp av en SQL Server-databas.

  • En modell kan innehålla en enda tabell. Om du vill skapa en modell som bygger på en enda tabell markerar du tabellen och klickar på Lägg till i datamodell i Power Pivot. Det kan du göra om du vill använda Power Pivot-funktioner, till exempel filtrerade datamängder, beräknade kolumner, beräknade fält, KPI:er och hierarkier.

  • Tabellrelationer kan skapas automatiskt om du importerar relaterade tabeller som har primär- och sekundärnyckelrelationer. Excel kan normalt använda den importerade relationsinformationen som grund för tabellrelationer i datamodellen.

  • Tips på hur du minskar storleken på en datamodell finns i Skapa en minneseffektiv datamodell med Excel 2013 och tillägget PowerPivot.

  • Mer information finns i självstudiekurs: analysera pivottabelldata med en datamodell i Excel 2013.

Tips: Arbetsboken innehåller data, men vet du om det innehåller en datamodell? Du kan snabbt se modellen status genom att öppna fönstret Power Pivot. Om data visas på flikarna, finns en modell. Mer information om att Ta reda på vilka data som källor som används i en arbetsboks datamodell.

Använda en datamodell i en annan pivottabell, pivotdiagram eller Power View-rapport

En Excel-arbetsbok kan endast innehålla en datamodell, men den modellen kan användas flera gånger i arbetsboken.

  1. Klicka på Infoga > Pivottabell i Excel.

  2. I Skapa pivottabell klickar du på Använd en extern datakälla och klickar sedan på Välj anslutning.

  3. I Befintlig anslutning klickar du på Tabeller.

  4. Under Den här arbetsbokens datamodell är Tabeller i arbetsbokens datamodell markerat som standard. Klicka på Öppna och sedan på OK. En fältlista för pivottabellen öppnas och visar alla tabeller i modellen.

Lägga till befintliga, orelaterade data i en datamodell

Anta att du har importerat eller kopierat stora mängder data som du vill använda i en modell, men att du inte markerade rutan Lägg till dessa data i datamodellen under importen. Det är enklare att lägga till nya data i en modell än du tror.

  1. Börja med de data som du vill lägga till i modellen. Det kan vara ett datumintervall, men ett namngivet område fungerar bäst.

  2. Markera de celler som du vill lägga till, eller placera markören i en cell om dina data finns i en tabell eller i ett namngivet område.

  3. Lägg till data med någon av följande metoder:

  4. Klicka på Power Pivot > Lägg till i datamodell.

  5. Klicka på Infoga > Pivottabell och markera Lägg till dessa data i datamodellen i dialogrutan Skapa pivottabell.

Området eller tabellen nu läggs till i modellen som en länkad tabell. Mer information om hur du arbetar med länkade tabeller i en modell finns i Lägga till Data genom att använda Excel länkade tabeller i Power Pivot.

Förfina och utöka datamodellen i Power Pivot-tilläggsprogrammet

Datamodellerna i Excel förstärker och förbättrar rapporteringsmiljön, särskilt när miljön omfattar pivottabeller eller andra rapportformat som är avsedda för datautforskning och analys. Datamodellerna är viktiga, men finns i bakgrunden så att du kan fokusera på det som du vill göra med dem.

Men anta att du faktiskt vill arbeta direkt med modellen. Om du vet att fältlistan baseras på en modell vill du kanske ta bort olika tabeller och fält som är överflödiga i listan, eller också vill du kanske visa alla underliggande data som finns i modellen. Du kan också vilja lägga till KPI:er, hierarkier och affärslogik. Det här är bara några anledningar till att du kan vilja göra ändringar direkt i datamodellen.

Om du vill ändra eller hantera datamodellen måste använda tillägget Power Pivot. Tillägget är en del av Office Professional Plus edition av Excel 2013, men aktiverat inte som standard. Mer information om att Starta Power Pivot i Microsoft Excel-tillägg.

Skillnader mellan en tabell i Power Pivot och en tabell i ett blad

I Power Pivot kan du lägga till en rad i en tabell genom att skriva direkt på en ny rad som du kan göra i ett Excel-kalkylblad. Men du kan lägga till rader genom att använda klistra in och Uppdatera data.

Data i ett Excel-kalkylblad är ofta variabla och inkonsekventa, d.v.s. en rad kan innehålla numeriska data medan nästa rad innehåller en bild eller textsträng. En tabell i Power Pivot fungerar däremot mer som en relationsdatabas, där varje rad har samma antal kolumner och de flesta kolumnerna innehåller data.

Använda datamodellen i Power View

En datamodell används som grund för en Power View-rapport. Med hjälp av Power Pivot-tilläggsprogrammet kan du använda optimeringar i modellen som förbättrar Power View-rapporteringen. Optimeringarna omfattar att ange en standardfältlista, välja representativa fält eller bilder som identifierar specifika rader unikt eller ange hur rader med upprepade värden (t.ex. anställda eller kunder med samma namn) ska hanteras i ett rapportprogram.

  1. Skapa en datamodell genom att importera flera relaterade tabeller.

  2. Klicka på Power Pivot > Hantera för att öppna Power Pivot-fönstret.

  3. Markera en tabell och tillämpa optimeringar:

    1. Klicka på Avancerat > Standardfältuppsättning. Välj de fält som ska visas automatiskt i en Power View-rapport när du klickar på den överordnade tabellen. Mer information finns i Konfigurera Standardfältuppsättning för Power View-rapporter .

    2. Klicka på Avancerat > Tabellfunktioner. Optimera för rapportlayouter som gruppera data. Gruppering omfattas av standardbeteenden som ibland tillverkas oväntade resultat, till exempel konsolidera rader som ska stå separat. Mer information finns i Konfigurera Tabellbeteendeegenskaper för Power View-rapporter .

    3. Klicka på Avancerat > Datakategori. Vissa rapportvisualiseringar är specifika för särskilda typer av data. Om du till exempel har en tids- eller datumbaserad tabell kan du tilldela en datumkategori som hjälper Power View med tidsbaserade visualiseringar.

  4. Upprepa för andra tabeller.

  5. I Excel klickar du på Infoga > Power View om du vill starta en ny rapport. Se Power View: Utforska, visualisera och presentera dina data för mer information.

Obs!: Ansvarsfriskrivning för maskinöversättning: Den här artikeln har översatts av ett datorsystem utan mänsklig inblandning. Microsoft erbjuder dessa maskinöversättningar för att hjälpa icke engelskspråkiga användare att ta del av information om Microsofts produkter, tjänster och tekniker. Eftersom artikeln är maskinöversatt kan den innehålla fel i ordval, syntax och grammatik.

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×