Skapa eller redigera CSV-filer som ska importeras till Outlook

Skapa eller redigera CSV-filer som ska importeras till Outlook

En CSV-fil är en fil med kommaavgränsade värden. När text och tal sparas i en CSV-fil är det enkelt att flytta dem från ett program till ett annat. Du kan t.ex. exportera kontakter från Google i CSV-format och sedan importera dem till Outlook.

CSV-filer kan användas med Excel och andra kalkylprogram. CSV-filer skiljer sig från andra typer av kalkylbladsfiler på så sätt att du inte kan spara någon formatering och inte heller några formler.

Ladda ned och öppna en exempelfil i .csv-format för att importera kontakter till Outlook

  1. Ladda ned den här exempelfilen i .csv-format. När du blir uppmanad att välja, väljer du att spara filen på datorn som en CSV-fil. Om du sparar den som en Excel-fil (.xls eller .xlsm) kommer alla data att hamna i en enda kolumn!

    När du laddar ned exempelfilen i .csv-format sparar du den på datorn som en CSV-fil.

  2. Öppna Excel på datorn.

  3. Gå till Arkiv > Öppna > i Excel och navigera sedan till den CSV-fil du just laddat ned till datorn. Om du vill söka efter CSV-filen bör du söka i Alla filer. Öppna CSV-filen genom att klicka på den.

    Om du vill söka efter CSV-filen bör du söka efter Alla filer.

Det finns några saker att tänka på när du arbetar med den här exempelfilen i .csv-format:

  • Ersätt inte kolumnrubrikerna på den första raden eftersom Outlook behöver dem.

    Så här ser exempelfilen i .csv-format ut i Excel.

  • Du kan ta bort data på raderna 2-6 (exempelnamnen, telefonnumren, e-postadresserna osv.).

  • Du behöver inte ange värden för varje kolumn. Ange bara den information du vill ha.

  • Spara filen med ett nytt namn och filtypen CSV (.csv). Om du använder Excel för att redigera filen uppmanas du några gånger att bekräfta att du vill spara den i CSV-format när du sparar. Välj alltid Ja. Om du väljer Nej blir filen oanvändbar och du måste börja om med en ny exempelfil.

  • Prova att importera din .csv-fil med bara några få kontakter för att säkerställa att du är nöjd med resultatet. Du kan sedan ta bort de importerade kontakterna, lägga till fler i .csv-filen och importera igen.

    Om du vill importera data i .csv-filen ska det se ut så här i Office 365 Outlook på webben:

    När du har importerat kontakter ser de ut så här i Outlook på webben.

Redigera en CSV-fil med kontakter som du vill importera till Outlook

Anta att du vill redigera en .csv-fil som du har exporterat från Outlook och sedan importera tillbaka den till Outlook eller en annan e-postleverantör. Med hjälp av Excel är det enkelt att redigera .csv-filen.

Här är några saker att komma ihåg när du redigerar en .csv-fil:

  • Behåll kolumnrubrikerna på den första raden.

  • När du sparar filen uppmanas du några gånger att bekräfta att du vill spara den i .csv-format. Välj alltid Ja. Om du väljer Nej blir filen oanvändbar och du måste börja om igen.

Problem: Alla data visas i den första kolumnen

Ett exempel på en CSV-fil som sparats i .xls-format.

Här är några anledningar till varför detta händer och tips om hur du kan försöka lösa problemet:

  • Om du sparar CSV-filen i ett annat format, t.ex. .xls eller .xlm, visas alla data i den första kolumnen. Gå tillbaka till den ursprungliga CSV-filen och se till att spara den i .csv-format.

  • Det är möjligt att programmet som CSV-filen skapas i lägger till extra citationstecken i dina data. Det leder till att dina data behandlas som en enhet i Excel. Anta t.ex. att dina data ser ut så här:

    a, b, c, d - Excel lägger in de olika bokstäverna i varsin egen kolumn.

    "a, b, c, d", e - Excel placeras a,b,c,d i en kolumn och e i en annan kolumn.

    Ta reda på om det är detta som är problemet med filen genom att öppna den i Anteckningar: Högerklicka på CSV-filen i Windows, välj Öppna med > Anteckningar. Sök efter extra citattecken.

    Om du hittar extra citationstecken gör du så här:

    1. Använd Excel för att öppna CSV-filen. Alla data visas då i kolumn A och citationstecken är borta.

    2. Använd nu guiden Text till kolumner för att dela in data i kolumn A i enskilda kolumner: välj Data > Text till kolumner på menyraden.

      Klicka på Data > Text till kolumner

    3. Välj Avgränsade > Nästa. Välj sedan Kommatecken > Slutför.

    4. Spara filen i .cvs-format så att du fortfarande kan importera den till Outlook.

Mer information finns i

Importera kontakter till Outlook

Exportera kontakter från Outlook

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Office Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×